cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Santhosh Edukulla <santhosh.eduku...@citrix.com>
Subject RE: Review Request 19874: CLOUDSTACK-6793 : Fixed an Invalid Domain Id Issue
Date Fri, 06 Jun 2014 14:02:18 GMT
Hi Daan,

Yes, for master planning additional approach with few more enhancements, useful for future
release. It may require modifying schema, which i believe is not possible for 4.4 because
of code freeze.

Regards
Santhosh
________________________________________
From: Daan Hoogland [daan.hoogland@gmail.com]
Sent: Friday, June 06, 2014 9:58 AM
To: Santhosh Edukulla
Cc: Kishan Kavala; cloudstack
Subject: Re: Review Request 19874: CLOUDSTACK-6793 : Fixed an Invalid Domain Id Issue

Santhosh,

Have you made sure this goes into master as well?


On Fri, Jun 6, 2014 at 3:53 PM, ASF Subversion and Git Services <asfbot@urd.zones.apache.org<mailto:asfbot@urd.zones.apache.org>>
wrote:
This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/19874/


Commit 91d054cb00f6a5818f2be1c7e4d3f44a2c58bfcc in cloudstack's branch refs/heads/4.4-forward
from sedukull
[ https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;h=91d054c ]

CLOUDSTACK-6793: Fixed an invalid Domain Id Issue

Signed-off-by: sedukull <santhosh.edukulla@gmail.com<mailto:santhosh.edukulla@gmail.com>>



- ASF Subversion and Git Services


On June 6th, 2014, 9:28 a.m. UTC, Santhosh Edukulla wrote:

Review request for cloudstack, daan Hoogland and Kishan Kavala.
By Santhosh Edukulla.

Updated June 6, 2014, 9:28 a.m.

Bugs: CLOUDSTACK-6793<https://issues.apache.org/jira/browse/CLOUDSTACK-6793>
Repository: cloudstack-git
Description

1. Added fix to retrieve the correct domain id for a given accountid. vm_template table and
respective vo, does not have a domain id information.
2. Added logic to retrieve correct domainid for a given accountid, only when an invalid domainid
is retrieved. Throw an exception in case of invalid domain id.
3. Now, creation of tags is getting successful post the fix.


Testing

Test creation, listing and deletion tags on UserVM ... === TestName: test_05_vm_tag | Status
: SUCCESS ===
ok
Test creation, listing and deletion tag on templates ... === TestName: test_06_template_tag
| Status : SUCCESS ===
ok
Test creation, listing and deletion tags on ISO ... === TestName: test_07_iso_tag | Status
: SUCCESS ===
ok
Test creation, listing and deletion tagson volume ... === TestName: test_08_volume_tag | Status
: SUCCESS ===
ok



Diffs

  *   engine/schema/src/com/cloud/user/dao/AccountDao.java (2f737cd)
  *   engine/schema/src/com/cloud/user/dao/AccountDaoImpl.java (4bc23ed)
  *   server/src/com/cloud/tags/TaggedResourceManagerImpl.java (fa7fcb7)

View Diff<https://reviews.apache.org/r/19874/diff/>




--
Daan

Mime
View raw message