cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Hoogland <daan.hoogl...@gmail.com>
Subject Re: Regarding Blocker bug CLOUDSTACK-6603
Date Tue, 03 Jun 2014 11:56:09 GMT
if a schema change fixes a bug, yes we can

On Tue, Jun 3, 2014 at 10:58 AM, Rajesh Battala
<rajesh.battala@citrix.com> wrote:
> Hi,
>
>
>
> This bug https://issues.apache.org/jira/browse/CLOUDSTACK-6603 [Upgrade]DB
> Exception while Autoscale monitoring after upgrading from 4.3 to 4.4] got
> introduced by the feature of “Autoscaling without netscaler”
>
>
>
> A new column “last_interval” got added to autoscale_vmgroups table by this
> commit (dc151115be3e922933ea26ab1507eb6469a91e11).
>
> Schema of autoscale_vmgroups table got changed in wrong version of schema
> file cause the upgrade failed.
>
> Instead of adding schema change to the upgrade path file it was added to
> setup/db/db/schema-40to410.sql file. It should be added to schema43to44
> upgrade path.
>
> Because of this issues, upgrade from 4.3 to 4.4 and 4.3 to 4.4 will fail.
>
>
>
> @Tuna, can you please have a look at your commit and fix it.
>
>
>
> @Daan, if this issue CLOUDSTACK-6603 is not fixed, upgrades from 4.2 to 4.4
> and 4.3 to 4.4 will fail.
>
>
>
> As 4.4 feature freeze had happened long back, Am not sure whether we can
> change db schema now in 4.4 branch
>
>
>
>
>
> Thanks
>
> Rajesh Battala



-- 
Daan

Mime
View raw message