cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nux! <...@li.nux.ro>
Subject Re: [cloudmonkey] Doesn't list any network usagerecords
Date Wed, 25 Jun 2014 14:15:27 GMT
Opened https://issues.apache.org/jira/browse/CLOUDSTACK-6993



--
Sent from the Delta quadrant using Borg technology!

Nux!
www.nux.ro


----- Original Message -----
From: "Loic Lambiel" <loic.lambiel@exoscale.ch>
To: "Sebastien Goasguen" <runseb@gmail.com>
Cc: dev@cloudstack.apache.org
Sent: Wednesday, 25 June, 2014 2:19:43 PM
Subject: Re: [cloudmonkey] Doesn't list any network usagerecords

It seems not (we’re purging old usage data)


Loic Lambiel
EXOSCALE Head of Operations
Tel : +41 58 668 56 00
Mail : loic.lambiel@exoscale.ch
--------
Swiss Cloud Services
www.exoscale.ch  <http://www.exoscale.ch/>
--------
exoscale is a brand of Veltigroup SA
Av. de Provence 4 ­ CH 1007 Lausanne
www.veltigroup.com <http://www.veltigroup.com/%22%20%5Ct%20%22_blank>






On 25/06/14 15:02, "Sebastien Goasguen" <runseb@gmail.com> wrote:

>And did you have them in 4.0 ?
>
>On Jun 25, 2014, at 8:52 AM, "Lambiel, Loic" <loic.lambiel@exoscale.ch>
>wrote:
>
>> Hi Guys,
>> 
>> We¹re running 4.3+ (KVM, Basic Networking). I confirm that we do not
>>have
>> any record of type 4 in the usage DB.
>> 
>> Best Regards,
>> 
>> -- 
>> Loic Lambiel
>> EXOSCALE Head of Operations
>> Tel : +41 58 668 56 00
>> Mail : loic.lambiel@exoscale.ch
>> --------
>> Swiss Cloud Services
>> www.exoscale.ch  <http://www.exoscale.ch/>
>> --------
>> exoscale is a brand of Veltigroup SA
>> Av. de Provence 4 ­ CH 1007 Lausanne
>> www.veltigroup.com <http://www.veltigroup.com/%22%20%5Ct%20%22_blank>
>> 
>> 
>> 
>> 
>> 
>> 
>> On 25/06/14 12:45, "sebgoa" <runseb@gmail.com> wrote:
>> 
>>> Let me wrap in Loic, he is running 4.3 with KVM and has usage going.
>>> 
>>> @Loic, do you see usage of type 4 in your cloud usage DB ? the network
>>> data ?
>>> 
>>> thanks,
>>> 
>>> -sebastien
>>> 
>>> On Jun 25, 2014, at 12:29 PM, Nux! <nux@li.nux.ro> wrote:
>>> 
>>>> Hi guys,
>>>> 
>>>> Checked the other emails in users@ re usage, but it does not seem to
>>>>be
>>>> my problem (I have a working connection to mysql, tables are
>>>>populated,
>>>> all tables are there etc). However, the data for types 4 and 5
>>>>(NETWORK
>>>> that is) is missing completely from the DB as I said earlier.
>>>> 
>>>> Here's my cloudmonkey command:
>>>> cloudmonkey list usagerecords
>>>> accountid=2fd94b65-2a2a-47d8-8a03-1d8361d8f042 startdate=2014-06-10
>>>> enddate=2014-06-20 type=4
>>>> 
>>>> 
>>>> And the cloudmonkey log:
>>>> 
>>>> 2014-06-25 11:22:03,166 - requester.py:41 - [DEBUG] ======== START
>>>> Request ========
>>>> 2014-06-25 11:22:03,167 - requester.py:41 - [DEBUG] Requesting
>>>> command=listUsageRecords, args={'startdate': '2014-06-10', 'type':
>>>>'4',
>>>> 'enddate': '2014-06-20', 'accountid':
>>>> '2fd94b65-2a2a-47d8-8a03-1d8361d8f042'}
>>>> 2014-06-25 11:22:03,167 - requester.py:41 - [DEBUG] Request sent:
>>>> 
>>>>https://****************&command=listUsageRecords&enddate=2014-06-20&ex
>>>>pi
>>>> 
>>>>res=2014-06-25T10%3A32%3A03%2B0000&response=json&signatureversion=3&sta
>>>>rt
>>>> date=2014-06-10&type=4&signature=*******************
>>>> 
>>>> Also, while there seems to be some plenty of output for other stuff
>>>> (types 2,3,6,10,13 etc) there is zero for NETWORK (4 and 5)
>>>> cloudmonkey list usagerecords
>>>> accountid=2fd94b65-2a2a-47d8-8a03-1d8361d8f042 startdate=2014-06-10
>>>> enddate=2014-06-20|grep "usagetype = 4" <- this outputs nada.
>>>> 
>>>> Nothing obvious in apilog or management log, there's no exceptions or
>>>> anything.
>>>> 
>>>> I can't redeploy the DB, this is a production setup. But by the looks
>>>> of things it may seem the data does not reach the DB, something goes
>>>> wrong before DB stage.
>>>> 
>>>> Any other pointers?
>>>> 
>>>> --
>>>> Sent from the Delta quadrant using Borg technology!
>>>> 
>>>> Nux!
>>>> www.nux.ro
>>>> 
>>>> 
>>>> ----- Original Message -----
>>>> From: "Rohit Yadav" <rohityadav89@gmail.com>
>>>> To: dev@cloudstack.apache.org
>>>> Sent: Wednesday, 25 June, 2014 11:09:11 AM
>>>> Subject: Re: [cloudmonkey] Doesn't list any network usagerecords
>>>> 
>>>> Hi Lucian,
>>>> 
>>>> Check what Sebastien suggested. In addition:
>>>> 
>>>> - in your ~/.cloudmonkey/log share with us the API/URL called (so we
>>>>can
>>>> check that cloudmonkey is not messing up the request)
>>>> - The type in listUsageRecords API is the hypervisor type, check valid
>>>> hypervisors
>>>> - Run the listUsageTypes APIs to get list of valid usage types
>>>> - Check the logs for exceptions/errors?
>>>> - For your reference:
>>>> 
>>>> 
>>>>https://cwiki.apache.org/confluence/display/CLOUDSTACK/Usage+and+Usage+
>>>>Ev
>>>> ents
>>>> - If it fails again I would recommend you start afresh, redeploy
>>>> database
>>>> (with the usage ones) and make sure usage server runs along with mgmt
>>>> server
>>>> 
>>>> Regards.
>>>> 
>>>> 
>>>> On Wed, Jun 25, 2014 at 3:18 PM, Sebastien Goasguen <runseb@gmail.com>
>>>> wrote:
>>>>> 
>>>>> 
>>>>> On Jun 25, 2014, at 5:37 AM, Nux! <nux@li.nux.ro> wrote:
>>>>> 
>>>>>> Hi,
>>>>>> 
>>>>>> We're trying to get some sort of accounting going on and we're
>>>>>>looking
>>>> at checking the network stats, but while "listVirtualMachines" will
>>>>list
>>>> some minimal stats[1] for running VMs, we were hoping
>>>>"listUsageRecords"
>>>> types 4 & 5 (
>>>>>> NETWORK_BYTES_SENT & RECEIVED) would have some more data, but
alas
>>>> there is none at all, or at least cloudmonkey won't return any:
>>>>>> "list usagerecords accountid=2fd94b65-2a2a-47d8-8a03-1d8361d8f042
>>>> startdate=2014-06-10 enddate=2014-06-20 type=4" only outputs a new
>>>>line.
>>>>>> 
>>>>> 
>>>>> Nux, I think I saw a similar question on users@ couple weeks ago.
>>>>> 
>>>>> Can you help solve this:
>>>>> 
>>>>> -Are the records you expect in the usage db ?
>>>>> -Can you make the api call on the integration port and check that you
>>>>> get
>>>> the data from the db
>>>>> -Check the format of the request in your ~/.cloudmonkey/log to see if
>>>> it's kosher.
>>>>> 
>>>>> 
>>>>> thanks,
>>>>> 
>>>>>> Am I doing something wrong? Also, any way to dump stats for a single
>>>>>> VM
>>>> instead of the whole account?
>>>>>> 
>>>>>> Is anyone aware of any problems with network stats in 4.3
>>>>>> (KVM/ADV+SG)?
>>>>>> 
>>>>>> Lucian
>>>>>> 
>>>>>> 
>>>>>> [1] eg
>>>>>> networkkbsread = 10802368
>>>>>> networkkbswrite = 10943832
>>>>>> 
>>>>>> --
>>>>>> Sent from the Delta quadrant using Borg technology!
>>>>>> 
>>>>>> Nux!
>>>>>> www.nux.ro
>>>>>> 
>>>>> 
>>> 
>

Mime
View raw message