cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yoshikazu Nojima <m...@ynojima.net>
Subject Re: 4.3 system vm template job failing in jenkins
Date Thu, 15 May 2014 06:00:59 GMT
Ian,

I experienced same issue, and I tried your solution, but it doesn't work for me.

Any thoughts on this?

https://github.com/verio-cloudstack/cloudstack/commit/8961c30e34afb34e4697e3ec3c25928e4d585a86

[cloudstack-pullreq-systemvm64] $ /bin/sh -xe /tmp/hudson9072932445266075170.sh
+ sudo apt-get install -y ruby1.9
Reading package lists...
Building dependency tree...
Reading state information...
libaugeas-ruby1.9.1 is already the newest version.
librrd-ruby1.9.1 is already the newest version.
libruby1.9.1 is already the newest version.
libruby1.9.1-dbg is already the newest version.
ruby1.9.1 is already the newest version.
ruby1.9.1-dev is already the newest version.
ruby1.9.1-examples is already the newest version.
libamrita2-ruby1.9.1 is already the newest version.
libbunny-ruby1.9.1 is already the newest version.
libdbd-mysql-ruby1.9.1 is already the newest version.
libdbd-pg-ruby1.9.1 is already the newest version.
libdpkg-ruby1.9.1 is already the newest version.
liberubis-ruby1.9.1 is already the newest version.
libextlib-ruby1.9.1 is already the newest version.
libfcgi-ruby1.9.1 is already the newest version.
libflexmock-ruby1.9.1 is already the newest version.
libgettext-activerecord-ruby1.9.1 is already the newest version.
libhdfeos5-ruby1.9.1 is already the newest version.
libhdfeos5-ruby1.9.1-dbg is already the newest version.
libhtree-ruby1.9.1 is already the newest version.
libimage-size-ruby1.9.1 is already the newest version.
libmapscript-ruby1.9.1 is already the newest version.
liboauth-ruby1.9.1 is already the newest version.
libopen4-ruby1.9.1 is already the newest version.
libpacket-ruby1.9.1 is already the newest version.
libpgsql-ruby1.9.1 is already the newest version.
librack-ruby1.9.1 is already the newest version.
libramaze-ruby1.9.1 is already the newest version.
libraspell-ruby1.9.1 is already the newest version.
libsequel-ruby1.9.1 is already the newest version.
libstfl-ruby1.9.1 is already the newest version.
libsvg-graph-ruby1.9.1 is already the newest version.
libtcltk-ruby1.9.1 is already the newest version.
libuconv-ruby1.9.1 is already the newest version.
libvalidatable-ruby1.9.1 is already the newest version.
libwirble-ruby1.9.1 is already the newest version.
libxapian-ruby1.9.1 is already the newest version.
ruby-amrita2 is already the newest version.
ruby-httpclient is already the newest version.
ruby-hyperestraier is already the newest version.
ruby-mixlib-cli is already the newest version.
ruby-net-scp is already the newest version.
ruby-net-ssh is already the newest version.
ruby-qdbm is already the newest version.
ruby1.9.1-full is already the newest version.
ruby1.9.3 is already the newest version.
uwsgi-plugin-rack-ruby1.9.1 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 36 not upgraded.
+ sudo apt-get install -y qemu-utils
Reading package lists...
Building dependency tree...
Reading state information...
qemu-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 36 not upgraded.
+ sudo apt-get install -y virtualbox
Reading package lists...
Building dependency tree...
Reading state information...
virtualbox is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 36 not upgraded.
+ sudo apt-get install -y build-essential
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 36 not upgraded.
+ sudo apt-get install -y zlib1g-dev libxml2-dev
Reading package lists...
Building dependency tree...
Reading state information...
libxml2-dev is already the newest version.
zlib1g-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 36 not upgraded.
+ sudo gem install bundler
Successfully installed bundler-1.6.2
1 gem installed
Installing ri documentation for bundler-1.6.2...
Installing RDoc documentation for bundler-1.6.2...
[cloudstack-pullreq-systemvm64] $ /bin/sh -xe /tmp/hudson1602043492931564285.sh
+ cd tools/appliance
+ sh ./build.sh systemvm64template
+ [ ! -z systemvm64template ]
+ appliance=systemvm64template
+ date +%Y-%m-%d
+ build_date=2014-05-14
+ branch=master
+ [ -z master ]
+ [ -z master ]
+ rootdir=/var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance
+ bundle
Using rake 10.3.1
Using libxml-ruby 2.7.0
Using CFPropertyList 2.0.17
Using Platform 0.4.0
Using builder 3.2.2
Using gyoku 1.1.1
Using mini_portile 0.5.3
Using nokogiri 1.6.1
Using akami 1.2.2
Using ansi 1.3.0
Using ffi 1.9.3
Using childprocess 0.5.3
Using diff-lcs 1.2.5
Using eventmachine 1.0.3
Using mixlib-log 1.6.0
Using uuidtools 2.1.4
Using gssapi 1.0.3
Using httpclient 2.3.4.1
Using little-plugger 1.1.3
Using multi_json 1.10.0
Using logging 1.8.2
Using rubyntlm 0.1.1
Using rack 1.5.2
Using httpi 0.9.7
Using nori 1.1.5
Using wasabi 1.0.0
Using savon 0.9.5
Using winrm 1.1.3
Using em-winrm 0.5.5
Using excon 0.33.0
Using fission 0.4.0
Using formatador 0.2.4
Using mime-types 1.25.1
Using net-ssh 2.9.0
Using net-scp 1.2.1
Using fog-core 1.22.0
Using fog-json 1.0.0
Using fog-brightbox 0.0.2
Using fog 1.22.0
Using posix-spawn 0.3.8
Using grit 2.5.0
Using highline 1.6.21
Using i18n 0.6.9
Using json 1.8.1
Using open4 1.3.3
Using os 0.9.6
Using popen4 0.1.2
Using progressbar 0.21.0
Using ruby-vnc 1.0.1
Using thor 0.19.1
Using veewee 0.3.12 from https://github.com/jedi4ever/veewee.git (at master)
Using bundler 1.6.2
Your bundle is complete!
Use `bundle show [gemname]` to see where a bundled gem is installed.
+ bundle exec veewee vbox destroy systemvm64template
Shutting down vm systemvm64template
VBoxManage unregistervm  "systemvm64template" --delete
Deleting vm systemvm64template
+ bundle exec veewee vbox build systemvm64template --nogui --auto
Downloading vbox guest additions iso v 4.3.10 -
http://download.virtualbox.org/virtualbox/4.3.10/VBoxGuestAdditions_4.3.10.iso
Checking if isofile VBoxGuestAdditions_4.3.10.iso already exists.
Full path: /var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/iso/VBoxGuestAdditions_4.3.10.iso

The isofile VBoxGuestAdditions_4.3.10.iso already exists.
Building Box systemvm64template with Definition systemvm64template:
- debug : false
- cwd : /var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance
- force : false
- nogui : true
- auto : true
- checksum : false
- redirectconsole : false
- postinstall_include : []
- postinstall_exclude : []
- skip_to_postinstall : false

The isofile debian-7.4.0-amd64-netinst.iso already exists.
Creating vm systemvm64template : 256M - 1 CPU - Debian_64
Creating new harddrive of size 2500, format VDI, variant Standard
Attaching disk: /var/lib/jenkins/VirtualBox
VMs/systemvm64template/systemvm64template1.vdi
Mounting cdrom:
/var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/iso/debian-7.4.0-amd64-netinst.iso
Mounting guest additions:
/var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/iso/VBoxGuestAdditions_4.3.10.iso
Finding unused TCP port in range: 7222 - 7262
Selected TCP port 7222
Finding unused TCP port in range: 7222 - 7262
Selected TCP port 7222
Waiting 10 seconds for the machine to boot
Finding unused TCP port in range: 7122 - 7199
Selected TCP port 7122
Starting a webserver :7122

Typing:[1]: <Esc>
Typing:[2]: install
Typing:[3]: preseed/url=http://10.0.2.2:7122/preseed.cfg
Typing:[4]: debian-installer=en_US
Typing:[5]: auto
Typing:[6]: locale=en_US
Typing:[7]: kbd-chooser/method=us
Typing:[8]: netcfg/get_hostname=systemvm
Typing:[9]: netcfg/get_domain=apache.org
Typing:[10]: fb=false
Typing:[11]: debconf/frontend=noninteractive
Typing:[12]: console-setup/ask_detect=false
Typing:[13]: console-keymaps-at/keymap=us
Typing:[14]: keyboard-configuration/xkb-keymap=us
Typing:[15]: <Enter>
Done typing.

Serving file /var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/definitions/systemvm64template/preseed.cfg
Shutting down for
/var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/definitions/systemvm64template/preseed.cfg
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
..............................................................
Transferring /tmp/.veewee_version20140514-20592-12ytw5o to .veewee_version
..
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Transferring /tmp/.vbox_version20140514-20592-xy4ben to .vbox_version
..
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Transferring /var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/iso/VBoxGuestAdditions_4.3.10.iso
to VBoxGuestAdditions_4.3.10.iso
...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Transferring /tmp/.veewee_params20140514-20592-bhzazi to .veewee_params
..
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Transferring /var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/definitions/systemvm64template/base.sh
to base.sh
..
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Executing command: chmod +x "base.sh"
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Transferring /var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/definitions/systemvm64template/postinstall.sh
to postinstall.sh
..
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Executing command: chmod +x "postinstall.sh"
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Transferring /var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/definitions/systemvm64template/cleanup.sh
to cleanup.sh
..
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Executing command: chmod +x "cleanup.sh"
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Transferring /var/lib/jenkins/workspace/cloudstack-pullreq-systemvm64/tools/appliance/definitions/systemvm64template/zerodisk.sh
to zerodisk.sh
..
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Executing command: chmod +x "zerodisk.sh"
Waiting for ssh login on 127.0.0.1 with user root to sshd on port =>
7222 to work, timeout=10000 sec
.
Executing command: ./base.sh


0% [Working]

Hit http://security.debian.org wheezy/updates Release.gpg


20% [Connecting to http.us.debian.org (128.61.240.89)]

Hit http://security.debian.org wheezy/updates Release

20% [Connecting to http.us.debian.org (128.61.240.89)]

20% [Release gpgv 102 kB] [Waiting for headers]

25% [Waiting for headers]

Hit http://security.debian.org wheezy/updates/main Sources

38% [Waiting for headers]

Hit http://security.debian.org wheezy/updates/main amd64 Packages


50% [Waiting for headers] [Waiting for headers]

Hit http://http.us.debian.org wheezy Release.gpg

56% [Waiting for headers] [Waiting for headers]

Hit http://security.debian.org wheezy/updates/main Translation-en


67% [Waiting for headers]

Hit http://http.us.debian.org wheezy-updates Release.gpg


70% [Working]

Hit http://http.us.debian.org wheezy Release

70% [Working]

70% [Release gpgv 168 kB] [Waiting for headers]

62% [Waiting for headers]

Hit http://http.us.debian.org wheezy-updates Release


62% [Working]

62% [Release gpgv 124 kB] [Waiting for headers]

56% [Waiting for headers]

Hit http://http.us.debian.org wheezy/main Sources

62% [Waiting for headers]

Hit http://http.us.debian.org wheezy/main amd64 Packages

69% [Waiting for headers]

Hit http://http.us.debian.org wheezy/main Translation-en

75% [Waiting for headers]

Hit http://http.us.debian.org wheezy-updates/main Sources

81% [Waiting for headers]

Hit http://http.us.debian.org wheezy-updates/main amd64 Packages/DiffIndex

88% [Waiting for headers]

Hit http://http.us.debian.org wheezy-updates/main Translation-en/DiffIndex


94% [Working]


Reading package lists... 0%

Reading package lists... 0%

Reading package lists... 1%

Reading package lists... 25%

Reading package lists... 52%

Reading package lists... 58%

Reading package lists... 58%

Reading package lists... 96%

Reading package lists... 96%

Reading package lists... 97%

Reading package lists... 98%

Reading package lists... 98%

Reading package lists... 99%

Reading package lists... 99%

Reading package lists... 99%

Reading package lists... 99%

Reading package lists... 99%

Reading package lists... 99%

Reading package lists... Done


Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done


Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree


Reading state information... 0%

Reading state information... 1%

Reading state information... Done

The following extra packages will be installed:
  ca-certificates libcurl3 libldap-2.4-2 librtmp0 libsasl2-2 libsasl2-modules
  libssh2-1 libssl1.0.0 openssl
Suggested packages:
  libsasl2-modules-otp libsasl2-modules-ldap libsasl2-modules-sql
  libsasl2-modules-gssapi-mit libsasl2-modules-gssapi-heimdal zip
The following NEW packages will be installed:
  ca-certificates curl libcurl3 libldap-2.4-2 librtmp0 libsasl2-2
  libsasl2-modules libssh2-1 openssl unzip
The following packages will be upgraded:
  libssl1.0.0
1 upgraded, 10 newly installed, 0 to remove and 5 not upgraded.
Need to get 3,609 kB of archives.
After this operation, 4,158 kB of additional disk space will be used.


0% [Working]

Get:1 http://http.us.debian.org/debian/ wheezy/main libssl1.0.0 amd64
1.0.1e-2+deb7u7 [1,255 kB]


0% [1 libssl1.0.0 0 B/1,255 kB 0%]

3% [1 libssl1.0.0 95.3 kB/1,255 kB 8%]

22% [1 libssl1.0.0 790 kB/1,255 kB 63%]

35% [Working]

Get:2 http://http.us.debian.org/debian/ wheezy/main libsasl2-2 amd64
2.1.25.dfsg1-6+deb7u1 [120 kB]


35% [2 libsasl2-2 0 B/120 kB 0%]

38% [Working]

Get:3 http://http.us.debian.org/debian/ wheezy/main libldap-2.4-2
amd64 2.4.31-1+nmu2 [243 kB]


39% [3 libldap-2.4-2 40.3 kB/243 kB 17%]

45% [Waiting for headers]

Get:4 http://http.us.debian.org/debian/ wheezy/main librtmp0 amd64
2.4+20111222.git4e06e21-1 [62.3 kB]


45% [4 librtmp0 2,663 B/62.3 kB 4%]

46% [4 librtmp0 38.9 kB/62.3 kB 62%]

47% [Working]

Get:5 http://http.us.debian.org/debian/ wheezy/main libssh2-1 amd64
1.4.2-1.1 [133 kB]


47% [5 libssh2-1 27.3 kB/133 kB 20%]

50% [Waiting for headers]

Get:6 http://http.us.debian.org/debian/ wheezy/main libcurl3 amd64
7.26.0-1+wheezy9 [331 kB]


50% [6 libcurl3 0 B/331 kB 0%]

57% [6 libcurl3 258 kB/331 kB 78%]

59% [Working]

Get:7 http://http.us.debian.org/debian/ wheezy/main openssl amd64
1.0.1e-2+deb7u7 [699 kB]


59% [7 openssl 0 B/699 kB 0%]

67% [7 openssl 278 kB/699 kB 40%]
74% [7 openssl 537 kB/699 kB 77%]

79% [Working]

Get:8 http://http.us.debian.org/debian/ wheezy/main ca-certificates
all 20130119 [185 kB]


79% [8 ca-certificates 0 B/185 kB 0%]

84% [Working]

Get:9 http://http.us.debian.org/debian/ wheezy/main curl amd64
7.26.0-1+wheezy9 [270 kB]


84% [9 curl 0 B/270 kB 0%]

91% [Working]

Get:10 http://http.us.debian.org/debian/ wheezy/main libsasl2-modules
amd64 2.1.25.dfsg1-6+deb7u1 [116 kB]


91% [10 libsasl2-modules 0 B/116 kB 0%]                             540 kB/s 0s
95% [Working]                                                       540 kB/s 0s

Get:11 http://http.us.debian.org/debian/ wheezy/main unzip amd64 6.0-8 [194 kB]

95% [11 unzip 0 B/194 kB 0%]                                        540 kB/s 0s
100% [Working]                                                      540 kB/s 0s

Fetched 3,609 kB in 6s (542 kB/s)
Preconfiguring packages ...
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 19951 files and directories currently installed.)
Preparing to replace libssl1.0.0:amd64 1.0.1e-2+deb7u4 (using
.../libssl1.0.0_1.0.1e-2+deb7u7_amd64.deb) ...
Unpacking replacement libssl1.0.0:amd64 ...
Selecting previously unselected package libsasl2-2:amd64.
Unpacking libsasl2-2:amd64 (from
.../libsasl2-2_2.1.25.dfsg1-6+deb7u1_amd64.deb) ...
Selecting previously unselected package libldap-2.4-2:amd64.
Unpacking libldap-2.4-2:amd64 (from
.../libldap-2.4-2_2.4.31-1+nmu2_amd64.deb) ...
Selecting previously unselected package librtmp0:amd64.
Unpacking librtmp0:amd64 (from
.../librtmp0_2.4+20111222.git4e06e21-1_amd64.deb) ...
Selecting previously unselected package libssh2-1:amd64.
Unpacking libssh2-1:amd64 (from .../libssh2-1_1.4.2-1.1_amd64.deb) ...
Selecting previously unselected package libcurl3:amd64.
Unpacking libcurl3:amd64 (from .../libcurl3_7.26.0-1+wheezy9_amd64.deb) ...
Selecting previously unselected package openssl.
Unpacking openssl (from .../openssl_1.0.1e-2+deb7u7_amd64.deb) ...
Selecting previously unselected package ca-certificates.
Unpacking ca-certificates (from .../ca-certificates_20130119_all.deb) ...
Selecting previously unselected package curl.
Unpacking curl (from .../curl_7.26.0-1+wheezy9_amd64.deb) ...
Selecting previously unselected package libsasl2-modules:amd64.
Unpacking libsasl2-modules:amd64 (from
.../libsasl2-modules_2.1.25.dfsg1-6+deb7u1_amd64.deb) ...
Selecting previously unselected package unzip.
Unpacking unzip (from .../archives/unzip_6.0-8_amd64.deb) ...
Processing triggers for man-db ...
Setting up libssl1.0.0:amd64 (1.0.1e-2+deb7u7) ...
Checking for services that may need to be restarted...done.
Checking for services that may need to be restarted...done.
Checking init scripts...
 [?1049h [1;24r [4l [?25l (B [m [37m [40m [1;24r [H [2J [1;1H [1m [37m [44m

         [2;1H
                        [3;1H
                                       [4;1H
                                                      [5;1H

 [6;1H
                [7;1H
                               [8;1H
                                              [9;1H
                                                             [10;1H

      [11;1H
                      [12;1H
                                      [13;1H
                                                      [14;1H

 [15;1H
                 [16;1H
                                 [17;1H
                                                 [18;1H

 [19;1H
                 [20;1H
                                 [21;1H
                                                 [22;1H

 [23;1H
                 [24;1H
                                [24;79H   [4h
 [4l [1;1H (B [m [37m [44mPackage
configuration [5;2H (0 [30m [47mlqqqqqqqqqqqqqqqqqqqqqu (B [m (B [30m [47m
 [31mConfiguring libssl1.0.0:amd64 [30m
 (0 [30m [47mtqqqqqqqqqqqqqqqqqqqqqk [6;2Hx (B [m (B [30m [47m

 (0 [30m [47mx (B [m (B [1m [37m [40m
 [7;2H (B [m (0 [30m [47mx (B [m (B [30m [47m There are services
installed on your system which need to be restarted
 (0 [30m [47mx (B [m (B [1m [37m [40m
 [8;2H (B [m (0 [30m [47mx (B [m (B [30m [47m when certain libraries,
such as libpam, libc, and libssl, are upgraded.
 (0 [30m [47mx (B [m (B [1m [37m [40m
 [9;2H (B [m (0 [30m [47mx (B [m (B [30m [47m Since these restarts may
cause interruptions of service for the system,
 (0 [30m [47mx (B [m (B [1m [37m [40m
 [10;2H (B [m (0 [30m [47mx (B [m (B [30m [47m you will normally be
prompted on each upgrade for the list of services
 (0 [30m [47mx (B [m (B [1m [37m [40m
 [11;2H (B [m (0 [30m [47mx (B [m (B [30m [47m you wish to restart.
You can choose this option to avoid being
 (0 [30m [47mx (B [m (B [1m [37m [40m
 [12;2H (B [m (0 [30m [47mx (B [m (B [30m [47m prompted; instead, all
necessary restarts will be done for you
 (0 [30m [47mx (B [m (B [1m [37m [40m
 [13;2H (B [m (0 [30m [47mx (B [m (B [30m [47m automatically so you
can avoid being asked questions on each library
 (0 [30m [47mx (B [m (B [1m [37m [40m
 [14;2H (B [m (0 [30m [47mx (B [m (B [30m [47m upgrade.

 (0 [30m [47mx (B [m (B [1m [37m [40m
 [15;2H (B [m (0 [30m [47mx (B [m (B [30m [47m

 (0 [30m [47mx (B [m (B [1m [37m [40m
 [16;2H (B [m (0 [30m [47mx (B [m (B [30m [47m Restart services during
package upgrades without asking?
 (0 [30m [47mx (B [m (B [1m [37m [40m
 [17;2H (B [m (0 [30m [47mx (B [m (B [30m [47m

 (0 [30m [47mx (B [m (B [1m [37m [40m
 [18;2H (B [m (0 [30m [47mx (B [m (B [30m [47m
<Yes>                        [37m [41m<No> [30m [47m
     (0 [30m [47mx (B [m (B [1m [37m [40m
 [19;2H (B [m (0 [30m [47mx (B [m (B [30m [47m

 (0 [30m [47mx (B [m (B [1m [37m [40m
 [20;2H (B [m (0 [30m
[47mmqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj
(B [m (B [1m [37m [40m
 [21;3H
              [18;52HBuild was aborted



2014-05-14 15:02 GMT-06:00 Ian Duffy <ian@ianduffy.ie>:
> Sorry for digging up an old thread.
>
> Hit this issue today on trying to build the 32 bit template.
>
> The upgrade of libssl was occurring with apt-get update
>
> To work around this I just added a default value via the pre-seed file.
>
> libssl1.0.0 libssl1.0.0/restart-services boolean true
> libssl1.0.0:i386 libssl1.0.0/restart-services boolean true
> libssl1.0.0:amd64 libssl1.0.0/restart-services boolean true
>
>
> On 10 April 2014 22:26, Erik Weber <terbolous@gmail.com> wrote:
>
>> What is the proper way to update the systemvm-template? I already have
>> systemvm-xenserver-4.3 registered as I've upgraded from 4.2.1, should I
>> delete that first or use another name?
>>
>> --
>> Erik Weber
>>
>>
>> On Thu, Apr 10, 2014 at 11:01 PM, Rayees Namathponnan <
>> rayees.namathponnan@citrix.com> wrote:
>>
>> > This is fixed in commit
>> >
>> https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=commit;h=0965fdb9f8f3cad8629761884eab16b2503cca1a
>> >
>> > New templates available at
>> > http://jenkins.buildacloud.org/job/build-systemvm64-master/
>> >
>> > Regards,
>> > Rayees
>> >
>> >
>> > -----Original Message-----
>> > From: Animesh Chaturvedi [mailto:animesh.chaturvedi@citrix.com]
>> > Sent: Thursday, April 10, 2014 9:21 AM
>> > To: dev@cloudstack.apache.org
>> > Cc: Wido den Hollander (wido@widodh.nl); Hugo Trippaers
>> > Subject: RE: 4.3 system vm template job failing in jenkins
>> >
>> > May be this can be a quick hackathon in collab. Copying Wido and Hugo
>> >
>> > > -----Original Message-----
>> > > From: Abhinandan Prateek [mailto:Abhinandan.Prateek@citrix.com]
>> > > Sent: Thursday, April 10, 2014 9:18 AM
>> > > To: dev@cloudstack.apache.org
>> > > Subject: Re: 4.3 system vm template job failing in jenkins
>> > >
>> > > On 10/04/14 5:24 pm, "Nux!" <nux@li.nux.ro> wrote:
>> > >
>> > > >On 10.04.2014 11:17, Abhinandan Prateek wrote:
>> > > >> I have tried with both the options now i.e. -qq and by removing
>> > > >> "DEBIAN_PRIORITY=critical², The pop up does not go away breaking
>> > > >> the build job.
>> > > >>
>> > > >> Guys, find the solution !
>> > > >>
>> > > >> -abhi
>> > > >
>> > > >
>> > > >This sort of works for me:
>> > > >
>> > > >(I'm downgrading to the vulnerable version)
>> > > >
>> > > >root@v-45-VM:~# aptitude install libssl1.0.0=1.0.1e-2+deb7u4 The
>> > > >following packages will be DOWNGRADED:
>> > > >   libssl1.0.0
>> > > >0 packages upgraded, 0 newly installed, 1 downgraded, 0 to remove and
>> > > >34 not upgraded.
>> > > >Need to get 0 B/3,027 kB of archives. After unpacking 52.2 kB will
be
>> > > >freed.
>> > > >Preconfiguring packages ...
>> > > >dpkg: warning: downgrading libssl1.0.0:i386 from 1.0.1e-2+deb7u6 to
>> > > >1.0.1e-2+deb7u4
>> > > >(Reading database ... 24354 files and directories currently
>> > > >installed.) Preparing to replace libssl1.0.0:i386 1.0.1e-2+deb7u6
>> > > >(using
>> > > >.../libssl1.0.0_1.0.1e-2+deb7u4_i386.deb) ...
>> > > >Unpacking replacement libssl1.0.0:i386 ...
>> > > >Setting up libssl1.0.0:i386 (1.0.1e-2+deb7u4) ...
>> > > >
>> > > >root@v-45-VM:~# "DEBIAN_FRONTEND=noninteractive apt-get install -y
>> > > >-qq --force-yes libssl1.0.0 Preconfiguring packages ...
>> > > >(Reading database ... 24354 files and directories currently
>> > > >installed.) Preparing to replace libssl1.0.0:i386 1.0.1e-2+deb7u4
>> > > >(using
>> > > >.../libssl1.0.0_1.0.1e-2+deb7u6_i386.deb) ...
>> > > >Unpacking replacement libssl1.0.0:i386 ...
>> > > >Setting up libssl1.0.0:i386 (1.0.1e-2+deb7u6) ...
>> > > >Checking for services that may need to be restarted...done.
>> > > >Checking init scripts...
>> > > >
>> > > >Restarting services possibly affected by the upgrade:
>> > > >[ ok ] Restarting OpenBSD Secure Shell server: sshd.
>> > > >[ ok ] Stopping NTP server: ntpd.
>> > > >[ ok ] Starting NTP server: ntpd.
>> > > >[ ok ] Stopping daemon monitor: monit.
>> > > >[ ok ] Starting daemon monitor: monit.
>> > > >
>> > > >Services restarted successfully."
>> > > >
>> > > >I tried disabling the $post script, but apparently there is no way
to
>> > > >do this in Debian.
>> > > >
>> > >
>> > > Is it possible for someone on the thread to test it out. I can get
>> > > back to this tomorrow.
>> > >
>> > > -abhi
>> > > >
>> >
>> >
>>

Mime
View raw message