cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Hoogland <daan.hoogl...@gmail.com>
Subject Re: unit test failures in files unchanged for more then 3 months??
Date Mon, 05 May 2014 11:59:40 GMT
I recalled the ln command from long ago after installing 1.7
I did a
$ sudo ln -sf /Library/Java/JavaVirtualMachines/jdk1.7.0_55.jdk/Contents
CurrentJDK
(forgot the -n option but it works)

Somehow oracle overwrites the links when installing 8 but not when
installing 7 over it.

On Mon, May 5, 2014 at 1:23 PM, Daan Hoogland <daan.hoogland@gmail.com> wrote:
> please note,
>
> installing java 8 on your system causes these failures. Even if java 7
> is still installed and used in your builds! Somehow a java 8 version
> of java.util.concurrrent is used/called.
>
> I am now re-installing java 7 to see if this solves the issue
>
> On Mon, May 5, 2014 at 1:00 PM, Daan Hoogland <daan.hoogland@gmail.com> wrote:
>> my present 4.4 does not build either! :(
>>
>> On Mon, May 5, 2014 at 12:49 PM, Daan Hoogland <daan.hoogland@gmail.com> wrote:
>>> Did anybody else see this?
>>>
>>> Running com.cloud.utils.backoff.impl.ConstantTimeBackoffTest
>>> 2014-05-05 12:38:52,966 DEBUG [backoff.impl.ConstantTimeBackoffTest]
>>> (main:) thread started
>>> 2014-05-05 12:38:52,966 DEBUG [backoff.impl.ConstantTimeBackoffTest]
>>> (Thread-0:) before
>>> 2014-05-05 12:38:53,068 DEBUG [backoff.impl.ConstantTimeBackoffTest]
>>> (main:) testing wakeup
>>> Tests run: 6, Failures: 0, Errors: 2, Skipped: 0, Time elapsed: 0.595
>>> sec <<< FAILURE!
>>>
>>> both the test and the test-subject have not changed recently. my env
>>> hasn't changed much, but I suspect it must be in there. Running on
>>> macosx 10.9. both in eclipse and on cmd line it fails with above
>>> errors. both in master and in 4.4-forward
>>>
>>> thanks for any pointer,
>>> --
>>> Daan
>>
>>
>>
>> --
>> Daan
>
>
>
> --
> Daan



-- 
Daan

Mime
View raw message