cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Hoogland <daan.hoogl...@gmail.com>
Subject Re: Cloudstack 4.3 instances can't access outside world
Date Mon, 05 May 2014 09:29:56 GMT
Serg,

You marked the bug as to be solved in 4.3.1. There is no plan for a
4.3.1 and a 4.4.0 is planned for the coming weeks. I think some more
conversation on this list is needed for this issue. If you have a dev
env, please find the location of the bug and contact whoever has been
working on those modules to come to a solution with them.

kind regards,
Daan

On Sat, May 3, 2014 at 8:56 AM, Serg Senko <kerncore@gmail.com> wrote:
> There is very urgent bug moved from users@
>
> https://issues.apache.org/jira/browse/CLOUDSTACK-6464
>
>
> ---------- Forwarded message ----------
> From: Sebastien Goasguen <runseb@gmail.com>
> Date: Fri, May 2, 2014 at 12:48 PM
> Subject: Re: Cloudstack 4.3 instances can't access outside world
> To: users@cloudstack.apache.org
>
>
>
> On Apr 30, 2014, at 4:14 PM, Evan McGee <evan@ringplus.net> wrote:
>
>> +1 on this — it’s a bit surprising that such a major regression made it
> into 4.3 final, as it appears any installation with traffic labeling will
> be affected.
>>
>> Should this conversation be moved to dev@cloudstack.apache.org?
>
> Yes please, can you send a note to dev@ with the issue.
>
> thanks
>
>>
>> On Apr 30, 2014, at 3:42 AM, Serg Senko <kerncore@gmail.com> wrote:
>>
>>> Hi Seresh,
>>>
>>> This bug is still unassigned.
>>> It will be fixed?
>>>
>>> Currently is now way for upgrade to 4.3, 4.4..
>>>
>>>
>>>
>>>
>>> On Mon, Apr 21, 2014 at 11:46 AM, Suresh Sadhu <Suresh.Sadhu@citrix.com
>>wrote:
>>>
>>>> This need to be addressed and for tracking purpose I have raised this
> bug.
>>>> kindly update your findings:
>>>>
>>>> https://issues.apache.org/jira/browse/CLOUDSTACK-6464
>>>>
>>>> regards
>>>> sadhu
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: Serg [mailto:kerncore@gmail.com]
>>>> Sent: 21 April 2014 12:04
>>>> To: users@cloudstack.apache.org
>>>> Cc: users@cloudstack.apache.org
>>>> Subject: Re: Cloudstack 4.3 instances can't access outside world
>>>>
>>>> Hi Suresh,
>>>>
>>>> Thanks for your update.
>>>> There is already submitted bug ( bug id?)? it's will be fixed in 4.3.1
> or
>>>> committed to 4.4?
>>>>
>>>>
>>>>
>>>> --
>>>> Serg
>>>>
>>>>> On 21 באפר 2014, at 08:50, Suresh Sadhu <Suresh.Sadhu@citrix.com>
> wrote:
>>>>>
>>>>> Its temporary  and its regression bug caused due to other last min
>>>> commit. due to this traffic labels are not considering.
>>>>>
>>>>> Regards
>>>>> Sadhu
>>>>>
>>>>>
>>>>>
>>>>> -----Original Message-----
>>>>> From: Serg Senko [mailto:kerncore@gmail.com]
>>>>> Sent: 21 April 2014 11:12
>>>>> To: users@cloudstack.apache.org
>>>>> Subject: Re: Cloudstack 4.3 instances can't access outside world
>>>>>
>>>>> Hi,
>>>>>
>>>>> What does mean "In 4.3 traffic labels are not considering" ?
>>>>> It's temporary or " traffic labels " is deprecated now ?
>>>>>
>>>>>
>>>>> Does mean, anyone with KVM traffic labels environment can't upgrade to
>>>> 4.3.0?
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> On Thu, Apr 10, 2014 at 5:05 PM, Suresh Sadhu <Suresh.Sadhu@citrix.com
>>>>> wrote:
>>>>>
>>>>>> Did you used traffic name labels?
>>>>>>
>>>>>> In 4.3 traffic labels are not considering ,by default its attaching
>>>>>> to default  traffic labels(eg:in KVM its cloudbr0 ...due to this
>>>>>> unable to access public network i.r before upgrade if ieth2 attached
>>>>>> cloudbr1 and after upgrade its attached to cloudbr0).maybe you are
>>>> hitting this issue.
>>>>>>
>>>>>> Regards
>>>>>> sadhu
>>>>>>
>>>>>>
>>>>>> -----Original Message-----
>>>>>> From: motty cruz [mailto:motty.cruz@gmail.com]
>>>>>> Sent: 10 April 2014 19:28
>>>>>> To: users@cloudstack.apache.org
>>>>>> Subject: Re: Cloudstack 4.3 instances can't access outside world
>>>>>>
>>>>>> yes I can ping VR, also after the upgrade VR has four insterfaces,
>>>>>> eth0 subnet for Instances, eth1, eth2 for public IP and eth3 for
> public
>>>> IP.
>>>>>>
>>>>>>
>>>>>>> On Wed, Apr 9, 2014 at 10:35 PM, Erik Weber <terbolous@gmail.com>
>>>> wrote:
>>>>>>>
>>>>>>> Can you ping the VR? Log on to the VR, and get the iptables rules.
>>>>>>> How do they look?
>>>>>>>
>>>>>>> Erik Weber
>>>>>>> 10. apr. 2014 00:21 skrev "motty cruz" <motty.cruz@gmail.com>
>>>> følgende:
>>>>>>>
>>>>>>>> I did add egress rules, reboot network but no sucess, so
I removed
>>>>>>>> that rules and nothing.
>>>>>>>>
>>>>>>>> I am lost.
>>>>>>>>
>>>>>>>>
>>>>>>>> On Wed, Apr 9, 2014 at 9:08 AM, Erik Weber <terbolous@gmail.com>
>>>>>> wrote:
>>>>>>>>
>>>>>>>>> Did you remove the egress rule again? If not, try that.
>>>>>>>>>
>>>>>>>>> Erik
>>>>>>>>> 9. apr. 2014 15:49 skrev "motty cruz" <motty.cruz@gmail.com>
>>>>>> følgende:
>>>>>>>>>
>>>>>>>>>> yes I try adding the rule, restart network and router
but no
>>>>>> success!
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On Tue, Apr 8, 2014 at 11:16 PM, Erik Weber <terbolous@gmail.com>
>>>>>>>> wrote:
>>>>>>>>>>
>>>>>>>>>>> Try adding an egress rule, and removing it again.
>>>>>>>>>>>
>>>>>>>>>>> We experience the same, but has so far believed
it was
>>>>>>>>>>> because we
>>>>>>>>> changed
>>>>>>>>>>> the default rule from deny to allow after accounts
were made..
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On Tue, Apr 8, 2014 at 11:14 PM, motty cruz
>>>>>>>>>>> <motty.cruz@gmail.com>
>>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>>> I have two isolated network both virtual
routers can ping
>>>>>>> anywhere,
>>>>>>>>> but
>>>>>>>>>>> the
>>>>>>>>>>>> Instances behind the virtual router can't
ping or access
>>>>>>>>>>>> the
>>>>>>>>> internet.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> On Tue, Apr 8, 2014 at 10:38 AM, motty cruz
<
>>>>>>> motty.cruz@gmail.com>
>>>>>>>>>>> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>> Hello,
>>>>>>>>>>>>> I'm having issues with VMs unable to
access outside world.
>>>>>>>>>>>>> I
>>>>>>> can
>>>>>>>>> ping
>>>>>>>>>>>>> gateway, also when I log in to virtual
router, I am able
>>>>>>>>>>>>> to
>>>>>>> ping
>>>>>>>>>>>>> google.com or anywhere.
>>>>>>>>>>>>> in the Egress rules I am allowing all.
reboot network
>>>>>>>>>>>>> and
>>>>>>> virtual
>>>>>>>>>>> router
>>>>>>>>>>>>> does not help.
>>>>>>>>>>>>>
>>>>>>>>>>>>> VMs were able to access outside before
upgrading from
>>>>>>>>>>>>> 4.2 to
>>>>>>> 4.3.
>>>>>>>>>>>>>
>>>>>>>>>>>>> any ideas?
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> ttyv0 "/usr/libexec/gmail Pc"  webcons on secure
>>>>
>>>
>>>
>>>
>>> --
>>> ttyv0 "/usr/libexec/gmail Pc"  webcons on secure
>>
>
>
>
>
> --
> ttyv0 "/usr/libexec/gmail Pc"  webcons on secure



-- 
Daan

Mime
View raw message