cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafael Weingartner <rafaelweingart...@gmail.com>
Subject Re: Erro: No remote endpoint to send command, check if host or ssvm is down?
Date Wed, 28 May 2014 19:42:37 GMT
Another interesting fact:
All the jars, cloud-**.jar are label as if they were 4.1.1 version.
Is that right?


On Wed, May 28, 2014 at 4:01 PM, Rafael Weingartner <
rafaelweingartner@gmail.com> wrote:

> Just an update.
> I have just checked my console proxy VM, which is also with "--" in agent
> state at "insfrastructure>System VM" page.
> The agente is running there, however its state is "--".
>
> I also looked into the source code, and the class "
> org.apache.cloudstack.storage.resource.NfsSecondaryStorageResource" is
> located in a jar called "cloud-secondary-storage" which is not in the
> directory "/usr/local/cloud/systemvm" that contains the jars used to run
> the agent. Neither in my SSVM nor in Console proxy VM that jar exist.
>
> I do not get, I cannot be the only one with this problem. It seems that
> this jar is missing into the system vm template.
>
>
> On Wed, May 28, 2014 at 2:45 PM, Rafael Weingartner <
> rafaelweingartner@gmail.com> wrote:
>
>> thanks, I checked the "/var/log/cloud/cloud.out", And I found this error:
>>  ERROR AgentShell:607 - Unable to start agent: Resource class not found:
>> org.apache.cloudstack.storage.resource.NfsSecondaryStorageResource due to:
>> java.lang.ClassNotFoundException:
>> org.apache.cloudstack.storage.resource.NfsSecondaryStorageResource
>> Unable to start agent: Resource class not found:
>> org.apache.cloudstack.storage.resource.NfsSecondaryStorageResource due to:
>> java.lang.ClassNotFoundException:
>> org.apache.cloudstack.storage.resource.NfsSecondaryStorageResource
>>
>> It seems that there is a jar dependency missing.
>>
>>
>>
>> On Wed, May 28, 2014 at 2:31 PM, Min Chen <min.chen@citrix.com> wrote:
>>
>>> Your UI indicates that agent is not running on your SSVM, it should show
>>> as 'Running', that is why your cloud.host does not have an entry for your
>>> new SSVM, thus we cannot find a remote host to send command to. Agent is
>>> a
>>> java code running inside your SSVM, you should see what error you
>>> encountered in starting agent in your ssvm from cloud.out file in SSVM
>>> log.
>>>
>>> Thanks
>>> -min
>>>
>>>
>>> On 5/28/14 10:20 AM, "Rafael Weingartner" <rafaelweingartner@gmail.com>
>>> wrote:
>>>
>>> >What agent are you talking about?
>>> >Is it an app that run into the SSVM?
>>> >I am using xenserver and XCP as the hypervisor.
>>> >
>>> >I looked into the CS UI, infrastructure>System VMs and the column that
>>> has
>>> >some values about the agent-state has a -- in it. Is it normal?
>>> >
>>> >At the end, should the SSVM have an entry into the host table?
>>> >
>>> >
>>> >On Wed, May 28, 2014 at 2:05 PM, Min Chen <min.chen@citrix.com> wrote:
>>> >
>>> >> Check if agent is running your ssvm.
>>> >>
>>> >> Thanks
>>> >> -min
>>> >>
>>> >> On 5/28/14 7:26 AM, "Rafael Weingartner" <rafaelweingartner@gmail.com
>>> >
>>> >> wrote:
>>> >>
>>> >> >Hi all,
>>> >> >sorry, to bother you again with this thread.
>>> >> >Could at least someone that has the CS 4.3.0 deployed try to
>>> download a
>>> >> >volume and/or a template?
>>> >> >
>>> >> >Could someone also check the database, table ³cloud.host² and
look if
>>> >> >there
>>> >> >is an entry there for the running SSVM and console proxy VM?
>>> >> >
>>> >> >
>>> >> >
>>> >> >On Mon, May 26, 2014 at 4:42 PM, Rafael Weingartner <
>>> >> >rafaelweingartner@gmail.com> wrote:
>>> >> >
>>> >> >> Hi folks, I am sending this to the dev list as well, hence
I am not
>>> >>sure
>>> >> >> if it is or not a bug. Sorry if I am mistaken.
>>> >> >>
>>> >> >> So, after I upgraded CS from 4.1.1 to 4.3.0, everything seemed
to
>>> be
>>> >> >> working just fine, however, whenever I try to download a template
>>> or
>>> >> >>volume
>>> >> >> I am getting the following error:
>>> >> >> ERROR [o.a.c.s.d.d.CloudStackImageStoreDriverImpl]
>>> >> >> (Job-Executor-1:ctx-1cb86faa ctx-61f7e4f9) No remote endpoint
to
>>> send
>>> >> >> command, check if host or ssvm is down?
>>> >> >> ERROR [o.a.c.s.d.d.CloudStackImageStoreDriverImpl]
>>> >> >> (Job-Executor-1:ctx-1cb86faa ctx-61f7e4f9) Unable to create
a link
>>> >>for
>>> >> >> entity at ... on ssvm,No remote endpoint to send command, check
if
>>> >>host
>>> >> >>or
>>> >> >> ssvm is down
>>> >> >>
>>> >> >> I have already destroyed the system VMs in order to let CS
recreate
>>> >>them
>>> >> >> with the new system VM template. I logged into the SSVM to
check
>>> >> >>whether or
>>> >> >> not it was created using the new template and it indeed.
>>> Therefore, I
>>> >> >>have
>>> >> >> ruled out that problem.
>>> >> >>
>>> >> >> Then, I took a look into the source code, more specifically
at
>>> >> >>
>>> >>
>>>
>>> >>>>"org.apache.cloudstack.storage.datastore.driver.CloudStackImageStoreDri
>>> >>>>ve
>>> >> >>rImpl.createEntityExtractUrl(DataStore,
>>> >> >> String, ImageFormat, DataObject)"
>>> >> >> and
>>> >> >>
>>> >> >>
>>> >>
>>>
>>> >>>>"org.apache.cloudstack.storage.endpoint.DefaultEndPointSelector.findEnd
>>> >>>>po
>>> >> >>intForImageStorage(DataStore)".
>>> >> >>
>>> >> >> I noticed that it looks for an entry at table "Cloud.host"
that has
>>> >>the
>>> >> >> type ³SecondaryStorageVM².
>>> >> >>
>>> >> >> I took a look into the DB, but, there are no entries either
for
>>> SSVM
>>> >>or
>>> >> >> Console proxy in ³Cloud.host² table. I mean no entries for
the VMs
>>> >>that
>>> >> >>are
>>> >> >> running. The older VMs that were destroyed have an entry there.
>>> >> >>
>>> >> >> Have anyone seem a problem like this before?
>>> >> >> Is there something I am missing?
>>> >> >>
>>> >> >> The VMs are running, should not them be registered there?
>>> >> >>
>>> >> >> --
>>> >> >> Rafael Weingärtner
>>> >> >>
>>> >> >
>>> >> >
>>> >> >
>>> >> >--
>>> >> >Rafael Weingärtner
>>> >>
>>> >>
>>> >
>>> >
>>> >--
>>> >Rafael Weingärtner
>>>
>>>
>>
>>
>> --
>> Rafael Weingärtner
>>
>
>
>
> --
> Rafael Weingärtner
>



-- 
Rafael Weingärtner

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message