cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <w...@widodh.nl>
Subject Re: Installation docs update
Date Wed, 28 May 2014 09:05:31 GMT


On 05/28/2014 10:43 AM, sebgoa wrote:
>
> On May 16, 2014, at 2:10 AM, Andrei Mikhailovsky <andrei@arhont.com> wrote:
>
>> Hi guys,
>>
>> Sorry if this email will sound a bit off, but it's rather late at night and i've
spent ages trying to figure out why ACS 4.3 is broken on a newly created install with XenServer
4.3.
>>
>> Could someone responsible for documentation please make the following corrections
to make sure that people following the installation guide will actually end up with a working
installation. At the moment, the installation guide has mistakes/omissions which prevent users
from having a working CloudStack environment. It just looks rather unprofessional (((
>>
>> Issues I've found so far (there might be more)
>>
>> 1. When installing the management server on Ubuntu server please add to requirement
to install libmysql-java by running:
>>
>> apt-get install libmysql-java
>
> I can confirm this, it seems to be missing from the packages.
>
> @wido, do you know about this ? It seems that we might be missing a dependency in the
deb packages. At least on 14.04.
>

Yes, I know about this and wrote a blogpost about it: 
http://blog.widodh.nl/2014/03/sql-connection-error-after-upgrade-to-cloudstack-4-3-0/

I fixed this in March in the master branch and it's also in the 4.3 and 
4.4 branches: 
https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=commit;h=b141641528d6723114c12499ea37acc31b1ce320

Wido

>>
>> Or the management server will not start. Produces a java exception complaining about
unable to connect to the sql database
>>
>>
>> 2. Please change the debian repo from:
>>
>> deb http://cloudstack.apt-get.eu/ubuntu precise 4.2
>>
>> to
>>
>> deb http://cloudstack.apt-get.eu/ubuntu precise 4.3 It would be also good to change
that line with every new version release. You do want users to install the latest version
of ACS, don't you?
>>
>>
>> 3. Please update the section about downloading vhd-util if you are using XenServer
and indicate that this file would also have to be manually copied to XenServer to /opt/cloud/bin
folder. This bit is missing from documentation and because of this system vms will no get
created. Simply downloading the file into the locattion indicated in the installation guide
is not enough. It is not being copied to the xenserver host automatically.
>>
>> Cheers
>>
>> Andrei
>>
>

Mime
View raw message