cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Devdeep Singh" <devdeep.si...@citrix.com>
Subject Re: Review Request 21429: CLOUDSTACK-6663: Agent fails to start on some setups if last nic on host in nic list doesn't contain unicast address
Date Tue, 27 May 2014 06:44:00 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/21429/#review43951
-----------------------------------------------------------

Ship it!


Ship It!

- Devdeep Singh


On May 14, 2014, 8:02 a.m., Anshul Gangwar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/21429/
> -----------------------------------------------------------
> 
> (Updated May 14, 2014, 8:02 a.m.)
> 
> 
> Review request for cloudstack, Devdeep Singh and Rajesh Battala.
> 
> 
> Bugs: CLOUDSTACK-6663
>     https://issues.apache.org/jira/browse/CLOUDSTACK-6663
> 
> 
> Repository: cloudstack-git
> 
> 
> Description
> -------
> 
> Before starting Hyper-V agent we initialize HypervResourceController. We try to initialize
it with IP address 0.0.0.0. We try to get nic info of 0.0.0.0. To get nic info we iterate
through all nics and return the last NIC in the list if it doesn't match with any IP address.
So in case last NIC doesn't have unicastAddress, Hyper-V agent will fail to start.
> 
> We don't need IP address during initialization. It get initialized with startupcommand
later
> 
> 
> Diffs
> -----
> 
>   plugins/hypervisors/hyperv/DotNet/ServerResource/AgentShell/AgentService.cs 9d66a5c

> 
> Diff: https://reviews.apache.org/r/21429/diff/
> 
> 
> Testing
> -------
> 
> Hyper-V Agent starts up without any problem.
> Created the basic Hyper-V setup and it works fine
> 
> 
> Thanks,
> 
> Anshul Gangwar
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message