cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitin Mehta <Nitin.Me...@citrix.com>
Subject Re: [QUESTION, SSVM] Updating code in SSVM
Date Fri, 18 Apr 2014 14:43:43 GMT
Mike - since your SSVM is running on XS please remove the tags from the
host as Sadhu says and then reconnect the host. You should see in the logs
that new systemvm.iso gets copied to the host.

* xe host-param-clear param-name=tags uuid=[uuid]



On 18/04/14 7:22 AM, "Mike Tutkowski" <mike.tutkowski@solidfire.com> wrote:

>OK - thanks!
>
>On Friday, April 18, 2014, Amogh Vasekar <amogh.vasekar@citrix.com> wrote:
>
>> (For the lack of a better answer) I guess this would be a manual step by
>> logging onto the Secondary storage҆
>>
>> Thanks,
>> Amogh
>>
>> On 4/17/14 11:25 PM, "Mike Tutkowski"
>><mike.tutkowski@solidfire.com<javascript:;>>
>> wrote:
>>
>> >Thanks :)
>> >
>> >What way do you recommend I remove systemvm.iso from secondary
>>storage? It
>> >doesn't show up under ISOs in the GUI.
>> >
>> >
>> >On Fri, Apr 18, 2014 at 12:15 AM, Suresh Sadhu
>> ><Suresh.Sadhu@citrix.com <javascript:;>>wrote:
>> >
>> >>
>> >> The  procedure mentioned by among  will work+ please make sure  that
>>you
>> >> stop and start the system vms after moving the old system vm from
>> >>secondary
>> >> storage .
>> >>
>> >>
>> >> And in case of xen. Clear the host tags on xen host and perform force
>> >> reconnect form CS,new systemvm.iso will be pushed to xen host.
>> >>
>> >> Regards
>> >> Sadhu
>> >>
>> >> -----Original Message-----
>> >> From: Amogh Vasekar [mailto:amogh.vasekar@citrix.com <javascript:;>]
>> >> Sent: 18 April 2014 11:34
>> >> To: dev@cloudstack.apache.org <javascript:;>
>> >> Subject: Re: [QUESTION, SSVM] Updating code in SSVM
>> >>
>> >> Hi,
>> >>
>> >> Which CloudStack version is it?
>> >> AFAIK for vmware - deleting systemvm.iso from the secondary storage
>>for
>> >> your VMWare zone, and restarting management server and SSVM should do
>> >>the
>> >> trick.
>> >>
>> >> Thanks,
>> >> Amogh
>> >>
>> >> On 4/17/14 10:55 PM, "Mike Tutkowski"
>><mike.tutkowski@solidfire.com<javascript:;>
>> >
>> >> wrote:
>> >>
>> >> >Hi,
>> >> >
>> >> >I was debugging storage code for ESXi that runs in SSVM (a
>> >>CopyCommand).
>> >> >
>> >> >I needed to make a change related to managed storage.
>> >> >
>> >> >I made the change, rebuilt the codebase, and have been trying
>>various
>> >> >ways of getting that code into SSVM, but SSVM seems to have the
>>older
>> >> >code still.
>> >> >
>> >> >In this situation, my SSVM is actually running on a XenServer host.
>> >> >
>> >> >Can someone provide me with the procedure to update the code that's
>> >> >running in SSVM on XenServer?
>> >> >
>> >> >I tried to scp the systemvm.iso file from where it was built to the
>> >> >XenServer host and then re-start SSVM, but that didn't seem to do
>>the
>> >> >trick.
>> >> >
>> >> >Thanks!
>> >> >
>> >> >--
>> >> >*Mike Tutkowski*
>> >> >*Senior CloudStack Developer, SolidFire Inc.*
>> >> >e: mike.tutkowski@solidfire.com <javascript:;>
>> >> >o: 303.746.7302
>> >> >Advancing the way the world uses the
>> >> >cloud<http://solidfire.com/solution/overview/?video=play>
>> >> >*(tm)*
>> >>
>> >>
>> >
>> >
>> >--
>> >*Mike Tutkowski*
>> >*Senior CloudStack Developer, SolidFire Inc.*
>> >e: mike.tutkowski@solidfire.com <javascript:;>
>> >o: 303.746.7302
>> >Advancing the way the world uses the
>> >cloud<http://solidfire.com/solution/overview/?video=play>
>> >*(tm)*
>>
>>
>
>-- 
>*Mike Tutkowski*
>*Senior CloudStack Developer, SolidFire Inc.*
>e: mike.tutkowski@solidfire.com
>o: 303.746.7302
>Advancing the way the world uses the
>cloud<http://solidfire.com/solution/overview/?video=play>
>*(tm)*


Mime
View raw message