cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Nalley <da...@gnsa.us>
Subject Re: java6 is installed instead of java7 when CloudStack rpm which build from master branch is installed with yum command.
Date Fri, 18 Apr 2014 01:33:20 GMT
I think, but am not sure; that this is because openjdk has an epoch in
addition to version. This would mean that version '>= 1.7.0' is
satisfied by version 1:1.6.0

See:
http://erikos.buchoase.de/2009/01/26/rpm-epoch-field/

Please see if changing the requires to 'java >= 1:1.70', if that
works, please submit a patch.

--David

On Thu, Apr 17, 2014 at 3:24 PM, Yoshikazu Nojima <mail@ynojima.net> wrote:
> Ilya,
> No,
> I tried on cleam environment again. This is a result:
> Any java wasn't installed before installing cloudstack rpm.
>
> [root@ut1-esxi-vm37 ~]# rpm -qa | grep java
> [root@ut1-esxi-vm37 ~]#
>
> * dependency list
> Even though "dependency: java >= 1.7.0" is specified,
> java-1.6.0-openjdk is listed as a candidate.
>
> [root@ut1-esxi-vm37 ~]# yum deplist cloudstack-agent
> Loaded plugins: fastestmirror, security
> Loading mirror speeds from cached hostfile
> Finding dependencies:
> package: cloudstack-agent.x86_64 4.5.0-SNAPSHOT.el6
>   dependency: libvirt
>    provider: libvirt.x86_64 0.10.2-29.el6_5.4
>    provider: libvirt.x86_64 0.10.2-29.el6.1
>    provider: libvirt.x86_64 0.10.2-29.el6_5.5
>    provider: libvirt.x86_64 0.10.2-29.el6_5.2
>    provider: libvirt.x86_64 0.10.2-29.el6_5.3
>    provider: libvirt.x86_64 0.10.2-29.el6
>   dependency: qemu-img
>    provider: qemu-img.x86_64 2:0.12.1.2-2.415.el6_5.6
>    provider: qemu-img.x86_64 2:0.12.1.2-2.415.el6_5.4
>    provider: qemu-img.x86_64 2:0.12.1.2-2.415.el6_5.7
>    provider: qemu-img.x86_64 2:0.12.1.2-2.415.el6_5.5
>    provider: qemu-img.x86_64 2:0.12.1.2-2.415.el6_5.3
>    provider: qemu-img.x86_64 2:0.12.1.2-2.415.el6
>   dependency: ipset
>    provider: ipset.x86_64 6.11-1.el6
>    provider: ipset.i686 6.11-1.el6
>   dependency: /bin/bash
>    provider: bash.x86_64 4.1.2-15.el6_4
>   dependency: jakarta-commons-daemon-jsvc
>    provider: jakarta-commons-daemon-jsvc.x86_64 1:1.0.1-8.9.el6
>   dependency: vconfig
>    provider: vconfig.x86_64 1.9-8.1.el6
>   dependency: jakarta-commons-daemon
>    provider: jakarta-commons-daemon.x86_64 1:1.0.1-8.9.el6
>   dependency: libvirt-python
>    provider: libvirt-python.x86_64 0.10.2-29.el6_5.2
>    provider: libvirt-python.x86_64 0.10.2-29.el6_5.5
>    provider: libvirt-python.x86_64 0.10.2-29.el6_5.3
>    provider: libvirt-python.x86_64 0.10.2-29.el6.1
>    provider: libvirt-python.x86_64 0.10.2-29.el6_5.4
>    provider: libvirt-python.x86_64 0.10.2-29.el6
>   dependency: ethtool
>    provider: ethtool.x86_64 2:3.5-1.2.el6_5
>    provider: ethtool.x86_64 2:3.5-1.el6
>   dependency: qemu-kvm
>    provider: qemu-kvm.x86_64 2:0.12.1.2-2.415.el6_5.4
>    provider: qemu-kvm.x86_64 2:0.12.1.2-2.415.el6_5.7
>    provider: qemu-kvm.x86_64 2:0.12.1.2-2.415.el6_5.3
>    provider: qemu-kvm.x86_64 2:0.12.1.2-2.415.el6_5.6
>    provider: qemu-kvm.x86_64 2:0.12.1.2-2.415.el6_5.5
>    provider: qemu-kvm.x86_64 2:0.12.1.2-2.415.el6
>   dependency: java >= 1.7.0
>    provider: java-1.7.0-openjdk.x86_64 1:1.7.0.51-2.4.4.1.el6_5
>    provider: java-1.6.0-openjdk.x86_64 1:1.6.0.0-3.1.13.1.el6_5
>    provider: java-1.7.0-openjdk.x86_64 1:1.7.0.45-2.4.3.4.el6_5
>    provider: java-1.7.0-openjdk.x86_64 1:1.7.0.45-2.4.3.3.el6
>    provider: java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.66.1.13.0.el6
>   dependency: /usr/bin/python
>    provider: python.x86_64 2.6.6-52.el6
>    provider: python.x86_64 2.6.6-51.el6
>   dependency: jsvc
>    provider: jakarta-commons-daemon-jsvc.x86_64 1:1.0.1-8.9.el6
>   dependency: perl
>    provider: perl.x86_64 4:5.10.1-136.el6
>   dependency: ebtables
>    provider: ebtables.x86_64 2.0.9-6.el6
>   dependency: iptables
>    provider: iptables.i686 1.4.7-11.el6
>    provider: iptables.x86_64 1.4.7-11.el6
>   dependency: cloudstack-common = 4.5.0
>    provider: cloudstack-common.x86_64 4.5.0-SNAPSHOT.el6
>   dependency: openssh-clients
>    provider: openssh-clients.x86_64 5.3p1-94.el6
>   dependency: /bin/sh
>    provider: bash.x86_64 4.1.2-15.el6_4
>   dependency: bridge-utils
>    provider: bridge-utils.x86_64 1.2-10.el6
>
>
> * java-1.6.0-openjdk will be installed while installin cloudstack rpm.
>
> [root@ut1-esxi-vm37 ~]# yum install cloudstack-agent
> Loaded plugins: fastestmirror, security
> Loading mirror speeds from cached hostfile
> Setting up Install Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package cloudstack-agent.x86_64 0:4.5.0-SNAPSHOT.el6 will be installed
> --> Processing Dependency: cloudstack-common = 4.5.0 for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: java >= 1.7.0 for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: qemu-kvm for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: qemu-img for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: libvirt for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: jsvc for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: jakarta-commons-daemon-jsvc for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: jakarta-commons-daemon for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: ipset for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Processing Dependency: ebtables for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Running transaction check
> ---> Package cloudstack-common.x86_64 0:4.5.0-SNAPSHOT.el6 will be installed
> ---> Package ebtables.x86_64 0:2.0.9-6.el6 will be installed
> ---> Package ipset.x86_64 0:6.11-1.el6 will be installed
> --> Processing Dependency: libmnl.so.0(LIBMNL_1.0)(64bit) for package:
> ipset-6.11-1.el6.x86_64
> --> Processing Dependency: libmnl.so.0()(64bit) for package:
> ipset-6.11-1.el6.x86_64
> ---> Package jakarta-commons-daemon.x86_64 1:1.0.1-8.9.el6 will be installed
> --> Processing Dependency: java-gcj-compat for package:
> 1:jakarta-commons-daemon-1.0.1-8.9.el6.x86_64
> --> Processing Dependency: java-gcj-compat for package:
> 1:jakarta-commons-daemon-1.0.1-8.9.el6.x86_64
> --> Processing Dependency: libgcj_bc.so.1()(64bit) for package:
> 1:jakarta-commons-daemon-1.0.1-8.9.el6.x86_64
> ---> Package jakarta-commons-daemon-jsvc.x86_64 1:1.0.1-8.9.el6 will
> be installed
> ---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-3.1.13.1.el6_5 will
> be installed
> --> Processing Dependency: jpackage-utils >= 1.7.3-1jpp.2 for package:
> 1:java-1.6.0-openjdk-1.6.0.0-3.1.13.1.el6_5.x86_64
> --> Processing Dependency: tzdata-java for package:
> 1:java-1.6.0-openjdk-1.6.0.0-3.1.13.1.el6_5.x86_64
> --> Processing Dependency: rhino for package:
> 1:java-1.6.0-openjdk-1.6.0.0-3.1.13.1.el6_5.x86_64
> --> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package:
> 1:java-1.6.0-openjdk-1.6.0.0-3.1.13.1.el6_5.x86_64
> --> Processing Dependency: libpulse.so.0()(64bit) for package:
> 1:java-1.6.0-openjdk-1.6.0.0-3.1.13.1.el6_5.x86_64
> --> Processing Dependency: libgif.so.4()(64bit) for package:
> 1:java-1.6.0-openjdk-1.6.0.0-3.1.13.1.el6_5.x86_64
> --> Processing Dependency: libXtst.so.6()(64bit) for package:
> 1:java-1.6.0-openjdk-1.6.0.0-3.1.13.1.el6_5.x86_64
> ---> Package libvirt.x86_64 0:0.10.2-29.el6_5.5 will be installed
> --> Processing Dependency: dnsmasq >= 2.41 for package:
> libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: radvd for package: libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: numad for package: libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: nfs-utils for package:
> libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: lzop for package: libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: libnetcf.so.1(NETCF_1.4.0)(64bit) for
> package: libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: libnetcf.so.1(NETCF_1.3.0)(64bit) for
> package: libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: libnetcf.so.1(NETCF_1.2.0)(64bit) for
> package: libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: libnetcf.so.1(NETCF_1.0.0)(64bit) for
> package: libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: libcgroup for package:
> libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: iscsi-initiator-utils for package:
> libvirt-0.10.2-29.el6_5.5.x86_64
> --> Processing Dependency: libnetcf.so.1()(64bit) for package:
> libvirt-0.10.2-29.el6_5.5.x86_64
> ---> Package qemu-img.x86_64 2:0.12.1.2-2.415.el6_5.7 will be installed
> --> Processing Dependency: libusbredirparser.so.1()(64bit) for
> package: 2:qemu-img-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: libgfxdr.so.0()(64bit) for package:
> 2:qemu-img-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: libgfrpc.so.0()(64bit) for package:
> 2:qemu-img-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: libgfapi.so.0()(64bit) for package:
> 2:qemu-img-0.12.1.2-2.415.el6_5.7.x86_64
> ---> Package qemu-kvm.x86_64 2:0.12.1.2-2.415.el6_5.7 will be installed
> --> Processing Dependency: seabios >= 0.6.1.2-20.el6 for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: vgabios-vmware for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: vgabios-stdvga for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: vgabios-qxl for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: vgabios for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency:
> libspice-server.so.1(SPICE_SERVER_0.8.3)(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency:
> libspice-server.so.1(SPICE_SERVER_0.8.2)(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency:
> libspice-server.so.1(SPICE_SERVER_0.8.1)(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency:
> libspice-server.so.1(SPICE_SERVER_0.6.0)(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency:
> libspice-server.so.1(SPICE_SERVER_0.12.4)(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency:
> libspice-server.so.1(SPICE_SERVER_0.11.2)(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency:
> libspice-server.so.1(SPICE_SERVER_0.10.4)(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency:
> libspice-server.so.1(SPICE_SERVER_0.10.0)(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: /usr/share/sgabios/sgabios.bin for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: /usr/share/gpxe/virtio-net.rom for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: /usr/share/gpxe/rtl8139.rom for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: /usr/share/gpxe/rtl8029.rom for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: /usr/share/gpxe/pcnet32.rom for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: /usr/share/gpxe/e1000-0x100e.rom for
> package: 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Processing Dependency: libspice-server.so.1()(64bit) for package:
> 2:qemu-kvm-0.12.1.2-2.415.el6_5.7.x86_64
> --> Running transaction check
> ---> Package dnsmasq.x86_64 0:2.48-13.el6 will be installed
> ---> Package giflib.x86_64 0:4.1.6-3.1.el6 will be installed
> --> Processing Dependency: libSM.so.6()(64bit) for package:
> giflib-4.1.6-3.1.el6.x86_64
> --> Processing Dependency: libICE.so.6()(64bit) for package:
> giflib-4.1.6-3.1.el6.x86_64
> ---> Package glusterfs-api.x86_64 0:3.4.0.57rhs-1.el6_5 will be installed
> ---> Package glusterfs-libs.x86_64 0:3.4.0.57rhs-1.el6_5 will be installed
> ---> Package gpxe-roms-qemu.noarch 0:0.9.7-6.10.el6 will be installed
> ---> Package iscsi-initiator-utils.x86_64 0:6.2.0.873-10.el6 will be installed
> ---> Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed
> --> Processing Dependency: sinjdoc for package:
> java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
> ---> Package jpackage-utils.noarch 0:1.7.5-3.12.el6 will be installed
> ---> Package libXtst.x86_64 0:1.2.1-2.el6 will be installed
> ---> Package libcgroup.x86_64 0:0.40.rc1-5.el6_5.1 will be installed
> ---> Package libgcj.x86_64 0:4.4.7-4.el6 will be installed
> --> Processing Dependency: libart_lgpl >= 2.1.0 for package:
> libgcj-4.4.7-4.el6.x86_64
> ---> Package libmnl.x86_64 0:1.0.2-3.el6 will be installed
> ---> Package lzop.x86_64 0:1.02-0.9.rc1.el6 will be installed
> ---> Package netcf-libs.x86_64 0:0.1.9-4.el6_5.2 will be installed
> --> Processing Dependency: libxslt.so.1(LIBXML2_1.1.18)(64bit) for
> package: netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for
> package: netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18)(64bit) for
> package: netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13)(64bit) for
> package: netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for
> package: netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for
> package: netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for
> package: netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libxslt.so.1()(64bit) for package:
> netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libexslt.so.0()(64bit) for package:
> netcf-libs-0.1.9-4.el6_5.2.x86_64
> --> Processing Dependency: libaugeas.so.0()(64bit) for package:
> netcf-libs-0.1.9-4.el6_5.2.x86_64
> ---> Package nfs-utils.x86_64 1:1.2.3-39.el6 will be installed
> --> Processing Dependency: nfs-utils-lib >= 1.1.0-3 for package:
> 1:nfs-utils-1.2.3-39.el6.x86_64
> --> Processing Dependency: keyutils >= 1.4-4 for package:
> 1:nfs-utils-1.2.3-39.el6.x86_64
> --> Processing Dependency: rpcbind for package: 1:nfs-utils-1.2.3-39.el6.x86_64
> --> Processing Dependency: libtirpc for package: 1:nfs-utils-1.2.3-39.el6.x86_64
> --> Processing Dependency: libgssglue.so.1(libgssapi_CITI_2)(64bit)
> for package: 1:nfs-utils-1.2.3-39.el6.x86_64
> --> Processing Dependency: libgssglue for package:
> 1:nfs-utils-1.2.3-39.el6.x86_64
> --> Processing Dependency: libtirpc.so.1()(64bit) for package:
> 1:nfs-utils-1.2.3-39.el6.x86_64
> --> Processing Dependency: libnfsidmap.so.0()(64bit) for package:
> 1:nfs-utils-1.2.3-39.el6.x86_64
> --> Processing Dependency: libgssglue.so.1()(64bit) for package:
> 1:nfs-utils-1.2.3-39.el6.x86_64
> ---> Package numad.x86_64 0:0.5-9.20130814git.el6 will be installed
> ---> Package pulseaudio-libs.x86_64 0:0.9.21-14.el6_3 will be installed
> --> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0)(64bit)
> for package: pulseaudio-libs-0.9.21-14.el6_3.x86_64
> --> Processing Dependency: libsndfile.so.1()(64bit) for package:
> pulseaudio-libs-0.9.21-14.el6_3.x86_64
> --> Processing Dependency: libasyncns.so.0()(64bit) for package:
> pulseaudio-libs-0.9.21-14.el6_3.x86_64
> ---> Package radvd.x86_64 0:1.6-1.el6 will be installed
> ---> Package rhino.noarch 0:1.7-0.7.r2.2.el6 will be installed
> --> Processing Dependency: jline for package: rhino-1.7-0.7.r2.2.el6.noarch
> ---> Package seabios.x86_64 0:0.6.1.2-28.el6 will be installed
> ---> Package sgabios-bin.noarch 0:0-0.3.20110621svn.el6 will be installed
> ---> Package spice-server.x86_64 0:0.12.4-6.el6_5.1 will be installed
> --> Processing Dependency: libcelt051.so.0()(64bit) for package:
> spice-server-0.12.4-6.el6_5.1.x86_64
> ---> Package tzdata-java.noarch 0:2014b-1.el6 will be installed
> ---> Package usbredir.x86_64 0:0.5.1-1.el6 will be installed
> ---> Package vgabios.noarch 0:0.6b-3.7.el6 will be installed
> --> Running transaction check
> ---> Package augeas-libs.x86_64 0:1.0.0-5.el6_5.1 will be installed
> ---> Package celt051.x86_64 0:0.5.1.3-0.el6 will be installed
> --> Processing Dependency: libogg.so.0()(64bit) for package:
> celt051-0.5.1.3-0.el6.x86_64
> ---> Package jline.noarch 0:0.9.94-0.8.el6 will be installed
> ---> Package keyutils.x86_64 0:1.4-4.el6 will be installed
> ---> Package libICE.x86_64 0:1.0.6-1.el6 will be installed
> ---> Package libSM.x86_64 0:1.2.1-2.el6 will be installed
> ---> Package libart_lgpl.x86_64 0:2.3.20-5.1.el6 will be installed
> ---> Package libasyncns.x86_64 0:0.8-1.1.el6 will be installed
> ---> Package libgssglue.x86_64 0:0.1-11.el6 will be installed
> ---> Package libsndfile.x86_64 0:1.0.20-5.el6 will be installed
> --> Processing Dependency: libvorbisenc.so.2()(64bit) for package:
> libsndfile-1.0.20-5.el6.x86_64
> --> Processing Dependency: libvorbis.so.0()(64bit) for package:
> libsndfile-1.0.20-5.el6.x86_64
> --> Processing Dependency: libFLAC.so.8()(64bit) for package:
> libsndfile-1.0.20-5.el6.x86_64
> ---> Package libtirpc.x86_64 0:0.2.1-6.el6_5.1 will be installed
> ---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be installed
> ---> Package nfs-utils-lib.x86_64 0:1.1.5-6.el6 will be installed
> ---> Package rpcbind.x86_64 0:0.2.0-11.el6 will be installed
> ---> Package sinjdoc.x86_64 0:0.5-9.1.el6 will be installed
> --> Processing Dependency: java_cup >= 0.10 for package:
> sinjdoc-0.5-9.1.el6.x86_64
> --> Running transaction check
> ---> Package flac.x86_64 0:1.2.1-6.1.el6 will be installed
> ---> Package java_cup.x86_64 1:0.10k-5.el6 will be installed
> ---> Package libogg.x86_64 2:1.1.4-2.1.el6 will be installed
> ---> Package libvorbis.x86_64 1:1.2.3-4.el6_2.1 will be installed
> --> Finished Dependency Resolution
>
> Dependencies Resolved
>
> ======================================================================================================================================
>  Package                               Arch             Version
>                     Repository                            Size
> ======================================================================================================================================
> Installing:
>  cloudstack-agent                      x86_64
> 4.5.0-SNAPSHOT.el6                 cloudstack-develop-ynojima
>   41 M
> Installing for dependencies:
>  augeas-libs                           x86_64
> 1.0.0-5.el6_5.1                    centos_updates_6.5_x86_64
>  309 k
>  celt051                               x86_64           0.5.1.3-0.el6
>                     centos_os_6.5_x86_64                  50 k
>  cloudstack-common                     x86_64
> 4.5.0-SNAPSHOT.el6                 cloudstack-develop-ynojima
>   87 M
>  dnsmasq                               x86_64           2.48-13.el6
>                     centos_os_6.5_x86_64                 149 k
>  ebtables                              x86_64           2.0.9-6.el6
>                     centos_os_6.5_x86_64                  95 k
>  flac                                  x86_64           1.2.1-6.1.el6
>                     centos_os_6.5_x86_64                 243 k
>  giflib                                x86_64           4.1.6-3.1.el6
>                     centos_os_6.5_x86_64                  37 k
>  glusterfs-api                         x86_64
> 3.4.0.57rhs-1.el6_5                centos_updates_6.5_x86_64
>   55 k
>  glusterfs-libs                        x86_64
> 3.4.0.57rhs-1.el6_5                centos_updates_6.5_x86_64
>  240 k
>  gpxe-roms-qemu                        noarch           0.9.7-6.10.el6
>                     centos_os_6.5_x86_64                 220 k
>  ipset                                 x86_64           6.11-1.el6
>                     centos_os_6.5_x86_64                  61 k
>  iscsi-initiator-utils                 x86_64
> 6.2.0.873-10.el6                   centos_os_6.5_x86_64
>  686 k
>  jakarta-commons-daemon                x86_64
> 1:1.0.1-8.9.el6                    centos_os_6.5_x86_64
>   45 k
>  jakarta-commons-daemon-jsvc           x86_64
> 1:1.0.1-8.9.el6                    centos_os_6.5_x86_64
>   27 k
>  java-1.5.0-gcj                        x86_64
> 1.5.0.0-29.1.el6                   centos_os_6.5_x86_64
>  139 k
>  java-1.6.0-openjdk                    x86_64
> 1:1.6.0.0-3.1.13.1.el6_5           centos_updates_6.5_x86_64
>   41 M
>  java_cup                              x86_64           1:0.10k-5.el6
>                     centos_os_6.5_x86_64                 197 k
>  jline                                 noarch           0.9.94-0.8.el6
>                     centos_os_6.5_x86_64                  86 k
>  jpackage-utils                        noarch           1.7.5-3.12.el6
>                     centos_os_6.5_x86_64                  59 k
>  keyutils                              x86_64           1.4-4.el6
>                     centos_os_6.5_x86_64                  39 k
>  libICE                                x86_64           1.0.6-1.el6
>                     centos_os_6.5_x86_64                  53 k
>  libSM                                 x86_64           1.2.1-2.el6
>                     centos_os_6.5_x86_64                  37 k
>  libXtst                               x86_64           1.2.1-2.el6
>                     centos_os_6.5_x86_64                  29 k
>  libart_lgpl                           x86_64           2.3.20-5.1.el6
>                     centos_os_6.5_x86_64                  65 k
>  libasyncns                            x86_64           0.8-1.1.el6
>                     centos_os_6.5_x86_64                  24 k
>  libcgroup                             x86_64
> 0.40.rc1-5.el6_5.1                 centos_updates_6.5_x86_64
>  125 k
>  libgcj                                x86_64           4.4.7-4.el6
>                     centos_os_6.5_x86_64                  19 M
>  libgssglue                            x86_64           0.1-11.el6
>                     centos_os_6.5_x86_64                  23 k
>  libmnl                                x86_64           1.0.2-3.el6
>                     centos_os_6.5_x86_64                  21 k
>  libogg                                x86_64
> 2:1.1.4-2.1.el6                    centos_os_6.5_x86_64
>   21 k
>  libsndfile                            x86_64           1.0.20-5.el6
>                     centos_os_6.5_x86_64                 233 k
>  libtirpc                              x86_64
> 0.2.1-6.el6_5.1                    centos_updates_6.5_x86_64
>   79 k
>  libvirt                               x86_64
> 0.10.2-29.el6_5.5                  centos_updates_6.5_x86_64
>  2.3 M
>  libvorbis                             x86_64
> 1:1.2.3-4.el6_2.1                  centos_os_6.5_x86_64
>  168 k
>  libxslt                               x86_64
> 1.1.26-2.el6_3.1                   centos_os_6.5_x86_64
>  452 k
>  lzop                                  x86_64
> 1.02-0.9.rc1.el6                   centos_os_6.5_x86_64
>   50 k
>  netcf-libs                            x86_64
> 0.1.9-4.el6_5.2                    centos_updates_6.5_x86_64
>   52 k
>  nfs-utils                             x86_64           1:1.2.3-39.el6
>                     centos_os_6.5_x86_64                 320 k
>  nfs-utils-lib                         x86_64           1.1.5-6.el6
>                     centos_os_6.5_x86_64                  67 k
>  numad                                 x86_64
> 0.5-9.20130814git.el6              centos_os_6.5_x86_64
>   28 k
>  pulseaudio-libs                       x86_64
> 0.9.21-14.el6_3                    centos_os_6.5_x86_64
>  462 k
>  qemu-img                              x86_64
> 2:0.12.1.2-2.415.el6_5.7           centos_updates_6.5_x86_64
>  588 k
>  qemu-kvm                              x86_64
> 2:0.12.1.2-2.415.el6_5.7           centos_updates_6.5_x86_64
>  1.5 M
>  radvd                                 x86_64           1.6-1.el6
>                     centos_os_6.5_x86_64                  75 k
>  rhino                                 noarch
> 1.7-0.7.r2.2.el6                   centos_os_6.5_x86_64
>  778 k
>  rpcbind                               x86_64           0.2.0-11.el6
>                     centos_os_6.5_x86_64                  51 k
>  seabios                               x86_64           0.6.1.2-28.el6
>                     centos_os_6.5_x86_64                  92 k
>  sgabios-bin                           noarch
> 0-0.3.20110621svn.el6              centos_os_6.5_x86_64
>  6.6 k
>  sinjdoc                               x86_64           0.5-9.1.el6
>                     centos_os_6.5_x86_64                 705 k
>  spice-server                          x86_64
> 0.12.4-6.el6_5.1                   centos_updates_6.5_x86_64
>  344 k
>  tzdata-java                           noarch           2014b-1.el6
>                     centos_updates_6.5_x86_64            147 k
>  usbredir                              x86_64           0.5.1-1.el6
>                     centos_os_6.5_x86_64                  40 k
>  vgabios                               noarch           0.6b-3.7.el6
>                     centos_os_6.5_x86_64                  42 k
>
> Transaction Summary
> ======================================================================================================================================
> Install      54 Package(s)
>
> Total download size: 199 M
> Installed size: 305 M
> Is this ok [y/N]:
>
> 2014-04-17 9:12 GMT-06:00 ilya musayev <ilya.mailing.lists@gmail.com>:
>> Yoshi
>>
>> Any chance you had 1.7 installed and 1.6 came as side effect of something
>> else?
>>
>> rpm -qa | grep java
>>
>> regards
>> ilya
>>
>> On 4/16/14, 5:08 PM, Yoshikazu Nojima wrote:
>>>
>>> Hi,
>>>
>>> I found java6 is installed instead of java7 when CloudStack rpm which
>>> build from master branch  is installed with yum command.
>>>
>>> Rpm spec file specifies java 1.7.0 or later, but it doesn't work.
>>> https://github.com/apache/cloudstack/commit/49a29
>>>
>>> I confirmed my rpm has a requirement for java 1.7.0 or later.
>>> I'm not familiar with rpm spec grammar, but I assume
>>> requirement specification by virtual capability name doesn't accept
>>> version specification. Is it accurate?
>>>
>>> If my understanding is correct, I will create a patch to change
>>> requirement from "java >= 1.7.0" to "java7".
>>>
>>> ===============
>>> yum install cloudstack-agent
>>> Loaded plugins: fastestmirror
>>> Loading mirror speeds from cached hostfile
>>>   * base: mirror.keystealth.org
>>>   * epel: mirrors.kernel.org
>>>   * extras: mirror.keystealth.org
>>>   * updates: mirror.keystealth.org
>>> Setting up Install Process
>>> Resolving Dependencies
>>> --> Running transaction check
>>> ---> Package cloudstack-agent.x86_64 0:4.5.0-SNAPSHOT.el6 will be
>>> installed
>>> --> Processing Dependency: java >= 1.7.0 for package:
>>> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
>>> --> Running transaction check
>>> ---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-5.1.13.3.el6_5 will
>>> be installed
>>> --> Finished Dependency Resolution
>>>
>>> Dependencies Resolved
>>>
>>>
>>> ========================================================================================================
>>>   Package                    Arch           Version
>>>          Repository          Size
>>>
>>> ========================================================================================================
>>> Installing:
>>>   cloudstack-agent           x86_64         4.5.0-SNAPSHOT.el6
>>>          cloudstack          41 M
>>> Installing for dependencies:
>>>   java-1.6.0-openjdk         x86_64         1:1.6.0.0-5.1.13.3.el6_5
>>>          updates             41 M
>>>
>>> Transaction Summary
>>>
>>> ========================================================================================================
>>> Install       2 Package(s)
>>>
>>> Total download size: 82 M
>>> Installed size: 122 M
>>> Is this ok [y/N]:
>>>
>>> ===============
>>>
>>> rpm -qp --requires cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64.rpm
>>> /bin/bash
>>> /bin/sh
>>> /bin/sh
>>> /bin/sh
>>> /usr/bin/python
>>> bridge-utils
>>> cloudstack-common = 4.5.0
>>> config(cloudstack-agent) = 4.5.0-SNAPSHOT.el6
>>> ebtables
>>> ethtool
>>> ipset
>>> iptables
>>> jakarta-commons-daemon
>>> jakarta-commons-daemon-jsvc
>>> java >= 1.7.0
>>> jsvc
>>> libvirt
>>> libvirt-python
>>> openssh-clients
>>> perl
>>> qemu-img
>>> qemu-kvm
>>> rpmlib(CompressedFileNames) <= 3.0.4-1
>>> rpmlib(FileDigests) <= 4.6.0-1
>>> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
>>> rpmlib(VersionedDependencies) <= 3.0.3-1
>>> vconfig
>>> rpmlib(PayloadIsXz) <= 5.2-1
>>
>>

Mime
View raw message