cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: [QUESTION] Debugging CS VMware logic in Eclipse
Date Wed, 16 Apr 2014 06:58:43 GMT
Hi Kelven,

Just wanted to follow up on this.

I was running my scenario with VMware again and I see in VMwareGuru that
CopyCommand is sent to the SSVM.

Do you know if this was changed at some point? When I did a bunch of my
testing in the not-too-distant past, I was seeing my CopyCommands being
sent to the server resource for the hypervisor in question that lives
within the management server. I was able to trace through the logic in
copyTemplateToPrimaryStorage(CopyCommand) and watch my code execute.

Now this command seems to be routed to the SSVM, though. I don't see any
recent changes to VMwareGuru, though. I thought you might have some insight
into this.

Thanks!
Mike


On Tue, Apr 8, 2014 at 12:09 PM, Mike Tutkowski <
mike.tutkowski@solidfire.com> wrote:

> Thanks, Kelven!
>
> Just so I can get a better understanding of this, is there any real-world
> scenario where a customer using VMware would run with storage delegation
> going to the server resource in the management server?
>
> Also, when you say "storage-related commands," do you just mean the
> commands in VmwareStorageProcessor?
>
> Thanks for clarifying this for me, Kelven. This is a bit different from
> how it works with XenServer and KVM and I just want to make sure I have it
> straight in my head. :)
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the
cloud<http://solidfire.com/solution/overview/?video=play>
*(tm)*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message