cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ilya musayev <ilya.mailing.li...@gmail.com>
Subject Re: java6 is installed instead of java7 when CloudStack rpm which build from master branch is installed with yum command.
Date Thu, 17 Apr 2014 15:12:52 GMT
Yoshi

Any chance you had 1.7 installed and 1.6 came as side effect of 
something else?

rpm -qa | grep java

regards
ilya
On 4/16/14, 5:08 PM, Yoshikazu Nojima wrote:
> Hi,
>
> I found java6 is installed instead of java7 when CloudStack rpm which
> build from master branch  is installed with yum command.
>
> Rpm spec file specifies java 1.7.0 or later, but it doesn't work.
> https://github.com/apache/cloudstack/commit/49a29
>
> I confirmed my rpm has a requirement for java 1.7.0 or later.
> I'm not familiar with rpm spec grammar, but I assume
> requirement specification by virtual capability name doesn't accept
> version specification. Is it accurate?
>
> If my understanding is correct, I will create a patch to change
> requirement from "java >= 1.7.0" to "java7".
>
> ===============
> yum install cloudstack-agent
> Loaded plugins: fastestmirror
> Loading mirror speeds from cached hostfile
>   * base: mirror.keystealth.org
>   * epel: mirrors.kernel.org
>   * extras: mirror.keystealth.org
>   * updates: mirror.keystealth.org
> Setting up Install Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package cloudstack-agent.x86_64 0:4.5.0-SNAPSHOT.el6 will be installed
> --> Processing Dependency: java >= 1.7.0 for package:
> cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64
> --> Running transaction check
> ---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-5.1.13.3.el6_5 will
> be installed
> --> Finished Dependency Resolution
>
> Dependencies Resolved
>
> ========================================================================================================
>   Package                    Arch           Version
>          Repository          Size
> ========================================================================================================
> Installing:
>   cloudstack-agent           x86_64         4.5.0-SNAPSHOT.el6
>          cloudstack          41 M
> Installing for dependencies:
>   java-1.6.0-openjdk         x86_64         1:1.6.0.0-5.1.13.3.el6_5
>          updates             41 M
>
> Transaction Summary
> ========================================================================================================
> Install       2 Package(s)
>
> Total download size: 82 M
> Installed size: 122 M
> Is this ok [y/N]:
>
> ===============
>
> rpm -qp --requires cloudstack-agent-4.5.0-SNAPSHOT.el6.x86_64.rpm
> /bin/bash
> /bin/sh
> /bin/sh
> /bin/sh
> /usr/bin/python
> bridge-utils
> cloudstack-common = 4.5.0
> config(cloudstack-agent) = 4.5.0-SNAPSHOT.el6
> ebtables
> ethtool
> ipset
> iptables
> jakarta-commons-daemon
> jakarta-commons-daemon-jsvc
> java >= 1.7.0
> jsvc
> libvirt
> libvirt-python
> openssh-clients
> perl
> qemu-img
> qemu-kvm
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(FileDigests) <= 4.6.0-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(VersionedDependencies) <= 3.0.3-1
> vconfig
> rpmlib(PayloadIsXz) <= 5.2-1


Mime
View raw message