cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From María Noelia Gil <marianoelia....@um.es>
Subject Re: KVM
Date Mon, 03 Mar 2014 20:41:58 GMT
Sorry, I have enabled the debug mode. Then I show a message that I found interesting: 

2014-03-03 20:24:07,979 DEBUG [kvm.resource.LibvirtComputingResource] (main:null) failing
to get physical interface from bridge virbr0, did not find an eth*, bond*, vlan*, em*, or
p*p* in /sys/devices/virtual/net/virbr0/brif

And at the end of the log file shows the following:

2014-03-03 20:24:08,968 DEBUG [cloud.agent.Agent] (Agent-Handler-1:null) Startup task created
2014-03-03 20:24:09,051 DEBUG [cloud.agent.Agent] (Agent-Handler-2:null) Received response:
Seq 0-0:  { Ans: , MgmtId: 268749063393642, via: -1, Ver: v1, Flags: 100000, [{"com.cloud.agent.api.StartupAnswer":{"hostId":0,"pingInterval":60,"result":true,"wait":0}}]
}
2014-03-03 20:24:09,052 DEBUG [cloud.agent.Agent] (Agent-Handler-2:null) Startup task cancelled
2014-03-03 20:24:09,052 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Proccess agent startup
answer, agent id = 0
2014-03-03 20:24:09,052 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Set agent id 0
2014-03-03 20:24:09,062 DEBUG [cloud.agent.Agent] (Agent-Handler-2:null) Adding a watch list
2014-03-03 20:24:09,062 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Startup Response
Received: agent id = 0
2014-03-03 20:24:09,063 DEBUG [cloud.agent.Agent] (agentRequest-Handler-1:null) Request:Seq
-1--1:  { Cmd , MgmtId: -1, via: -1, Ver: v1, Flags: 111, [{"com.cloud.agent.api.ReadyCommand":{"_details":"java.lang.IllegalArgumentException:
Host ***.***.***.*** sent incorrect data center: default","wait":0}}] }
2014-03-03 20:24:09,064 DEBUG [cloud.agent.Agent] (agentRequest-Handler-1:null) Processing
command: com.cloud.agent.api.ReadyCommand
2014-03-03 20:24:09,064 DEBUG [cloud.agent.Agent] (agentRequest-Handler-1:null) Not ready
to connect to mgt server: java.lang.IllegalArgumentException: Host ***.***.***.*** sent incorrect
data center: default
2014-03-03 20:24:09,064 INFO  [cloud.agent.Agent] (AgentShutdownThread:null) Stopping the
agent: Reason = sig.kill
2014-03-03 20:24:09,065 DEBUG [cloud.agent.Agent] (AgentShutdownThread:null) Sending shutdown
to management server
2014-03-03 20:24:09,065 DEBUG [kvm.resource.LibvirtComputingResource] (UgentTask-1:null) Executing:
/usr/share/cloudstack-common/scripts/vm/network/security_group.py get_rule_logs_for_vms 
2014-03-03 20:24:09,149 DEBUG [kvm.resource.LibvirtComputingResource] (UgentTask-1:null) Execution
is successful.
2014-03-03 20:24:09,151 DEBUG [cloud.agent.Agent] (UgentTask-1:null) Sending ping: Seq 0-1:
 { Cmd , MgmtId: -1, via: 0, Ver: v1, Flags: 11, [{"com.cloud.agent.api.PingRoutingWithNwGroupsCommand":{"newGroupStates":{},"newStates":{},"_gatewayAccessible":true,"_vnetAccessible":true,"hostType":"Routing","hostId":0,"wait":0}}]
}

Thanks.

El 03/03/2014, a las 01:09, Marcus <shadowsor@gmail.com> escribió:

> It doesn't look like you've enabled debug, you're only getting WARN
> and INFO messages. Please enable debug.
> 
> On Sun, Mar 2, 2014 at 4:40 PM, María Noelia Gil <marianoelia.gil@um.es> wrote:
>> When I run "CloudStack-setup-agent" shows the following:
>> 
>> Starting to configure your system:
>> Configure Apparmor ...        [OK]
>> Configure Network ...         [OK]
>> Configure Libvirt ...
>> [OK]
>> Configure Firewall ...
>> [OK]
>> Configure Nfs ...             [OK]
>> Configure cloudAgent ...
>> [OK]
>> CloudStack Agent setup is done!
>> 
>> The log file displays the following.
>> 
>> 2014-03-03 00:32:44,320 INFO  [cloud.agent.AgentShell] (main:null) Agent started
>> 2014-03-03 00:32:44,321 INFO  [cloud.agent.AgentShell] (main:null) Implementation
Version is 4.2.1
>> 2014-03-03 00:32:44,322 INFO  [cloud.agent.AgentShell] (main:null) agent.properties
found at /etc/cloudstack/agent/agent.properties
>> 2014-03-03 00:32:44,323 INFO  [cloud.agent.AgentShell] (main:null) Defaulting to
using properties file for storage
>> 2014-03-03 00:32:44,324 INFO  [cloud.agent.AgentShell] (main:null) Defaulting to
the constant time backoff algorithm
>> 2014-03-03 00:32:44,326 INFO  [cloud.utils.LogUtils] (main:null) log4j configuration
found at /etc/cloudstack/agent/log4j-cloud.xml
>> 2014-03-03 00:32:44,384 INFO  [cloud.agent.Agent] (main:null) id is 0
>> 2014-03-03 00:32:44,396 INFO  [resource.virtualnetwork.VirtualRoutingResource] (main:null)
VirtualRoutingResource _scriptDir to use: scripts/network/domr/kvm
>> 2014-03-03 00:32:45,020 WARN  [kvm.resource.LibvirtComputingResource] (main:null)
LibVirt version 0.9.10 required for guest cpu mode, but version 0.9.8 detected, so it will
be disabled
>> 2014-03-03 00:32:45,114 INFO  [kvm.resource.LibvirtComputingResource] (main:null)
No libvirt.vif.driver specified. Defaults to BridgeVifDriver.
>> 2014-03-03 00:32:45,145 INFO  [cloud.agent.Agent] (main:null) Agent [id = 0 : type
= LibvirtComputingResource : zone = default : pod = default : workers = 5 : host = localhost
: port = 8250
>> 2014-03-03 00:32:45,154 INFO  [utils.nio.NioClient] (Agent-Selector:null) Connecting
to localhost:8250
>> 2014-03-03 00:32:45,333 INFO  [utils.nio.NioClient] (Agent-Selector:null) SSL: Handshake
done
>> 2014-03-03 00:32:45,334 INFO  [utils.nio.NioClient] (Agent-Selector:null) Connected
to localhost:8250
>> 2014-03-03 00:32:45,662 INFO  [cloud.serializer.GsonHelper] (Agent-Handler-1:null)
Default Builder inited.
>> 2014-03-03 00:32:45,733 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Proccess
agent startup answer, agent id = 0
>> 2014-03-03 00:32:45,733 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Set agent
id 0
>> 2014-03-03 00:32:45,737 INFO  [cloud.agent.Agent] (AgentShutdownThread:null) Stopping
the agent: Reason = sig.kill
>> 2014-03-03 00:32:45,738 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Startup
Response Received: agent id = 0
>> 
>> I do not get to fix the error.
>> 
>> Thanks.
>> 
>> El 02/03/2014, a las 00:25, Marcus <shadowsor@gmail.com> escribió:
>> 
>>> changing
>> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message