cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <and...@arhont.com>
Subject Re: ACS + RBD = mixed RAW/QCOW2 formats
Date Tue, 25 Mar 2014 15:49:56 GMT

It looks like a similar issue that I am experiencing, but i need to double check the sequence.



I've tested it a few months back, but from what I recall i've managed to go through vm >
snapshot > template > deploy without any issues. However, what I was experiencing is
occasional problems with snapshots, which tend to cause problems for some image types and
not others. 


For instance, I had a volume which always caused an error during snapshot and in addition
to that it caused agent to disconnect from the master leaving the status with Alert. It happened
every time i've tried to snapshot it. I've created another volume and migrated data across
and didn't have any issues. The db entries for both images were identical (in terms of important
fields - not creation/modification dates, etc). 


I will need to find time to do more testing and report back. 


Thanks 


Andrei 


----- Original Message -----

From: "Suresh Sadhu" <Suresh.Sadhu@citrix.com> 
To: dev@cloudstack.apache.org 
Sent: Tuesday, 25 March, 2014 5:44:21 AM 
Subject: RE: ACS + RBD = mixed RAW/QCOW2 formats 

HI, 


Check this below 2 issues and it will give better idea ..why you are seeing this 2 disk formats
and also still issues related RBD base primary storage(ceph) are in open state. 

https://issues.apache.org/jira/browse/CLOUDSTACK-4549 

https://issues.apache.org/jira/browse/CLOUDSTACK-4114 


May I know which version of cloudstack you are using. 

regards 
sadhu 

-----Original Message----- 
From: Andrei Mikhailovsky [mailto:andrei@arhont.com] 
Sent: 25 March 2014 05:51 
To: dev@cloudstack.apache.org 
Subject: ACS + RBD = mixed RAW/QCOW2 formats 

Hello guys, 


Was wondering if anyone noticed that when you create images/vms you sometimes get the wrong
format shown in the database. I've noticed, but couldn't find the correlation yet, that sometimes
I get the QCOW2 disk image format and sometimes the RAW format when ACS stores images on the
RBD primary storage. 


Not sure if this relates to how images are created (from snapshots/templates/image_wizzard).
As a result, i tend to have an issue with volume snapshot creation when incorrect format is
specified. 


Thanks 


Andrei 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message