cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhinandan Prateek <Abhinandan.Prat...@citrix.com>
Subject Re: [VOTE] Apache CloudStack 4.3.0 (sixth round)
Date Fri, 21 Feb 2014 12:48:35 GMT
What I get is that by fixing the pom.xml, maven will not package the
connector.
The dependency for the connector was set to compile time that made the
maven to download the connector at compile time instead of at run-time.
Due to this the connector got packaged.

Now changing it to provided will make maven get the connector for
compilation but  due to expectation that this is available at run-time it
will not be packaged.

-abhi

On 21/02/14 6:01 pm, "Daan Hoogland" <daan.hoogland@gmail.com> wrote:

>sure,
>
>we will need to do something in install instructions as well, do we?
>
>thanks,
>Daan
>
>On Fri, Feb 21, 2014 at 1:28 PM, Abhinandan Prateek
><Abhinandan.Prateek@citrix.com> wrote:
>> Daan,
>>
>>   It seems that the dependency on the connector can be changed so that
>>the
>> connector is not packaged with the product.
>> Once Damodar, who is fixing it provides a patch we can take a call.
>>
>> -abhi
>>
>>
>>
>> On 21/02/14 5:31 pm, "Daan Hoogland" <daan.hoogland@gmail.com> wrote:
>>
>>>Animesh,
>>>
>>>Having followed the legal discussions and remarks from David on these
>>>matters, I will have to retract my +1 and cast a -1 (binding). I
>>>suggest we postpone 4.3 indefinitely awaiting legal advice and
>>>discussion on how to proceed on this list.
>>>
>>>sorry,
>>>Daan
>>>
>>>On Fri, Feb 21, 2014 at 12:16 PM, benoit lair <kurushi4000@gmail.com>
>>>wrote:
>>>> Hi,
>>>>
>>>> I agree with Florin about GRE tunnel. It is very problematic. If i
>>>>can't
>>>> get GRE tunnels working with xenserver 6.2, i won't be able to use the
>>>>ACS
>>>> 4.3
>>>>
>>>> So the jira CLOUDSTACK-5967 is not resolved, isn't it ?
>>>>
>>>> Murali, you said on the Feb 14th (CLOUDSTACK-5967) that if there is a
>>>>new
>>>> RC :
>>>> "Fix is simple, but not sure we can get this into 4.3, given
>>>> its not regression. Will get this in if there is a new RC."
>>>>
>>>> Is it still relevant ?
>>>>
>>>> Regards.
>>>>
>>>> Benoit Lair.
>>>>
>>>>
>>>>
>>>> 2014-02-21 11:29 GMT+01:00 Srikanteswararao Talluri <
>>>> srikanteswararao.talluri@citrix.com>:
>>>>
>>>>> There is a bug filed for live migration on ESXi 5.5.
>>>>> https://issues.apache.org/jira/browse/CLOUDSTACK-6146
>>>>>
>>>>> I feel we need to fix this bug too in 4.3.
>>>>>
>>>>> Thanks,
>>>>> ~Talluri
>>>>>
>>>>> On 20/02/14 11:19 pm, "David Nalley" <david@gnsa.us> wrote:
>>>>>
>>>>> >On Thu, Feb 20, 2014 at 11:23 AM, Chip Childers
>>>>><chipchilders@apache.org>
>>>>> >wrote:
>>>>> >> On Wed, Feb 19, 2014 at 04:25:21AM +0000, Animesh Chaturvedi
>>>>>wrote:
>>>>> >>>
>>>>> >>> [ ] +1  approve
>>>>> >>>
>>>>> >>> [ ] +0  no opinion
>>>>> >>>
>>>>> >>> [ ] -1  disapprove (and reason why)
>>>>> >>>
>>>>> >>
>>>>> >> Given the recently noticed legal issues with the
>>>>>mysql-connector-java
>>>>> >> dependency, I'm -1 (binding) until that is resolved.
>>>>> >>
>>>>> >
>>>>> >I hate to have to issue a -1 (binding) but will do so as well.
>>>>> >
>>>>> >--David
>>>>>
>>>>>
>>>
>>>
>>>
>>>--
>>>Daan
>>
>
>
>
>-- 
>Daan


Mime
View raw message