cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kishan Kavala <Kishan.Kav...@citrix.com>
Subject RE: [VOTE] Apache CloudStack 4.3.0 (fourth round)
Date Thu, 13 Feb 2014 10:59:12 GMT
Daan,
 I couldn't repo CLOUDSTACK-6069 in my regular VPC setup.  Does this happen only when using
mixed setup with Nicira?

> -----Original Message-----
> From: Daan Hoogland [mailto:DHoogland@schubergphilis.com]
> Sent: Thursday, 13 February 2014 2:29 PM
> To: Animesh Chaturvedi; dev@cloudstack.apache.org
> Cc: Kishan Kavala; Murali Reddy; daan Hoogland
> Subject: RE: [VOTE] Apache CloudStack 4.3.0 (fourth round)
> 
> I can confirm that it also exists in master. Unfortunately it is not high on my
> prio list right now. We have a pressing bug hurting us in our production
> systems that I will get out of the way first.
> 
> What I can say is that I am puzzled that my test works in 4.2 and before as I
> instantiate a private gateway with associated network, while the system
> network offering for private gateways has no tags and I have two guest
> networks.
> 
> I will return to this issue when given time.
> 
> Regards,
> Daan
> 
> -----Original Message-----
> From: Animesh Chaturvedi [mailto:animesh.chaturvedi@citrix.com]
> Sent: woensdag 12 februari 2014 11:52
> To: dev@cloudstack.apache.org
> Cc: Kishan Kavala; Murali Reddy; Daan Hoogland; daan Hoogland
> Subject: RE: [VOTE] Apache CloudStack 4.3.0 (fourth round)
> 
> Adding Murali as well.
> 
> Daan I am not sure if there was any specific work done on this during 4.3 to
> cause it to regress.  Did you debug this further?
> 
> Thanks
> Animesh
> 
> 
> 
> > -----Original Message-----
> > From: Daan Hoogland [mailto:daan.hoogland@gmail.com]
> > Sent: Monday, February 10, 2014 11:42 AM
> > To: dev
> > Cc: Kishan Kavala
> > Subject: Re: [VOTE] Apache CloudStack 4.3.0 (fourth round)
> >
> > https://issues.apache.org/jira/browse/CLOUDSTACK-6069
> >
> > I will try in master as well. And look for a solution there.
> >
> > On Mon, Feb 10, 2014 at 8:13 PM, Animesh Chaturvedi
> > <animesh.chaturvedi@citrix.com> wrote:
> > > Daan
> > >
> > > Can you create a tracking bug for this issue? Adding Kishan for his
> > > input
> > >
> > > Animesh
> > >
> > >> -----Original Message-----
> > >> From: Daan Hoogland [mailto:daan.hoogland@gmail.com]
> > >> Sent: Monday, February 10, 2014 10:25 AM
> > >> To: dev
> > >> Subject: Re: [VOTE] Apache CloudStack 4.3.0 (fourth round)
> > >>
> > >> H,
> > >>
> > >> -1 (binding)
> > >>
> > >> I have a backwards compatibility issue with 4.3. It might turn out
> > >> to be a setup thing but I have verified that 4.2.1 works with my setup.
> > >> I have four basic test cases|:
> > >> 1. create network and vm on top - works 2. create bridged network
> > >> and create vm on it - works 3. create a vpc with private gateway
> > >> (and
> > >> ...) - fails 4. create a vpc with nicira based private gateway -
> > >> works
> > >>
> > >> I haven't actually tried 1,2 and 4 on this rc because 3 was always
> > >> giving me the most problems. The others worked on the previous rc.
> > >> Having discussed this with Hugo, we'll probably not stop using 4.3
> > >> if it passes but it needs fixing asap.
> > >>
> > >> setup
> > >> 1 zone
> > >> 1 pod
> > >> 1 cluster
> > >> 2 hosts (xen 6.0.2)
> > >>
> > >> 2 physnets
> > >> - physnet 1 vlan based (Public, Guest(tagged "vlan-based"),
> > >> Management,
> > >> Storage)
> > >> - physnet 2 nicira based (Guest (tagged "nicira-based"))
> > >>
> > >> Now creating a private gateway on the vpc using marvin I get a 530
> > >> server error. I dare to put a -1 here as it is a majority vote. One
> > >> of the things that makes me hesitate is
> > >> 4.2.1 code (succeeding):
> > >> 2014-02-10 15:43:45,621 DEBUG [xen.resource.CitrixResourceBase]
> > >> (DirectAgent-4:null) Creating VLAN 322 on host 10.200.23.41 on
> > >> device
> > >> tunnel0
> > >> 4.3.0 code (failing)
> > >> 2014-02-10 17:33:51,083 DEBUG [c.c.h.x.r.CitrixResourceBase]
> > >> (DirectAgent-4:ctx-6d5f0cd4) Creating VLAN 322 on host 10.200.23.42
> > >> on device tunnel0
> > >>
> > >>
> > >> On Mon, Feb 10, 2014 at 12:28 PM, Nux! <nux@li.nux.ro> wrote:
> > >> > On 08.02.2014 10:56, Nux! wrote:
> > >> >>
> > >> >> On 08.02.2014 00:51, Animesh Chaturvedi wrote:
> > >> >>>
> > >> >>> Hi All,
> > >> >>>
> > >> >>>
> > >> >>> I've created a 4.3.0 release, with the following artifacts
up
> > >> >>> for a
> > >> >>> vote:
> > >> >>
> > >> >>
> > >> >> +1 from me, upgrade from 4.2.1 works fine. Tested with CentOS,
> > >> >> +KVM,
> > >> >> NFS, CLVM, Adv+SG.
> > >> >
> > >> >
> > >> > There might be a problem with the HA engine, please see
> > >> > https://issues.apache.org/jira/browse/CLOUDSTACK-6065
> > >> >
> > >> >
> > >> > --
> > >> > Sent from the Delta quadrant using Borg technology!
> > >> >
> > >> > Nux!
> > >> > www.nux.ro
> > >>
> > >>
> > >>
> > >> --
> > >> Daan
> >
> >
> >
> > --
> > Daan

Mime
View raw message