cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugo Trippaers <h...@trippaers.nl>
Subject Re: Template for Java 7 in Master branch
Date Sat, 08 Feb 2014 12:05:18 GMT
Sheng,

Use the templates build from master (after build 77) from jenkins.buildacloud.org. Those templates
have java 7.

http://jenkins.buildacloud.org/job/build-systemvm-master/

Cheers,

Hugo


On 8 feb. 2014, at 02:10, Sheng Yang <sheng@yasker.org> wrote:

> BTW, the error result in SSVM and CPVM agents fail to start.
> 
> --Sheng
> 
> On Fri, Feb 7, 2014 at 5:10 PM, Sheng Yang <sheng@yasker.org> wrote:
> 
>> Got this error with 4.3 template:
>> 
>> Exception in thread "main" java.lang.UnsupportedClassVersionError:
>> com/cloud/agent/AgentShell : Unsupported major.minor version 51.0
>>        at java.lang.ClassLoader.defineClass1(Native Method)
>>        at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
>>        at
>> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
>>        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
>>        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
>>        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
>>        at java.security.AccessController.doPrivileged(Native Method)
>>        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
>>        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
>>        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
>>        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
>> 
>> I am using Java 7 when compiling(due to following commit), and I guess the
>> above error due to all of our templates using java 6.
>> 
>> commit 49a29ce0cfe0fca535037d0d7e15e399e76ea49f
>> Author: Wido den Hollander <wido@widodh.nl>
>> Date:   Mon Jan 27 10:03:39 2014 +0100
>> 
>>    Switch to Java 7
>> 
>>    We now require at least Java 7 to build and run CloudStack.
>> 
>>    Both the DEB and RPM packaging now also require Java 7 during
>> installation
>>    of the packages.
>> 
>> --Sheng
>> 


Mime
View raw message