cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wilder Rodrigues <WRodrig...@schubergphilis.com>
Subject [4.3.0] Smoke tests of the fourth round RC
Date Sat, 08 Feb 2014 17:43:20 GMT
Hi there guys,

I have been trying to do a smoke test on the 4.3.0 fourth round RC for few hours already unsuccessfully.
I followed the release test procedures wiki and all the checks and builds worked fine. However,
when it comes to start the management server, I get errors about creating bean with name 'lockMasterListener'.
All communications with my DevCloud are working. I ran the deploy DB profile and also did
telnet to the devcloud on port 3306. So, there are no communication issues so far.

I did Google a bit and found few emails describing the same problem, one of them on the 4.4.0-SNAPSHOT
and the tester was Alex Hitchings - community colleague. The emails can be found here: http://comments.gmane.org/gmane.comp.apache.cloudstack.devel/37008

Snippet from my stacktrace:

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'lockMasterListener'
defined in URL [jar:file:/home/wilder/.m2/repository/org/apache/cloudstack/cloud-server/4.3.0/cloud-server-4.3.0.jar!/META-INF/cloudstack/system/spring-server-system-context.xml]:
Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException:
Could not instantiate bean class [com.cloud.server.LockMasterListener]: Constructor threw
exception; nested exception is com.cloud.utils.exception.CloudRuntimeException: Unable to
initialize a connection to the database for locking purposes:
            at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:288)
            at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.autowireConstructor(AbstractAutowireCapableBeanFactory.java:1045)
            at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:949)
            at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:487)
            at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:458)
            at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:295)
            at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:223)
            at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:292)
            at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:194)

And further down a "Connection Refused" as a cause. But DevCloud2 e fine and database as well.
I can deploy the DB as many times as I want... ping to devcloud... telnet on 3306.

2014-02-08 18:07:01.807:WARN::Nested in org.springframework.beans.factory.BeanCreationException:
Error creating bean with name 'lockMasterListener' defined in URL [jar:file:/home/wilder/.m2/repository/org/apache/cloudstack/cloud-server/4.3.0/cloud-server-4.3.0.jar!/META-INF/cloudstack/system/spring-server-system-context.xml]:
Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException:
Could not instantiate bean class [com.cloud.server.LockMasterListener]: Constructor threw
exception; nested exception is com.cloud.utils.exception.CloudRuntimeException: Unable to
initialize a connection to the database for locking purposes: :
java.net.ConnectException: Connection refused
            at java.net.PlainSocketImpl.socketConnect(Native Method)
            at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:327)
            at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:193)
            at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:180)
            at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:385)

My environment:


*         DevCloud2 on VirtualBox 4.3.6

*         A separate VM running Debian Wheezy

The same environment was working yesterday with the 4.3.0 third round RC.

Does anyone have any idea?

Thanks in advance.

With kind regards,
Wilder

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message