cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjeev Neelarapu <sanjeev.neelar...@citrix.com>
Subject RE: Build on 4.3-forward Fails: Shows Failure for Framework-Clustering
Date Thu, 23 Jan 2014 07:56:58 GMT
I am also facing this issue.

-Sanjeev

-----Original Message-----
From: Santhosh Edukulla [mailto:santhosh.edukulla@citrix.com] 
Sent: Thursday, January 23, 2014 1:20 PM
To: dev@cloudstack.apache.org
Subject: Build on 4.3-forward Fails: Shows Failure for Framework-Clustering

Team,

1. We are seeing a build failure for latest 4.3-forward branch code. Below is the error message:

 Apache CloudStack Cloud Engine API ................ SUCCESS [2.351s] [INFO] Apache CloudStack
Core ............................ SUCCESS [4.720s] [INFO] Apache CloudStack Agents ..........................
SUCCESS [4.663s] [INFO] Apache CloudStack Framework - Clustering .......... FAILURE [0.031s]
[INFO] Apache CloudStack Framework


INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 41.245s
[INFO] Finished at: Thu Jan 23 18:16:58 IST 2014 [INFO] Final Memory: 44M/256M [INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project cloud-framework-cluster: Could not resolve dependencies
for project org.apache.cloudstack:cloud-framework-cluster:jar:4.3.0: Failure to find org.apache.cloudstack:cloud-api:jar:tests:4.3.0
in http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will
not be reattempted until the update interval of central has elapsed or updates are forced
-> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with
the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

2. The above behavior was observed on few linux variants viz., rhel,centos,fedora. Tried on
3 different setups and the issue seems to be there on these 3 setups. On mac, it seems to
work.

Tried few steps:
1. providing -U to mvn step
2. Deleted the mentioned package from the home directory m2../ , still the issue persists.

Regards,
Santhosh

Mime
View raw message