cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Sorensen <shadow...@gmail.com>
Subject Re: deployVm with data disk
Date Fri, 10 Jan 2014 05:47:52 GMT
*allocates the root disk*

On Thu, Jan 9, 2014 at 10:47 PM, Marcus Sorensen <shadowsor@gmail.com> wrote:
> To clarify, deploying service offering 'foo' and then
> creating/attaching a disk offering 'bar' afterward works fine, but if
> we try to deploy together, it doesn't interrogate any storage pools
> for capacity on the data disk deploy. The behavior is as if the code
> asks for all storage pools matching 'foo', allocates the data disk,
> and then goes through the same list looking for 'bar', and of course
> matches none.
>
> On Thu, Jan 9, 2014 at 10:45 PM, Marcus Sorensen <shadowsor@gmail.com> wrote:
>> No, we have two primary storages, one tagged "foo", one tagged "bar".
>> We have two disk offerings implementing these. We can verify that data
>> disks deploy properly to both. Then we have a service offering with
>> storage tag "foo". We can deploy a VM with a data disk tagged "foo"
>> but not one named "bar". It's as if the deploy command sees a conflict
>> between storage tags. According to the logs it doesn't even find a
>> storage pool to try, but if we deploy the offering without a data disk
>> it works fine.
>>
>> I spent a little while this evening trying to unravel how the
>> allocators and deployment planner work, but really at this point all I
>> have is the behavior, and it seems to indicate that one cannot deploy
>> a service offering with a data disk that has a non-matching tag.
>>
>> On Thu, Jan 9, 2014 at 10:19 PM, Nitin Mehta <Nitin.Mehta@citrix.com> wrote:
>>> In addition, do check if there are at least 1 PS for each of the tags in
>>> the same cluster.
>>> Pasting the snippet of logs with failure would help. (But do paste the
>>> entire snippet for vm deployment)
>>>
>>>
>>> On 09/01/14 8:14 PM, "Mike Tutkowski" <mike.tutkowski@solidfire.com> wrote:
>>>
>>>>Are you saying there was no primary storage tagged "bar"?
>>>>
>>>>If that is the case, I guess I would expect the deployment of the VM to
>>>>fail because not all of the criteria could be met.
>>>>
>>>>
>>>>On Thu, Jan 9, 2014 at 7:08 PM, Marcus Sorensen <shadowsor@gmail.com>
>>>>wrote:
>>>>
>>>>> Is this a bug (perhaps fixed), or expected behavior?
>>>>>
>>>>> If I create a service offering with storage tag=foo, and a disk
>>>>> offering with storage tag=bar, I cannot provide this disk offering as
>>>>> a data disk to deploy along with this service offering. The root
>>>>> volume gets allocated, and then the data disk fails.
>>>>>
>>>>
>>>>
>>>>
>>>>--
>>>>*Mike Tutkowski*
>>>>*Senior CloudStack Developer, SolidFire Inc.*
>>>>e: mike.tutkowski@solidfire.com
>>>>o: 303.746.7302
>>>>Advancing the way the world uses the
>>>>cloud<http://solidfire.com/solution/overview/?video=play>
>>>>* *
>>>

Mime
View raw message