cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gaurav Aradhye <gaurav.arad...@clogeny.com>
Subject Adding KVM host fails
Date Tue, 21 Jan 2014 14:22:41 GMT
Hello,

I configured a new KVM host on top of Ubuntu (12.04.4) following everything
on [1]. I am facing two issues.

1) When I updated network interfaces with following and rebooted the host,
the original static IP of the host got changed and I had to remove this
change.

# Public network
auto cloudbr0
iface cloudbr0 inet manual
    bridge_ports eth0.200
    bridge_fd 5
    bridge_stp off
    bridge_maxwait 1

# Private network
auto cloudbr1
iface cloudbr1 inet manual
    bridge_ports eth0.300
    bridge_fd 5
    bridge_stp off
    bridge_maxwait 1


2) While trying to add the host to Cloudstack, operation fails with
"Unable to add the host" and the management server log says:


2014-01-21 15:26:31,582 DEBUG [kvm.discoverer.LibvirtServerDiscoverer]
(catalina-exec-17:null) Timeout, to wait for the host connecting to
mgt svr, assuming it is failed
2014-01-21 15:26:31,583 WARN  [cloud.resource.ResourceManagerImpl]
(catalina-exec-17:null) Unable to find the server resources at
http://192.168.100.210
2014-01-21 15:26:31,584 INFO  [utils.exception.CSExceptionErrorCode]
(catalina-exec-17:null) Could not find exception:
com.cloud.exception.DiscoveryException in error code list for
exceptions
2014-01-21 15:26:31,584 WARN  [admin.host.AddHostCmd]
(catalina-exec-17:null) Exception:
com.cloud.exception.DiscoveryException: Unable to add the host
    at com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl.java:798)
    at com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.java:590)
    at org.apache.cloudstack.api.command.admin.host.AddHostCmd.execute(AddHostCmd.java:143)
    at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:158)
    at com.cloud.api.ApiServer.queueCommand(ApiServer.java:514)
    at com.cloud.api.ApiServer.handleRequest(ApiServer.java:372)
    at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:305)
    at com.cloud.api.ApiServlet.doPost(ApiServlet.java:71)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
    at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:555)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
    at org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:889)
    at org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(Http11NioProtocol.java:721)
    at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:2274)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)

    at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:679)
2014-01-21 15:26:31,585 INFO  [cloud.api.ApiServer] (catalina-exec-17:null)
Unable to add the host
2014-01-21 15:26:31,589 DEBUG [cloud.api.ApiServlet]
(catalina-exec-17:null) ===END===  192.168.100.41 -- POST
 command=addHost&response=json&sessionkey=4yR04FYeisMdiNFElfJD%2FezU%2FRE%3D
2014-01-21 15:26:47,341 DEBUG
[storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) Zone 2
is not ready to launch secondary storage VM yet
2014-01-21 15:26:47,762 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl]
(consoleproxy-1:null) Skip capacity scan due to there is no Primary Storage
UPintenance mode
2014-01-21 15:26:55,397 DEBUG
[cloud.network.ExternalDeviceUsageManagerImpl]
(ExternalNetworkMonitor-1:null) External devices stats collector is
running...
2014-01-21 15:26:55,436 INFO  [cloud.ha.HighAvailabilityManagerImpl]
(HA-3:null) checking health of usage server
2014-01-21 15:26:55,438 DEBUG [cloud.ha.HighAvailabilityManagerImpl]
(HA-3:null) usage server running? false, heartbeat: null
2014-01-21 15:26:55,438 WARN  [apache.cloudstack.alerts] (HA-3:null)
 alertType:: 13 // dataCenterId:: 0 // podId:: 0 // clusterId:: null //
message:: No usage server process running


Can someone give me some specific checkpoints to look exactly what is going
wrong and which server resource I am missing?

The qemu/kvm, libvirt versions are well above required.

I have 4.2.1 setup.

1.
https://cloudstack.apache.org/docs/en-US/Apache_CloudStack/4.0.2/html/Installation_Guide/hypervisor-kvm-install-flow.html

Regards,
Gaurav

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message