cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Stevens <wstev...@cloudops.com>
Subject Re: untagged as public vlan tag (4.3)
Date Thu, 02 Jan 2014 17:01:20 GMT
Thank you for your help pointing me in the right direction on this one.

Just a note.  Interestingly, I was able to get it to deploy using the
following in my devcloud.cfg (as per hints in that bug).

"ipranges": [
    {
        "startip": "192.168.80.100",
        "endip": "192.168.80.199",
        "netmask": "255.255.255.0",
        "vlan": "",
        "gateway": "192.168.80.2"
    }
],

I am not sure if it is going to work as if it is untagged (or work at all
in practice), but it deployed.  Figured it is relevant if this is blocking
other people deploying and testing unrelated functionality.


On Thu, Jan 2, 2014 at 11:51 AM, Marcus Sorensen <shadowsor@gmail.com>wrote:

> No, it's definitely the commit mentioned in CLOUDSTACK-5502. Not
> hypervisor specific.
>
> On Thu, Jan 2, 2014 at 9:41 AM, Will Stevens <wstevens@cloudops.com>
> wrote:
> > I am experiencing this bug using Xen, so it may or may not be related to
> > the KVM bug...
> >
> >
> > On Thu, Jan 2, 2014 at 11:39 AM, Will Stevens <wstevens@cloudops.com>
> wrote:
> >
> >> Sorry, this bug is already open for this:
> >> https://issues.apache.org/jira/browse/CLOUDSTACK-5502
> >>
> >>
> >> On Thu, Jan 2, 2014 at 11:37 AM, Will Stevens <wstevens@cloudops.com
> >wrote:
> >>
> >>> Should this be working still?
> >>>
> >>> *My devcloud config has this (and it has forever):*
> >>> "ipranges": [
> >>>     {
> >>>         "startip": "192.168.80.100",
> >>>         "endip": "192.168.80.199",
> >>>         "netmask": "255.255.255.0",
> >>>         "vlan": "untagged",
> >>>         "gateway": "192.168.80.2"
> >>>     }
> >>> ],
> >>>
> >>>
> >>> *When I deploy via devcloud I get the following error:*
> >>> [DEBUG] Executing command line: python
> >>> ../marvin/marvin/deployDataCenter.py -i devcloud.cfg
> >>> Traceback (most recent call last):
> >>>   File "../marvin/marvin/deployDataCenter.py", line 572, in <module>
> >>>     deploy.deploy()
> >>>   File "../marvin/marvin/deployDataCenter.py", line 556, in deploy
> >>>     self.createZones(self.config.zones)
> >>>   File "../marvin/marvin/deployDataCenter.py", line 428, in createZones
> >>>     zoneId)
> >>>   File "../marvin/marvin/deployDataCenter.py", line 167, in
> >>> createVlanIpRanges
> >>>     self.apiClient.createVlanIpRange(vlanipcmd)
> >>>   File
> >>>
> "/mnt/hgfs/palo_alto/cloudstack/tools/marvin/marvin/cloudstackAPI/cloudstackAPIClient.py",
> >>> line 871, in createVlanIpRange
> >>>     response = self.connection.marvinRequest(command,
> >>> response_type=response, method=method)
> >>>   File
> >>>
> "/mnt/hgfs/palo_alto/cloudstack/tools/marvin/marvin/cloudstackConnection.py",
> >>> line 272, in marvinRequest
> >>>     response = jsonHelper.getResultObj(response.json(), response_type)
> >>>   File
> >>> "/mnt/hgfs/palo_alto/cloudstack/tools/marvin/marvin/jsonHelper.py",
> line
> >>> 148, in getResultObj
> >>>     raise cloudstackException.cloudstackAPIException(respname, errMsg)
> >>> cloudstackException.cloudstackAPIException: Execute cmd:
> >>> createvlaniprange failed, due to: errorCode: 431, errorText:Vlan id is
> >>> required when add ip range to the public network
> >>>
> >>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message