cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jayapal Reddy Uradi <jayapalreddy.ur...@citrix.com>
Subject Re: DHCP entry fails to apply on the latest master
Date Wed, 22 Jan 2014 04:51:19 GMT
+users

When ever we see the error 'Unable to contact resource', I suggest to check the host agent
logs (for xen /var/log/SMlog).
It will give you idea of what is going wrong from the router. Most of times there could be
script execution failures.

Adding command to clean up tags on xenserver
xe host-param-clear param-name=tags uuid=[uuid]

-Jayapal

On 22-Jan-2014, at 12:49 AM, Alena Prokharchyk <Alena.Prokharchyk@citrix.com> wrote:

> To fix it, you should cleanup the tags on your xen host, so the MS will
> copy the newest ISO there.
> 
> Sheng, thank you for helping to debug it.
> 
> -Alena.
> 
> On 1/21/14, 11:09 AM, "Nitin Mehta" <Nitin.Mehta@citrix.com> wrote:
> 
>> I also face this issue. Here is the snippet of logs. Please let me know if
>> you need any other info.
>> 
>> 2014-01-21 10:52:46,909 INFO  [c.c.v.VirtualMachineManagerImpl]
>> (Job-Executor-1:ctx-57a7ba8c ctx-933fbba1) Unable to contact resource.
>> com.cloud.exception.ResourceUnavailableException: Resource [DataCenter:1]
>> is unreachable: Unable to apply dhcp entry on router
>>       at 
>> com.cloud.network.router.VirtualNetworkApplianceManagerImpl.applyRules(Vir
>> t
>> ualNetworkApplianceManagerImpl.java:3826)
>>       at 
>> com.cloud.network.router.VirtualNetworkApplianceManagerImpl.applyDhcpEntry
>> (
>> VirtualNetworkApplianceManagerImpl.java:2956)
>>       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>       at 
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:
>> 3
>> 9)
>>       at 
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorIm
>> p
>> l.java:25)
>>       at java.lang.reflect.Method.invoke(Method.java:597)
>> 
>> 
>> 
>> 
>> 
>> 
>> On 21/01/14 11:01 AM, "Alena Prokharchyk" <Alena.Prokharchyk@citrix.com>
>> wrote:
>> 
>>> I¹ve deployed the latest master code, re-deployed the DB and uploaded new
>>> system templates with 4.3 version. After that, UserVm fails to start
>>> because DHCP entry fails to apply on the VR.
>>> Its a xen host deployment, and I¹ve tested that ssh to the VR works just
>>> fine. Sheng, can you please take a look? It happened on a couple of
>>> setups.
>>> 
>>> -Alena.
>> 
> 

Mime
View raw message