cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wei ZHOU <ustcweiz...@gmail.com>
Subject Re: [VOTE] 2rd round of voting for ASF 4.2.1 third RC
Date Fri, 13 Dec 2013 12:10:02 GMT
Santhosh,

It works after running "python setup.py install" from tools/marvin folder.
Thanks.

-Wei


2013/12/13 Santhosh Edukulla <santhosh.edukulla@citrix.com>

> 1. Just get the latest marvin from branch and run "python setup.py
> install" from tools/marvin folder. It should fix those issues.
>
> 2. Make sure you use the configuration as mentioned in below mail.
>
> Santhosh
> ________________________________________
> From: Wei ZHOU [ustcweizhou@gmail.com]
> Sent: Friday, December 13, 2013 4:47 AM
> To: dev@cloudstack.apache.org
> Subject: Re: [VOTE] 2rd round of voting for ASF 4.2.1 third RC
>
> Santhosh,
>
> Please see the following.
>
> [root@centos master(4.2)]# python tools/marvin/marvin/deployDataCenter.py
> -i tools/devcloud/devcloud-advancedsg.cfg
> Traceback (most recent call last):
>   File "tools/marvin/marvin/deployDataCenter.py", line 19, in <module>
>     import configGenerator
>   File
> "/root/git/cloudstack.git/master/tools/marvin/marvin/configGenerator.py",
> line 22, in <module>
>     from marvin.codes import *
> ImportError: No module named codes
>
> I did not test 4.3 and master branch.
>
> -Wei
>
>
> 2013/12/13 Santhosh Edukulla <santhosh.edukulla@citrix.com>
>
> > Wei,
> >
> > What error you are getting when you run the below cmd?  If it is related
> > to configuration, please use the configuration as similar to
> > setup/dev/advanced.cfg, check for logger node and run to see the error
> > disappears.
> >
> > python tools/marvin/marvin/deployDataCenter.py -i
> > tools/devcloud/devcloud-advancedsg.cfg
> >
> > Regards,
> > Santhosh
> > ________________________________________
> > From: Wei ZHOU [ustcweizhou@gmail.com]
> > Sent: Friday, December 13, 2013 3:56 AM
> > To: dev@cloudstack.apache.org
> > Subject: Re: [VOTE] 2rd round of voting for ASF 4.2.1 third RC
> >
> > Abhi,
> > Thanks for your reply.
> >
> > Another issue after commit 55c56b6cc26d4e1f5156b0a6a387594659d271f5 is
> that
> > I can not use devcloud for testing any more.
> >
> > (1) All of the following command will fail when I want to add a zone and
> > host.
> > mvn -P developer -pl tools/devcloud -Ddeploysvr
> > python tools/marvin/marvin/deployDataCenter.py -i
> > tools/devcloud/devcloud.cfg
> > python tools/marvin/marvin/deployDataCenter.py -i
> > tools/devcloud/devcloud-advanced.cfg
> > python tools/marvin/marvin/deployDataCenter.py -i
> > tools/devcloud/devcloud-advancedsg.cfg
> >
> > (2) After I add the host manually, the following error appeared
> > 2013-12-13 00:06:27,939 WARN  [xen.resource.XenServerStorageProcessor]
> > (DirectAgent-42:null) can not create vdi in sr
> > 9f3f9262-3f77-09cc-2df7-0d8475676260
> > 2013-12-13 00:06:27,939 WARN  [xen.resource.XenServerStorageProcessor]
> > (DirectAgent-42:null) Catch Exception
> > com.cloud.utils.exception.CloudRuntimeException for template +  due to
> > com.cloud.utils.exception.CloudRuntimeException: can not create vdi in sr
> > 9f3f9262-3f77-09cc-2df7-0d8475676260
> >
> > This is because of commit 7f9463bb54f19e7676f8c6049d1ebc02330a730f
> > Author: Anthony Xu <anthony.xu@citrix.com>
> > Date:   Tue Dec 3 01:36:24 2013 -0800
> >
> >     put shell scripts to a seperate directory in XS
> >     use same scripts for both XS and XCP
> >
> > In this commit, the directory of vhd-util changed, and
> > copy_vhd_from_secondarystorage.sh changed .
> > (for XCP we use copy_vhd_from_secondarystorage.sh in xenserver/xcposs
> > before, now in xenserver directory.)
> >
> >
> >
> > It is not critical, but we need to fix it.
> >
> >
> > 2013/12/13 Abhinandan Prateek <Abhinandan.Prateek@citrix.com>
> >
> > > Fixed the build script a 3rd round of voting is due now, so please hold
> > on
> > > voting for this round.
> > >
> > > -abhi
> > >
> > > On 13/12/13 10:57 am, "Abhinandan Prateek" <
> > Abhinandan.Prateek@citrix.com>
> > > wrote:
> > >
> > > > The build script explicitly removes the SNAPSHOT from the version
> > before
> > > >it builds.
> > > >AS per CLOUDSTACK-4827 the the xapi version in
> > deps/XenServerJava/pom.xml
> > > >should not change.
> > > >But then I see someone explicitly add the following in
> > > >tools/build/build_asf.sh :
> > > >
> > > >mv deps/XenServerJava/pom.xml.versionsBackup
> deps/XenServerJava/pom.xml
> > > >
> > > >perl -pi -e "s/-SNAPSHOT//" deps/XenServerJava/pom.xml
> > > >perl -pi -e "s/-SNAPSHOT//" tools/apidoc/pom.xml
> > > >
> > > >Can someone comment why the above lines were added ?
> > > >
> > > >
> > > >-abhi
> > > >
> > > >On 13/12/13 10:42 am, "Abhinandan Prateek" <
> > Abhinandan.Prateek@citrix.com
> > > >
> > > >wrote:
> > > >
> > > >>On 12/12/13 10:00 pm, "Wei ZHOU" <ustcweizhou@gmail.com> wrote:
> > > >>
> > > >>>Abhi,
> > > >>>I have two problems
> > > >>>(1) I can not checkout the commit
> > > >>>43350d64ce66e366f08a9fa13ad09bca462b66da,
> > > >>>it looks not exist
> > > >>>(2) the xapi version in deps/XenServerJava/pom.xml should not be
> > changed
> > > >>>when you bump the version from 4.2.1-SNAPSHOT to 4.2.1. (see
> > > >>>CLOUDSTACK-4827)
> > > >>
> > > >>Ok, I can see that the build script is trying to revert back the
> > version
> > > >>to 4.2.1-SNAPSHOT but in the final build the version is not reverted.
> > > >>Will be checking what is causing that.
> > > >>
> > > >>-abhi
> > > >>
> > > >
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message