cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <>
Subject Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC
Date Fri, 20 Dec 2013 14:53:02 GMT

I've done some tests with secondary storage as nfs and S3 and I do not have any issues live
migrating with nfs storage. However, with S3 there is an issue. If the vm is installed from
a template/iso stored on the S3 secondary storage it fails to migrate because ACS passes on
the iso/template details to the migration target host regardless if the iso is attached to
the vm or not. This is not happening with nfs. 

If you have an opportunity, could you please check to see if you are experiencing similar


----- Original Message -----

From: "Pavan Bandarupally" <> 
Sent: Friday, 20 December, 2013 6:12:42 AM 
Subject: RE: [VOTE] 3rd round of voting for ASF 4.2.1 RC 

In 4.2.1 , I have tested the feature where user has the option to choose single part or multi
part upload with S3 store. It worked fine in my environment. The feature works as below: 

If you have a snapshot or template or anything that needs to be uploaded to S3 based secondary
storage, it can be uploaded either by single part upload or multipart upload and what will
be used can be dictated by a global setting [s3.singleupload.max.size: The maximum size limit
for S3 single part upload API(in GB). If it is set to 0, then it means always use multi-part
upload to upload object to S3. If it is set to -1, then it means always use single-part upload
to upload object to S3 ] 

I have taken snapshots which were greater/lesser than the size set in the parameter above
and they got successfully uploaded to S3 store using multipart/singlepart respectively. The
same is the case with templates as well. 

Live migration is something that I haven't tested with S3 store but to my knowledge, I don't
think it has any relationship with S3 store I guess. Once your VM is deployed from a template
on S3 store the template will be first copied to primary store from secondary store for the
VM to be deployed. 

-----Original Message----- 
From: Andrei Mikhailovsky [] 
Sent: Thursday, December 19, 2013 10:20 PM 
Subject: Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC 


Not sure if this is relevant to this release, but the feature list of 4.2.0 and 4.2.1 shows
that S3 is supported for secondary storage. If this feature is broken and can't be used in
production does it not mean that it has to be fixed in the next release? I am not a developer,
so I do not really know the criteria for version releases. 


----- Original Message ----- 

From: "Daan Hoogland" <> 
To: "dev" <> 
Sent: Thursday, 19 December, 2013 3:04:54 PM 
Subject: Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC 


This sounds like a serious issue but not like an issue related to the release. Unless off
course you have been able to get it working in 
4.2.0 and it is now broken. 

If not it will have to move to a future release. 

I do not use s3 based secondary storage so I can't verify. 


On Thu, Dec 19, 2013 at 3:44 PM, Andrei Mikhailovsky <> wrote: 
> Not that I want to delay the release even more, but has anyone tested the S3 Secondary
Storage functionality of the 4.2.1? I can't be the only one with issues. I've tried installing
ACS three times and the issue is reproducable. 
> Things like migration of vms installed from templates or isos stored in S3 is not working.

> 2013-12-10 18:48:28,067 DEBUG [cloud.agent.Agent] (agentRequest-Handler-4:null) Request:Seq
26-349831812: { Cmd , MgmtId: 90520737989049, via: 26, Ver: v1, Flags: 100111, [{"":{"vm":{"id":56,"name":"i-2-56-VM","type":"User","cpus":2,"minSpeed":2800,"maxSpeed":2800,"minRam":2147483648,"maxRam":2147483648,"arch":"x86_64","os":"Apple
Mac OS X 10.6 (32-bit)","bootArgs":"","rebootOnCrash":false,"enableHA":true,"limitCpuUse":false,"enableDynamicallyScaleVm":false,"vncPassword":"5c7980f779d3ffa3","params":{},"uuid":"bd033b3d-f86a-4d6f-bb8c-06e61b7e1d62","disks":[{"data":{"":{"uuid":"6c9c3134-bfcf-4b8f-8508-db7d8fea5404","volumeType":"ROOT","dataStore":{"":{"uuid":"4a1a6908-7c45-3232-a250-550650793b1c","id":9,"poolType":"RBD","host":"","path":"cloudstack","port":6789}},"name":"ROOT-56","size":21474836480,"path":"754a16ec-662c-4303-97f9-3168f1affbfb","volumeId":78,"vmName":"i-2-56-VM","accountId":2,"format":"RAW","id":78,"hypervisorType":"KVM"}},"diskSeq":0,"type":"ROOT"},{"data":{"":{"path":"template/tmpl/2/212/212-2-e6277a31-7fb6-3ca1-9486-c383c9027cdb/ub.iso","origUrl":"","uuid":"75badc3e-ca5e-490c-8450-5f4397c43789","id":212,"format":"ISO","accountId":2,"hvm":true,"displayText":"Ubuntu
Server 12.04.3 64bit","imageDataStore":{"":{"id":11,"uuid":"ee84fa05-3ad5-4822-89fd-0e1817421b19","endPoint":"","bucketName":"cs-secondary","httpsFlag":false,"created":"Dec
10, 2013 3:40:55 PM","enableRRS":false}},"name":"212-2-e6277a31-7fb6-3ca1-9486-c383c9027cdb","hypervisorType":"None"}},"diskSeq":3,"type":"ISO"}],"nics":[{"deviceId":0,"networkRateMbps":200,"defaultNic":true,"uuid":"58903a2b-ef3c-40e5-8b83-99b343ee7474","ip":"","netmask":"","gateway":"","mac":"02:00:30:44:00:01","dns1":"","dns2":"","broadcastType":"Vlan","type":"Guest","broadcastUri":"vlan://578","isolationUri":"vlan://578","isSecurityGroupEnabled":false,"name":"cloudbr0"},{"deviceId":1,"networkRateMbps":200,"defaultNic":false,"uuid":"c0df2b28-e97b-4eda-91e0-71a171ec5509","ip":"","netmask":"","gateway":"","mac":"02:00:6a:3e:00:10","dns1":"","dns2":"212.70.182.

> 2013-12-10 18:48:28,124 WARN [cloud.agent.Agent] (agentRequest-Handler-4:null) Caught:

> java.lang.ClassCastException: cannot be 
> cast to at 
> th( 
> at 
> at 
> est( 
> at 
> at$AgentRequestHandler.doTask( 
> at 
> at 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.j 
> ava:1146) at 
> java.util.concurrent.ThreadPoolExecutor$ 
> java:615) at 
> 2) Spanshoting seems to be totally broken: 
> - any ROOT volume for any instance is always marked as OVM Hypervisor 
> (not KVM) which brakes the normal behaviour of the action buttons 
> filter in scripts/storage.js in the GUI 
> - the "Volume details" Action Filter functions in scripts/storage.js 
> lack some conditions for hypervysor and volume type / state 
> combination 
> - due to those bugs the GUI doesn't provide Take Snapshot / Recurring Snapshot buttons
for most of the volumes (had to create a DATA volume, attach it to VM and then detach for
Snapshot buttons to appear). 
> Andrei 
> ----- Original Message ----- 
> From: "Daan Hoogland" <> 
> To: 
> Sent: Thursday, 19 December, 2013 10:49:33 AM 
> Subject: RE: [VOTE] 3rd round of voting for ASF 4.2.1 RC 
> H, 
> We've started running our custom 4.2.1 build 24 hours ago on our internal projects/employees
system. The build is based on the last fix by Kishan's fix for CLOUDSTACK-5145. The environment
is a hybrid xen/vmware environment with nicira networking and nexenta storage. 
> No issues have come up so far so: 
> +1 (binding) 
> I have done a rebase on the specified commit with a smoke test in a dev-env and am satisfied
with it. 
> Regards, 
> Daan 
> -----Original Message----- 
> From: Srikanteswararao Talluri 
> [] 
> Sent: woensdag 18 december 2013 9:37 
> To: 
> Subject: Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC 
> +1 
> ~Talluri 
> On 18/12/13 10:57 am, "Sailaja Mada" <> wrote: 
>>Validated from the specified commit id. 
>>-----Original Message----- 
>>From: Abhinandan Prateek [] 
>>Sent: 17 December 2013 19:19 
>>To: CloudStack Dev 
>>Subject: [VOTE] 3rd round of voting for ASF 4.2.1 RC 
>>The 4.2.1 is re-spun mainly because the commit that was used to 
>>generate the previous RC did not get pushed to repo. 
>>Following are the particulars to vote for this time around: 
>>commit: 1b2b58fe352a19aee1721bd79b9d023d36e80ec5 
>>List of changes are available in Release Notes, a summary can be 
>>Source release revision 3911 (checksums and signatures are available 
>>at the same location): 
>>PGP release keys (signed using RSA Key ID = 42443AA1): 
>>Vote will be open for 72 hours (until 20 Dec 2013 End of day PST). 
>>For sanity in tallying the vote, can PMC members please be sure to 
>>indicate "(binding)" with their vote? 
>>[ ] +1 approve 
>>[ ] +0 no opinion 
>>[ ] -1 disapprove (and reason why) 

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message