cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <and...@arhont.com>
Subject Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC
Date Fri, 20 Dec 2013 14:55:27 GMT
I don't mind, but I do hope someone else could verify this apart from me. Even though i've
tried it three times on three different clean installs, I could be doing something wrong.


Andrei 

----- Original Message -----

From: "Abhinandan Prateek" <Abhinandan.Prateek@citrix.com> 
To: dev@cloudstack.apache.org 
Sent: Friday, 20 December, 2013 10:47:13 AM 
Subject: Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC 

I think at this time we will just document these as known issues. Any 
comments ? 

-abhi 

On 20/12/13 11:42 am, "Pavan Bandarupally" <Pavan.Bandarupally@citrix.com> 
wrote: 

>In 4.2.1 , I have tested the feature where user has the option to choose 
>single part or multi part upload with S3 store. It worked fine in my 
>environment. The feature works as below: 
> 
>If you have a snapshot or template or anything that needs to be uploaded 
>to S3 based secondary storage, it can be uploaded either by single part 
>upload or multipart upload and what will be used can be dictated by a 
>global setting [s3.singleupload.max.size: The maximum size limit for S3 
>single part upload API(in GB). If it is set to 0, then it means always 
>use multi-part upload to upload object to S3. If it is set to -1, then it 
>means always use single-part upload to upload object to S3 ] 
> 
>I have taken snapshots which were greater/lesser than the size set in the 
>parameter above and they got successfully uploaded to S3 store using 
>multipart/singlepart respectively. The same is the case with templates as 
>well. 
> 
>Live migration is something that I haven't tested with S3 store but to my 
>knowledge, I don't think it has any relationship with S3 store I guess. 
>Once your VM is deployed from a template on S3 store the template will be 
>first copied to primary store from secondary store for the VM to be 
>deployed. 
> 
>Regards, 
>Pavan 
>-----Original Message----- 
>From: Andrei Mikhailovsky [mailto:andrei@arhont.com] 
>Sent: Thursday, December 19, 2013 10:20 PM 
>To: dev@cloudstack.apache.org 
>Subject: Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC 
> 
> 
> 
>Daan, 
> 
>Not sure if this is relevant to this release, but the feature list of 
>4.2.0 and 4.2.1 shows that S3 is supported for secondary storage. If this 
>feature is broken and can't be used in production does it not mean that 
>it has to be fixed in the next release? I am not a developer, so I do not 
>really know the criteria for version releases. 
> 
>Cheers 
> 
>----- Original Message ----- 
> 
>From: "Daan Hoogland" <daan.hoogland@gmail.com> 
>To: "dev" <dev@cloudstack.apache.org> 
>Sent: Thursday, 19 December, 2013 3:04:54 PM 
>Subject: Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC 
> 
>Andrei, 
> 
>This sounds like a serious issue but not like an issue related to the 
>release. Unless off course you have been able to get it working in 
>4.2.0 and it is now broken. 
> 
>If not it will have to move to a future release. 
> 
>I do not use s3 based secondary storage so I can't verify. 
> 
>regards, 
>Daan 
> 
>On Thu, Dec 19, 2013 at 3:44 PM, Andrei Mikhailovsky <andrei@arhont.com> 
>wrote: 
>> Not that I want to delay the release even more, but has anyone tested 
>>the S3 Secondary Storage functionality of the 4.2.1? I can't be the only 
>>one with issues. I've tried installing ACS three times and the issue is 
>>reproducable. 
>> 
>> Things like migration of vms installed from templates or isos stored in 
>>S3 is not working. 
>> 
>> 2013-12-10 18:48:28,067 DEBUG [cloud.agent.Agent] 
>>(agentRequest-Handler-4:null) Request:Seq 26-349831812: { Cmd , MgmtId: 
>>90520737989049, via: 26, Ver: v1, Flags: 100111, 
>>[{"com.cloud.agent.api.PrepareForMigrationCommand":{"vm":{"id":56,"name": 
>>"i-2-56-VM","type":"User","cpus":2,"minSpeed":2800,"maxSpeed":2800,"minRa 
>>m":2147483648,"maxRam":2147483648,"arch":"x86_64","os":"Apple Mac OS X 
>>10.6 
>>(32-bit)","bootArgs":"","rebootOnCrash":false,"enableHA":true,"limitCpuUs 
>>e":false,"enableDynamicallyScaleVm":false,"vncPassword":"5c7980f779d3ffa3 
>>","params":{},"uuid":"bd033b3d-f86a-4d6f-bb8c-06e61b7e1d62","disks":[{"da 
>>ta":{"org.apache.cloudstack.storage.to.VolumeObjectTO":{"uuid":"6c9c3134- 
>>bfcf-4b8f-8508-db7d8fea5404","volumeType":"ROOT","dataStore":{"org.apache 
>>.cloudstack.storage.to.PrimaryDataStoreTO":{"uuid":"4a1a6908-7c45-3232-a2 
>>50-550650793b1c","id":9,"poolType":"RBD","host":"ceph.admin.lv","path":"c 
>>loudstack","port":6789}},"name":"ROOT-56","size":21474836480,"path":"754a 
>>16ec-662c-4303-97f9-3168f1affbfb","volumeId":78,"vmName":"i-2-56-VM","acc 
>>ountId":2,"format":"RAW","id":78,"hypervisorType":"KVM"}},"diskSeq":0,"ty 
>>pe":"ROOT"},{"data":{"org.apache.cloudstack.storage.to.TemplateObjectTO": 
>>{"path":"template/tmpl/2/212/212-2-e6277a31-7fb6-3ca1-9486-c383c9027cdb/u 
>>b.iso","origUrl":"http://www.emigrant.lv/ub.iso","uuid":"75badc3e-ca5e-49 
>>0c-8450-5f4397c43789","id":212,"format":"ISO","accountId":2,"hvm":true,"d 
>>isplayText":"Ubuntu Server 12.04.3 
>>64bit","imageDataStore":{"com.cloud.agent.api.to.S3TO":{"id":11,"uuid":"e 
>>e84fa05-3ad5-4822-89fd-0e1817421b19","endPoint":"s3.admin.lv","bucketName 
>>":"cs-secondary","httpsFlag":false,"created":"Dec 10, 2013 3:40:55 
>>PM","enableRRS":false}},"name":"212-2-e6277a31-7fb6-3ca1-9486-c383c9027cd 
>>b","hypervisorType":"None"}},"diskSeq":3,"type":"ISO"}],"nics":[{"deviceI 
>>d":0,"networkRateMbps":200,"defaultNic":true,"uuid":"58903a2b-ef3c-40e5-8 
>>b83-99b343ee7474","ip":"10.50.1.249","netmask":"255.255.255.0","gateway": 
>>"10.50.1.1","mac":"02:00:30:44:00:01","dns1":"91.224.1.10","dns2":"212.70 
>>.182.77","broadcastType":"Vlan","type":"Guest","broadcastUri":"vlan://578 
>>","isolationUri":"vlan://578","isSecurityGroupEnabled":false,"name":"clou 
>>dbr0"},{"deviceId":1,"networkRateMbps":200,"defaultNic":false,"uuid":"c0d 
>>f2b28-e97b-4eda-91e0-71a171ec5509","ip":"10.50.1.27","netmask":"255.255.2 
>>55.0","gateway":"10.50.1.1","mac":"02:00:6a:3e:00:10","dns1":"91.224.1.10 
>>","dns2":"212.70.182. 
>> 
>> 2013-12-10 18:48:28,124 WARN [cloud.agent.Agent] 
>>(agentRequest-Handler-4:null) Caught: 
>> java.lang.ClassCastException: com.cloud.agent.api.to.S3TO cannot be 
>> cast to com.cloud.agent.api.to.NfsTO at 
>> com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.getVolumePa 
>> th(LibvirtComputingResource.java:3628) 
>> at 
>> com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.execute(Lib 
>> virtComputingResource.java:2985) at 
>> com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.executeRequ 
>> est(LibvirtComputingResource.java:1196) 
>> at com.cloud.agent.Agent.processRequest(Agent.java:525) 
>> at com.cloud.agent.Agent$AgentRequestHandler.doTask(Agent.java:852) 
>> at com.cloud.utils.nio.Task.run(Task.java:83) 
>> at 
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.j 
>> ava:1146) at 
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor. 
>> java:615) at java.lang.Thread.run(Thread.java:701) 
>> 
>> 2) Spanshoting seems to be totally broken: 
>> 
>> - any ROOT volume for any instance is always marked as OVM Hypervisor 
>> (not KVM) which brakes the normal behaviour of the action buttons 
>> filter in scripts/storage.js in the GUI 
>> - the "Volume details" Action Filter functions in scripts/storage.js 
>> lack some conditions for hypervysor and volume type / state 
>> combination 
>> - due to those bugs the GUI doesn't provide Take Snapshot / Recurring 
>>Snapshot buttons for most of the volumes (had to create a DATA volume, 
>>attach it to VM and then detach for Snapshot buttons to appear). 
>> 
>> 
>> 
>> Andrei 
>> 
>> 
>> ----- Original Message ----- 
>> From: "Daan Hoogland" <DHoogland@schubergphilis.com> 
>> To: dev@cloudstack.apache.org 
>> Sent: Thursday, 19 December, 2013 10:49:33 AM 
>> Subject: RE: [VOTE] 3rd round of voting for ASF 4.2.1 RC 
>> 
>> H, 
>> 
>> We've started running our custom 4.2.1 build 24 hours ago on our 
>>internal projects/employees system. The build is based on the last fix 
>>by Kishan's fix for CLOUDSTACK-5145. The environment is a hybrid 
>>xen/vmware environment with nicira networking and nexenta storage. 
>> 
>> No issues have come up so far so: 
>> +1 (binding) 
>> 
>> I have done a rebase on the specified commit with a smoke test in a 
>>dev-env and am satisfied with it. 
>> 
>> Regards, 
>> Daan 
>> 
>> -----Original Message----- 
>> From: Srikanteswararao Talluri 
>> [mailto:srikanteswararao.talluri@citrix.com] 
>> Sent: woensdag 18 december 2013 9:37 
>> To: dev@cloudstack.apache.org 
>> Subject: Re: [VOTE] 3rd round of voting for ASF 4.2.1 RC 
>> 
>> +1 
>> 
>> ~Talluri 
>> 
>> On 18/12/13 10:57 am, "Sailaja Mada" <sailaja.mada@citrix.com> wrote: 
>> 
>>>+1 
>>> 
>>>Validated from the specified commit id. 
>>> 
>>>Thanks, 
>>>Sailaja.M 
>>> 
>>>-----Original Message----- 
>>>From: Abhinandan Prateek [mailto:Abhinandan.Prateek@citrix.com] 
>>>Sent: 17 December 2013 19:19 
>>>To: CloudStack Dev 
>>>Subject: [VOTE] 3rd round of voting for ASF 4.2.1 RC 
>>> 
>>>The 4.2.1 is re-spun mainly because the commit that was used to 
>>>generate the previous RC did not get pushed to repo. 
>>> 
>>>Following are the particulars to vote for this time around: 
>>> 
>>>https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=shortlog;h= 
>>>r 
>>>efs 
>>>/heads/4.2 
>>>commit: 1b2b58fe352a19aee1721bd79b9d023d36e80ec5 
>>> 
>>>List of changes are available in Release Notes, a summary can be 
>>>accessed 
>>>here: 
>>>https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=blob_plain; 
>>>f 
>>>=CH 
>>>ANGES;hb=4.2 
>>> 
>>>Source release revision 3911 (checksums and signatures are available 
>>>at the same location): 
>>>https://dist.apache.org/repos/dist/dev/cloudstack/4.2.1/ 
>>> 
>>>PGP release keys (signed using RSA Key ID = 42443AA1): 
>>>https://dist.apache.org/repos/dist/release/cloudstack/KEYS 
>>> 
>>>Vote will be open for 72 hours (until 20 Dec 2013 End of day PST). 
>>> 
>>>For sanity in tallying the vote, can PMC members please be sure to 
>>>indicate "(binding)" with their vote? 
>>> 
>>>[ ] +1 approve 
>>>[ ] +0 no opinion 
>>>[ ] -1 disapprove (and reason why) 
>>> 
>> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message