cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Sorensen <shadow...@gmail.com>
Subject api incompatibility between 4.1 and 4.2 in ACLs
Date Thu, 07 Nov 2013 21:23:36 GMT
Maybe this has been discussed already, but we seem to have run into an
api incompatibility. In 4.1, you could create ad-hoc ACL rules that
applied to a network. In 4.2, you have to first create an 'ACL list',
then add those rules to the list, then apply the list to a network. Or
so it seems.  This means that applications that are coded to the
cloudstack API and utilize createNetworkACL will break, because the
flow has changed.

Am I correct on this? And if so, shouldn't we have deployed 4.2 as
5.0, since the stated versioning is based on API compatibility?

Mime
View raw message