cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Usman Wyne <uw...@yahoo.com>
Subject Re: Jetty run takes 970 MB of memory and runs out of PermGen space
Date Sun, 03 Nov 2013 22:39:00 GMT
Thanks Daan,
That was indeed missed by me. However adding those still did not resolve the problem. Earlier
I had run it with the following command line
mvn -DjvmArgs="-Xmx2000m -Xms1000m -XX:PermSize=512m -XX:MaxPermSize=512m" -pl :cloud-client-ui
jetty:run  and still got the same problem.
 
I somehow feel that it is stuck in an endless loop. I tried it with -X command and it writes
the attached almost endlessly
Thanks again for your help
Regards
Usman
 
 
 From: Daan Hoogland <daan.hoogland@gmail.com>
To: dev <dev@cloudstack.apache.org>; Usman Wyne <uwyne@yahoo.com> 
Cc: "cloudstack-dev@incubator.apache.org" <cloudstack-dev@incubator.apache.org> 
Sent: Sunday, November 3, 2013 4:12 PM
Subject: Re: Jetty run takes 970 MB of memory and runs out of PermGen space
  

Usman,


You probably forgot the actions at the bottom of step 4:
Modify the following things in eclipse.ini.  The file can be found in
the directory you installed eclipse to.

Change launcher.XXMaxpermSize to 1024m
Add or change to -Xms1024m
Add or change to -Xmx2048m



On Sun, Nov 3, 2013 at 10:21 PM, Usman Wyne <uwyne@yahoo.com> wrote:
>
> Hi dev community
> I apologize upfront if some of these questions would look quite basic, but I
> am new to Cloud Stack and Open Source Software environment and feel that I
> need some guidance.
>
> I am following the directions at this site for basic windows compilation
>
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/Setting+up+a+CloudStack+dev+environment+on+Windows
>
> When I reach this step (Step 13) Build) and I run
>
> mvn -pl :cloud-client-ui jetty:run
>
> I end up with
>
> Exception in thread "Timer-3" java.lang.OutOfMemoryError: PermGen space
>         at java.lang.ClassLoader.defineClass1(Native Method)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:792)
>         at
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
>
> I am attaching the whole output file just in case you find that useful.
> Thanks again for your time and help
> Regards
> Usman Wyne
>
>
Mime
View raw message