cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Venkata SwamyBabu Budumuru <venkataswamybabu.budum...@citrix.com>
Subject Re: [URGENT] Unable to stop/start system VMs after upgrade to 4.2.0
Date Thu, 03 Oct 2013 13:42:17 GMT
What is the hypervisor you are using?

On 03/10/13 6:14 PM, "David Ortiz" <dportiz@outlook.com> wrote:

>If you manually change the vm status in the database would it let you
>destroy it then?
>
>> Date: Thu, 3 Oct 2013 20:22:33 +0800
>> Subject: Re: [URGENT] Unable to stop/start system VMs after upgrade to
>>4.2.0
>> From: indra@sg.or.id
>> To: dev@cloudstack.apache.org; users@cloudstack.apache.org
>> 
>> Dear all,
>> 
>> I managed to fix the VRs issue by destroying the routers and restarting
>>the
>> networks associated to the routers.
>> 
>> Only left is the CPVM, I am not able to stop/destroy it. Any advise?
>> 
>> Looking forward to your reply, thank you.
>> 
>> Cheers.
>> 
>> 
>> 
>> On Thu, Oct 3, 2013 at 8:16 PM, Indra Pramana <indra@sg.or.id> wrote:
>> 
>> > Dear all,
>> >
>> > I am now in the progress of upgrading my CloudStack from 4.1.1 to
>>4.2.0.
>> > Running cloudstack-sysvmadm can restart the SSVM, but failed to
>>restart the
>> > CPVM and all the VRs.
>> >
>> > ====
>> > [1] 3152
>> > root@cs-mgmt-01:~/backup/20131003# tail -f sysvm.log
>> > nohup: ignoring input
>> > /usr/bin/cloudstack-sysvmadm: line 21: /etc/rc.d/init.d/functions: No
>>such
>> > file or directory
>> >
>> > Stopping and starting 1 secondary storage vm(s)...
>> > Done stopping and starting secondary storage vm(s)
>> >
>> > Stopping and starting 1 console proxy vm(s)...
>> > ERROR: Failed to stop console proxy vm with id 1980
>> >
>> > Done stopping and starting console proxy vm(s) .
>> >
>> > Stopping and starting 0 running routing vm(s)...
>> > ====
>> >
>> > SSVM seems OK, I have run health check script and everything is in
>>order.
>> >
>> > VM state of CPVM is running, but state is disconnected. I can't stop
>>or
>> > destroy the CPVM.
>> >
>> > All the VRs are running now but I am not too sure if they are already
>> > using the new 4.2 template or still using the old template, since it
>>seems
>> > the sysvmadm script was unable to detect the virtual routers.
>> >
>> > Anyone can help?
>> >
>> > Thank you.
>> >
> 		 	   		  


Mime
View raw message