cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Santhosh Edukulla <santhosh.eduku...@citrix.com>
Subject RE: is marvin on master broken?
Date Thu, 24 Oct 2013 18:08:07 GMT
Hi Darren,

1. I just ran again using  the latest nosetests-2.7 with  marvin-plugin, marvin-config=<path_to_config
EX:setup/dev/advanced.cfg >, it went fine with no issues. 
 
2. Please check whether the below contents are available under configuration file passed to
marvin or nosetests. Check advanced.cfg under ( setup/dev/ ) for reference. In short, it seems
as per trace, under loadCfg , testClientLogFile which is getting loaded based upon below values
from config is None, leading to further issues and so below trace.

For passing the correct config :

 If we are using nosetests to run the marvin tests, please use --marvin-config="<path to
config file >"  ( or  )

 If we are using deployAndRun, please use --config ="<path to config file >".

    "logger": [
        {
            "name": "TestClient",
            "file": "/tmp/testclient.log"
        },
        {
            "name": "TestCase",
            "file": "/tmp/testcase.log"
        }
    ],
 
3. If issue persists for some reason, please let us know.

4.  Ideally, marvin should have gracefully handled to continue further or gracefully exited
with relevant help text to console if there are any dependencies. It seems there were other
checks also missing.  In any case, we are planning to do some changes to logging facility
under marvin. 

Thanks!
Santhosh
________________________________________
From: Darren Shepherd [darren.s.shepherd@gmail.com]
Sent: Thursday, October 24, 2013 11:00 AM
To: dev@cloudstack.apache.org
Subject: Re: is marvin on master broken?

Traceback (most recent call last):
  File "tools/marvin/marvin/deployDataCenter.py", line 610, in <module>
    deploy.deploy()
  File "tools/marvin/marvin/deployDataCenter.py", line 596, in deploy
    self.loadCfg()
  File "tools/marvin/marvin/deployDataCenter.py", line 557, in loadCfg
    mgtDetails.apiKey, mgtDetails.securityKey = self.registerApiKey()
  File "tools/marvin/marvin/deployDataCenter.py", line 492, in registerApiKey
    listuserRes = self.testClient.getApiClient().listUsers(listuser)
  File "/home/darren/src/cloudstack/tools/marvin/marvin/cloudstackAPI/cloudstackAPIClient.py",
line 505, in listUsers
    response = self.connection.marvinRequest(command,
response_type=response, method=method)
  File "/home/darren/src/cloudstack/tools/marvin/marvin/cloudstackConnection.py",
line 269, in marvinRequest
    self.logging.debug("sending %s request: %s %s" % (method, cmdname,
AttributeError: 'NoneType' object has no attribute 'debug'

On Thu, Oct 24, 2013 at 1:21 AM, Santhosh Edukulla
<santhosh.edukulla@citrix.com> wrote:
> Hello Darren,
>
> Some trace is still missing i believe. i could not see the last stack frame in the below
trace as what lead to this trace?
>
> I just pulled the latest from master branch and used marvin  to deploy few cloudstack
entities and it worked. Can you please provide the command you are using to run marvin tests?
or what command lead to the below trace?
>
> Regards,
> Santhosh
> ________________________________________
> From: Darren Shepherd [darren.s.shepherd@gmail.com]
> Sent: Thursday, October 24, 2013 3:48 AM
> To: dev@cloudstack.apache.org
> Subject: is marvin on master broken?
>
> Whenever I use marvin on master I get
>
> Traceback (most recent call last):
>   File "./tools/marvin/marvin/deployDataCenter.py", line 610, in <module>
>     deploy.deploy()
>   File "./tools/marvin/marvin/deployDataCenter.py", line 596, in deploy
>     self.loadCfg()
>   File "./tools/marvin/marvin/deployDataCenter.py", line 557, in loadCfg
>     mgtDetails.apiKey, mgtDetails.securityKey = self.registerApiKey()
>   File "./tools/marvin/marvin/deployDataCenter.py", line 492, in registerApiKey
>     listuserRes = self.testClient.getApiClient().listUsers(listuser)
>   File "/home/darren/src/cloudstack/tools/marvin/marvin/cloudstackAPI/cloudstackAPIClient.py",
> line 505, in listUsers
>     response = self.connection.marvinRequest(command,
> response_type=response, method=method)
>   File "/home/darren/src/cloudstack/tools/marvin/marvin/cloudstackConnection.py",
> line 269, in marvinRequest
>     self.logging.debug("sending %s request: %s %s" % (method, cmdname,
>
> So it looks like cloudConnection needs a logger passed to the
> constructor and its not being passed?  I've just been hacking up
> ./tools/marvin/marvin/cloudstackConnection.py to work around this.
>
> Darren

Mime
View raw message