cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Santhosh Edukulla <santhosh.eduku...@citrix.com>
Subject RE: is marvin on master broken?
Date Thu, 24 Oct 2013 08:21:15 GMT
Hello Darren,

Some trace is still missing i believe. i could not see the last stack frame in the below trace
as what lead to this trace?

I just pulled the latest from master branch and used marvin  to deploy few cloudstack entities
and it worked. Can you please provide the command you are using to run marvin tests? or what
command lead to the below trace?  

Regards,
Santhosh
________________________________________
From: Darren Shepherd [darren.s.shepherd@gmail.com]
Sent: Thursday, October 24, 2013 3:48 AM
To: dev@cloudstack.apache.org
Subject: is marvin on master broken?

Whenever I use marvin on master I get

Traceback (most recent call last):
  File "./tools/marvin/marvin/deployDataCenter.py", line 610, in <module>
    deploy.deploy()
  File "./tools/marvin/marvin/deployDataCenter.py", line 596, in deploy
    self.loadCfg()
  File "./tools/marvin/marvin/deployDataCenter.py", line 557, in loadCfg
    mgtDetails.apiKey, mgtDetails.securityKey = self.registerApiKey()
  File "./tools/marvin/marvin/deployDataCenter.py", line 492, in registerApiKey
    listuserRes = self.testClient.getApiClient().listUsers(listuser)
  File "/home/darren/src/cloudstack/tools/marvin/marvin/cloudstackAPI/cloudstackAPIClient.py",
line 505, in listUsers
    response = self.connection.marvinRequest(command,
response_type=response, method=method)
  File "/home/darren/src/cloudstack/tools/marvin/marvin/cloudstackConnection.py",
line 269, in marvinRequest
    self.logging.debug("sending %s request: %s %s" % (method, cmdname,

So it looks like cloudConnection needs a logger passed to the
constructor and its not being passed?  I've just been hacking up
./tools/marvin/marvin/cloudstackConnection.py to work around this.

Darren
Mime
View raw message