cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marty Sweet <msweet....@gmail.com>
Subject Re: Bandwidth Shaping - Ubuntu 12.04.3 KVM
Date Mon, 28 Oct 2013 20:25:32 GMT
Hi Marcus,

My earlier email mentioned those configurations, unfortunately not really
complying with what was set out in the compute offering.
After setting the compute offering network limit and stop/starting the VMs
the lines do not appear, and outbound traffic has returned to normal speeds
but inbound is proving an issue.

Also tried rebooting the hypervisor hosts with no success.
How is this traffic shaping implemented, is it just via KVM and virsh, or
does cloudstack run custom tc rules?

Thanks,
Marty


On Mon, Oct 28, 2013 at 8:19 PM, Marcus Sorensen <shadowsor@gmail.com>wrote:

> Check the XML that was generated when the VM in question was started:
>
> # virsh dumpxml i-2-15-VM | egrep "inbound|outbound"
>         <inbound average='2560000' peak='2560000'/>
>         <outbound average='2560000' peak='2560000'/>
>
>
> See if the settings match what you put in your network offering or
> properties (whichever applies to your situation).
>
>
> On Oct 28, 2013 1:44 PM, "Marty Sweet" <msweet.dev@gmail.com> wrote:
>
> > Thanks for the links, while I have set 0 for all the properties the
> > following results still occur:
> >
> > Guest -> Other Server : >900Mbps (As expected)
> > Other Server -> Guest (so inbound to the VM) : Varies depending on
> > hypervisor host: 121, 405, 233, 234Mbps
> >
> > Each hypervisor has 2 NICS in an LACP bond, was working perfectly before
> > 4.2.0 :(
> >
> > Thanks,
> > Marty
> >
> >
> >
> > On Mon, Oct 28, 2013 at 2:44 PM, Marcus Sorensen <shadowsor@gmail.com
> > >wrote:
> >
> > > Yeah, the bandwidth limiting for KVM was dropped into 4.2. You just
> > > need to tweak your settings, whether it's on network offerings or
> > > global.
> > >
> > > On Mon, Oct 28, 2013 at 8:25 AM, Wei ZHOU <ustcweizhou@gmail.com>
> wrote:
> > > > Please read this artcle http://support.citrix.com/article/CTX132019
> > > > Hope this help you.
> > > >
> > > >
> > > > 2013/10/28 Marty Sweet <msweet.dev@gmail.com>
> > > >
> > > >> Hi Guys,
> > > >>
> > > >> Following my upgrade from 4.1.1 -> 4.2.0, I have noticed that VM
> > > traffic is
> > > >> now limited to 2Mbits.
> > > >> My compute offerings were already 1000 for network limit and I have
> > > created
> > > >> new offerings to ensure this wasn't the issue (this fixed it for
> > > someone in
> > > >> the mailing list).
> > > >>
> > > >> Is there anything that I am missing? I can't remember reading this
> as
> > a
> > > bug
> > > >> fix or new feature.
> > > >> If there is a way to resolve or disable it, it would be most
> > > appreciated -
> > > >> have been going round in circles for hours.
> > > >>
> > > >> Thanks,
> > > >> Marty
> > > >>
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message