cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rayees Namathponnan <rayees.namathpon...@citrix.com>
Subject RE: Master broken in KVM ?
Date Wed, 16 Oct 2013 20:08:46 GMT
KVM Master automation runs blocked due to defect https://issues.apache.org/jira/browse/CLOUDSTACK-4865


Regards,
Rayees 

-----Original Message-----
From: Prasanna Santhanam [mailto:tsp@apache.org] 
Sent: Monday, October 14, 2013 10:32 PM
To: dev@cloudstack.apache.org
Subject: Re: Master broken in KVM ?

The actual error was a few lines above what Rayees indicated. I've filed a bug report in CLOUDSTACK-4865.
All the deployVM commands are failing.

On Tue, Oct 15, 2013 at 10:47:45AM +0530, Prasanna Santhanam wrote:
> well deployment was broken but i fixed it over the weekend. this was 
> the configdepot changes that puts the 'host' variable in the agent set 
> to localhost causing the kvm agent to reach back to itself.
> 
> the vm deployment failures i am investigating. the deployvm api always 
> shows XenServer because the API asks (used to?) for the hypervisor 
> argument.
> 
> On Mon, Oct 14, 2013 at 05:03:48PM -0600, Marcus Sorensen wrote:
> > Seems to work. I was able to deploy a VM from the UI at least, so 
> > something in the test perhaps is wrongly choosing hypervisor when 
> > constructing the API call.
> > 
> > This was master as of:
> > commit 8b397f1d427b9e8704ab684cf3c359e5d35e8d91
> > Author: Jessica Wang <jessicawang@apache.org>
> > Date:   Mon Oct 14 13:39:27 2013 -0700
> > 
> > On Mon, Oct 14, 2013 at 3:37 PM, Marcus Sorensen <shadowsor@gmail.com> wrote:
> > > I can pull down the latest and give it a shot. It was working for 
> > > me earlier. Could this be the automation run or test config's fault?
> > >
> > > On Mon, Oct 14, 2013 at 3:28 PM, Rayees Namathponnan 
> > > <rayees.namathponnan@citrix.com> wrote:
> > >> Is it master broken in KVM ?
> > >>
> > >> All deployment failed in KVM master automation run,  result 
> > >> available at 
> > >> http://jenkins.buildacloud.org/view/cloudstack-qa/job/test-smoke-
> > >> matrix/906/
> > >>
> > >> We can get agent and management server logs from 
> > >> http://jenkins.buildacloud.org/job/test-matrix-extended/distro=ce
> > >> ntos63,hypervisor=kvm,profile=kvm-centos63/210/artifact/210.tar.b
> > >> z2
> > >>
> > >> See the deploy VM command, hypervisor type is sending "XenServer" 
> > >> instead of KVM
> > >>
> > >> Oct 14 06:31:46 cloudstack-centos63.fmt.vmops.com local0: 
> > >> 2013-10-14 13:31:46,920 DEBUG [cloud.api.ApiServlet] 
> > >> (catalina-exec-4:ctx-78384906) ===START===  10.208.8.5 -- GET  
> > >> domainid=faed73b4-34d0-11e3-9299-b6c8db337241&zoneid=307e8e7e-c99
> > >> c-4bc9-9706-05d5f4b951d7&apiKey=5ActUcvzhUe5kE8jIzeS8X1xKUEjwUTdw
> > >> YalTEkJiO6ZsFv6kr9BP3IR0qLP9v5gdqztflpZTtdzjFieThsZ7Q&serviceoffe
> > >> ringid=61e8c4cb-d01b-4f3b-8d05-d9489453bb96&displayname=Test+VM&s
> > >> ignature=cMgm7%2BeADcPZGZOit171RMXub1g%3D&templateid=4&response=j
> > >> son&account=test-TestDeployVM-test_deploy_vm-KK2MXV&name=testvm&c
> > >> ommand=deployVirtualMachine&hypervisor=XenServer
> > >>
> > >>
> > >> Regards,
> > >> Rayees
> > >>
> 
> --
> Prasanna.,
> 
> ------------------------
> Powered by BigRock.com

--
Prasanna.,

------------------------
Powered by BigRock.com


Mime
View raw message