cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Soheil Eizadi <seiz...@infoblox.com>
Subject RE: System VM template caching
Date Wed, 09 Oct 2013 04:49:02 GMT
This seems similar to a problem I had on 4.3 Master with System VM creation. If it is the same
problem you can check from API command ListTemplateCommand(), from CloudMonkey and see if
it returns a bogus cached value. Then you know it is the same problem.
-Soheil 

http://mail-archives.apache.org/mod_mbox/cloudstack-dev/201309.mbox/%3C6717EC2E5A665A40A5AF626D7D4FA90625E2E487@x2008mb1.infoblox.com%3E

________________________________________
From: Kelcey Jamison Damage [kelcey@backbonetechnology.com]
Sent: Tuesday, October 08, 2013 12:19 PM
To: Cloud Dev
Subject: [ACS 4.2][Upgrade Issue] System VM template caching

Hi,

Several of us in the community have found that with the 4.2 upgrade, when we download and
install the latest system VM template, CloudStack refuses to use this template for new system
VM creation. CloudStack appears to be usin a cached or master-clone variant of the old template.

This is causing may KVM+ 4.2 users to have broken clouds, A bug report has been filed: https://issues.apache.org/jira/browse/CLOUDSTACK-4826

My question is: Does anyone know where this cached template is stored? when CloudStack goes
to make a new system VM, where does it look first for the template? We have observed through
testing that this is no secondary storage.

Thanks in advance.

Kelcey Damage | Infrastructure Systems Architect
Strategy | Automation | Cloud Computing | Technology Development

Backbone Technology, Inc
604-331-1152 ext. 114




Mime
View raw message