cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francois Gaudreault <fgaudrea...@cloudops.com>
Subject Re: LXC and SSVM/CPVM on the host
Date Tue, 22 Oct 2013 14:05:12 GMT
According to the feature page on the wiki, the KVM images are supposed 
to be used... or maybe I understood it wrong.

Francois

On 10/22/2013, 1:24 AM, Chiradeep Vittal wrote:
> As far as I understand, in an LXC scenario, the system vms are expected to
> run on real hypervisors.
> You can always use the QuickCloud way to not use system vms at all.
>
> On 10/21/13 1:45 PM, "Francois Gaudreault" <fgaudreault@cloudops.com>
> wrote:
>
>> Ok I think we have to look at this further. I'll stop hijacking other
>> threads.
>>
>> I am trying to get the SSVM/CPVM to run on a LXC host. The SSVM/CPVM
>> starts, get IPs, but then CloudStack kill them for some reason. Yes, I
>> use the 4.2 images :
>>
>> 2013-10-21 16:19:21,605 DEBUG [agent.manager.AgentManagerImpl]
>> (AgentManager-Handler-9:null) SeqA 73--1: Processing Seq 73--1:  { Cmd ,
>> MgmtId: -1, via: 73, Ver: v1, Flags: 111,
>> [{"com.cloud.agent.api.ShutdownCommand":{"reason":"sig.kill","wait":0}}] }
>> 2013-10-21 16:19:21,605 INFO  [agent.manager.AgentManagerImpl]
>> (AgentManager-Handler-9:null) Host 73 has informed us that it is
>> shutting down with reason sig.kill and detail null
>> 2013-10-21 16:19:21,606 INFO  [agent.manager.AgentManagerImpl]
>> (AgentTaskPool-11:null) Host 73 is disconnecting with event
>> ShutdownRequested
>> 2013-10-21 16:19:21,609 DEBUG [agent.manager.AgentManagerImpl]
>> (AgentTaskPool-11:null) The next status of agent 73is Disconnected,
>> current status is Up
>> 2013-10-21 16:19:21,609 DEBUG [agent.manager.AgentManagerImpl]
>> (AgentTaskPool-11:null) Deregistering link for 73 with state Disconnected
>> 2013-10-21 16:19:21,609 DEBUG [agent.manager.AgentManagerImpl]
>> (AgentTaskPool-11:null) Remove Agent : 73
>> 2013-10-21 16:19:21,609 DEBUG [agent.manager.ConnectedAgentAttache]
>> (AgentTaskPool-11:null) Processing Disconnect.
>>
>> I transferred the host to KVM, and now the same SSVM/CPVM images are
>> running fine for the last 30min ( so I assume it works fine...).
>> Something seems to be wrong with the LXC side :S
>>
>> Anyone wants to invest some time to troubleshoot? I'll open a ticket also.
>>
>> -- 
>> Francois Gaudreault
>> Architecte de Solution Cloud | Cloud Solutions Architect
>> fgaudreault@cloudops.com
>> 514-629-6775
>> - - -
>> CloudOps
>> 420 rue Guy
>> Montréal QC  H3J 1S6
>> www.cloudops.com
>> @CloudOps_
>>
>


-- 
Francois Gaudreault
Architecte de Solution Cloud | Cloud Solutions Architect
fgaudreault@cloudops.com
514-629-6775
- - -
CloudOps
420 rue Guy
Montréal QC  H3J 1S6
www.cloudops.com
@CloudOps_


Mime
View raw message