cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francois Gaudreault <fgaudrea...@cloudops.com>
Subject Re: KVM systemvm not getting IP
Date Mon, 21 Oct 2013 19:41:33 GMT
Can someone explain why CS tries to load PremiumSecondaryStorageResource 
on a LXC zone?

2013-10-21 15:37:16,697 DEBUG 
[storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) 
VmWare hypervisor configured, telling the ssvm to load the 
PremiumSecondaryStorageResource

I don't even have a VMWare zone anymore in my setup.... I am still 
having issues with my SSVM/CPVM being killed. Do I need to update 
anything on the systemvm image itself if I use non-oss?

Francois

On 10/15/2013, 5:12 PM, Francois Gaudreault wrote:
> Interesting. We built our CS with noredist (nonoss). So I should spin 
> the KVM VM image, update the ISO on it, and then recreate the image? 
> Did I understand you properly?
>
> Thanks!
>
> Francois
>
> On 10/15/2013, 5:10 PM, Marcus Sorensen wrote:
>> This has to do with how your cloudstack was built. Are you using
>> community provided packages? It's looking for the VMWare secondary
>> storage service, which isn't running.  I forget exactly how to fix it,
>> but it's something to do with compiling as '-Dnonoss' or '-Dnoredist'.
>> Something like that. After that you need to reinstall the packages so
>> that the systemvm.iso gets updated to the new code you compiled.
>>
>> On Tue, Oct 15, 2013 at 2:50 PM, Francois Gaudreault
>> <fgaudreault@cloudops.com> wrote:
>>> Apparently, the cloud agent is not able to run on the version of the
>>> systemvm I have. This one:
>>> http://download.cloud.com/templates/4.2/systemvmtemplate-2013-06-12-master-kvm.qcow2.bz2

>>>
>>>
>>> The error is :
>>> 2013-10-15 20:39:25,195 ERROR [cloud.agent.AgentShell] (main:null) 
>>> Unable to
>>> start agent: Resource class not found:
>>> com.cloud.storage.resource.PremiumSecondaryStorageResource due to:
>>> java.lang.ClassNotFoundException:
>>> com.cloud.storage.resource.PremiumSecondaryStorageResource
>>>
>>> After couple time, the VM is killed by CloudStack. I should precise 
>>> I am
>>> running an LXC zone (I understand this type requires the KVM image for
>>> systemvm).
>>>
>>> Francois
>>>
>>>
>>> On 10/12/2013, 10:13 AM, Francois Gaudreault wrote:
>>>> I got the new template, and the VMs are having IPs now. One thing 
>>>> fixed :)
>>>>
>>>> My other problem is regarding libvirt/qemu. My VMs are killed 
>>>> randomly :S
>>>>
>>>> Francois
>>>>
>>>> On 10/11/2013, 10:23 PM, Rajesh Battala wrote:
>>>>> Acton template won't work. In 4.2 there is a new template. You can 
>>>>> check
>>>>> it by checking the release version of it.
>>>>> 4.2  systemvm is generated from debian wheezy.
>>>>>
>>>>> Thanks
>>>>> Rajesh Battala
>>>>>
>>>>> -----Original Message-----
>>>>> From: Francois Gaudreault [mailto:fgaudreault@cloudops.com]
>>>>> Sent: Friday, October 11, 2013 9:48 PM
>>>>> To: dev@cloudstack.apache.org
>>>>> Subject: Re: KVM systemvm not getting IP
>>>>>
>>>>> Hmm... How do I know if I am using the old or new :P
>>>>>
>>>>> I downloaded this one:
>>>>>
>>>>> http://download.cloud.com/templates/acton/acton-systemvm-02062012.qcow2.bz2

>>>>>
>>>>>
>>>>> FG
>>>>>
>>>>> On 10/11/2013, 12:12 PM, Rajesh Battala wrote:
>>>>>> Hi Francois,
>>>>>> Are you using the new systemvm template.
>>>>>> System vm's ip's info (boot args) are passed via socket in 4.2. 
>>>>>> Please
>>>>>> check whether you are using new or old systemvm template.
>>>>>>
>>>>>> Thanks
>>>>>> Rajesh Battala
>>>>>>
>>>>>> -----Original Message-----
>>>>>> From: Francois Gaudreault [mailto:fgaudreault@cloudops.com]
>>>>>> Sent: Friday, October 11, 2013 8:30 PM
>>>>>> To: dev@cloudstack.apache.org
>>>>>> Subject: KVM systemvm not getting IP
>>>>>>
>>>>>> Anyone faced an issue where the KVM system VM doesn't set IPs on
the
>>>>>> network interfaces? In fact there is no interfaces definitions in
>>>>>> /etc/network/interfaces.
>>>>>>
>>>>>> I am using CS 4.2. I re-installed my host to use Ubuntu 13.04 (I

>>>>>> have
>>>>>> the same behavior on CentOS 6).
>>>>>>
>>>>>> -- 
>>>>>> Francois Gaudreault
>>>>>> Architecte de Solution Cloud | Cloud Solutions Architect
>>>>>> fgaudreault@cloudops.com
>>>>>> 514-629-6775
>>>>>> - - -
>>>>>> CloudOps
>>>>>> 420 rue Guy
>>>>>> Montréal QC  H3J 1S6
>>>>>> www.cloudops.com
>>>>>> @CloudOps_
>>>>>>
>>>>>>
>>>>>>
>>>>> -- 
>>>>> Francois Gaudreault
>>>>> Architecte de Solution Cloud | Cloud Solutions Architect
>>>>> fgaudreault@cloudops.com
>>>>> 514-629-6775
>>>>> - - -
>>>>> CloudOps
>>>>> 420 rue Guy
>>>>> Montréal QC  H3J 1S6
>>>>> www.cloudops.com
>>>>> @CloudOps_
>>>>>
>>>>>
>>>>>
>>>>
>>>
>>> -- 
>>> Francois Gaudreault
>>> Architecte de Solution Cloud | Cloud Solutions Architect
>>> fgaudreault@cloudops.com
>>> 514-629-6775
>>> - - -
>>> CloudOps
>>> 420 rue Guy
>>> Montréal QC  H3J 1S6
>>> www.cloudops.com
>>> @CloudOps_
>>>
>>
>
>


-- 
Francois Gaudreault
Architecte de Solution Cloud | Cloud Solutions Architect
fgaudreault@cloudops.com
514-629-6775
- - -
CloudOps
420 rue Guy
Montréal QC  H3J 1S6
www.cloudops.com
@CloudOps_


Mime
View raw message