cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darren Shepherd <darren.s.sheph...@gmail.com>
Subject Re: Upgrade from 4.1.1 to 4.2.0 failed: Error creating bean with name 'apiDBUtils'
Date Mon, 23 Sep 2013 17:45:31 GMT
>From the spring log it seems it can't find
GlobalLoadBalancingRulesService.  That is defined in
componentContext.xml.  Is it possible you have a customized version of
componentContext.xml?  If you did you need to merge your
customizations into the new componentContext.xml shipped with 4.2.

Darren

On Mon, Sep 23, 2013 at 10:21 AM, Animesh Chaturvedi
<animesh.chaturvedi@citrix.com> wrote:
> Can you post the log, mailing list will not take an attachment, so you can create a JIRA
ticket and put in the log as attachment.
>
> Thanks
> Animesh
>
>> -----Original Message-----
>> From: Indra Pramana [mailto:indra@sg.or.id]
>> Sent: Monday, September 23, 2013 10:10 AM
>> To: users@cloudstack.apache.org; dev@cloudstack.apache.org
>> Subject: Upgrade from 4.1.1 to 4.2.0 failed: Error creating bean with
>> name 'apiDBUtils'
>>
>> Dear all,
>>
>> Apologise, reposting this issue since the subject on the earlier thread
>> might not be clearly depicting the problem.
>>
>> I tried to perform upgrade of CloudStack version 4.1.1 to 4.2.0, and I
>> am not able to access the CloudStack GUI after the upgrade.
>>
>> I am able to start the cloudstack-management service:
>>
>> root@cs-mgmt-01:/usr/share# service cloudstack-management start
>>  * Starting CloudStack-specific Tomcat servlet engine cloudstack-
>> management [ OK ]
>>
>> However, I am not able to access the GUI with this error message:
>>
>> =====
>> HTTP Status 404 -
>>
>> type Status report
>>
>> message
>>
>> description The requested resource () is not available.
>> Apache Tomcat/6.0.35
>> =====
>>
>> I am getting this error message on
>> /var/log/cloudstack/management/management-server.log:
>>
>> =====
>> 2013-09-23 21:36:57,003 ERROR [web.context.ContextLoader] (main:null)
>> Context initialization failed
>> org.springframework.beans.factory.BeanCreationException: Error creating
>> bean with name 'apiDBUtils': Injection of autowired dependencies failed;
>> =====
>>
>> Full log can be found here: http://pastebin.com/0FP9itAf
>>
>> Any help is greatly appreciated, thank you.

Mime
View raw message