cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Sorensen <shadow...@gmail.com>
Subject Re: Managed storage with KVM
Date Sat, 21 Sep 2013 04:21:53 GMT
The log says your mgmt server is 192.168.233.10? But you tried to telnet to
192.168.233.1? It might be enough to change that in
/etc/cloudstack/agent/agent.properties, but you may want to edit the config
as well to tell it the real ms IP.
On Sep 20, 2013 10:12 PM, "Mike Tutkowski" <mike.tutkowski@solidfire.com>
wrote:

> Here's what my /etc/network/interfaces file looks like, if that is of
> interest (the 192.168.233.0 network is the NAT network VMware Fusion set
> up):
>
> auto lo
> iface lo inet loopback
>
> auto eth0
> iface eth0 inet manual
>
> auto cloudbr0
> iface cloudbr0 inet static
>     address 192.168.233.10
>     netmask 255.255.255.0
>     network 192.168.233.0
>     broadcast 192.168.233.255
>     dns-nameservers 8.8.8.8
>     bridge_ports eth0
>     bridge_fd 5
>     bridge_stp off
>     bridge_maxwait 1
>     post-up route add default gw 192.168.233.2 metric 1
>     pre-down route del default gw 192.168.233.2
>
>
> On Fri, Sep 20, 2013 at 10:08 PM, Mike Tutkowski <
> mike.tutkowski@solidfire.com> wrote:
>
> > You appear to be correct. This is from the MS log (below). Discovery
> timed
> > out.
> >
> > I'm not sure why this would be. My network settings shouldn't have
> changed
> > since the last time I tried this.
> >
> > I am able to ping the KVM host from the MS host and vice versa.
> >
> > I'm even able to manually kick off a VM on the KVM host and ping from it
> > to the MS host.
> >
> > I am using NAT from my Mac OS X host (also running the CS MS) to the VM
> > running KVM (VMware Fusion).
> >
> > 2013-09-20 19:40:40,141 DEBUG [c.c.h.k.d.LibvirtServerDiscoverer]
> > (613487991@qtp-1659933291-3:ctx-6b28dc48) Timeout, to wait for the host
> > connecting to mgt svr, assuming it is failed
> > 2013-09-20 19:40:40,144 WARN  [c.c.r.ResourceManagerImpl]
> > (613487991@qtp-1659933291-3:ctx-6b28dc48) Unable to find the server
> > resources at http://192.168.233.10
> > 2013-09-20 19:40:40,145 INFO  [c.c.u.e.CSExceptionErrorCode]
> > (613487991@qtp-1659933291-3:ctx-6b28dc48) Could not find exception:
> > com.cloud.exception.DiscoveryException in error code list for exceptions
> > 2013-09-20 19:40:40,147 WARN  [o.a.c.a.c.a.h.AddHostCmd]
> > (613487991@qtp-1659933291-3:ctx-6b28dc48) Exception:
> > com.cloud.exception.DiscoveryException: Unable to add the host
> > at
> >
> com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl.java:778)
> >
> > I do seem to be able to telnet in from my KVM host to the MS host's 8250
> > port:
> >
> > mtutkowski@ubuntu:~$ telnet 192.168.233.1 8250
> > Trying 192.168.233.1...
> > Connected to 192.168.233.1.
> > Escape character is '^]'.
> >
>
>
>
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the
> cloud<http://solidfire.com/solution/overview/?video=play>
> *™*
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message