cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Sorensen <shadow...@gmail.com>
Subject Re: Libvirt-java 0.5.0 has been released
Date Mon, 16 Sep 2013 15:47:43 GMT
There are some minimum requirements in Libvirt for volblockresize if I
recall, but I think all of our platforms include it.

On Mon, Sep 16, 2013 at 5:28 AM, Wido den Hollander <wido@widodh.nl> wrote:
> On 09/16/2013 12:51 PM, Wei ZHOU wrote:
>>
>> Thanks Wido.
>>
>> Do you know the minimal requirement of libvirt if we use libvirt-java
>> 0.5.0
>> ?
>>
>
> There shouldn't be a difference in the required libvirt version. I
> implemented a couple of methods in the bindings which were already in
> libvirt for a long time, but the bindings was just missing them.
>
> Wido
>
>
>>
>> 2013/9/16 Wido den Hollander <wido@widodh.nl>
>>
>>> Hi,
>>>
>>> I worked with the RedHat guys last week to get libvirt-java 0.5.0
>>> released
>>> which has some nice new features for us:
>>>
>>> - Supports different XML on destination host during migration
>>> - Supports resizing volumes
>>> - Supports more snapshot functionalities
>>>
>>> I took the liberty to depend on 0.5.0 in master and also merge in the
>>> code
>>> for the VNC listen, we now no longer listen on 0.0.0.0 for VNC, which was
>>> a
>>> security issue imho.
>>>
>>> The reason I'm bringing this to the list is that we can simplify some
>>> code
>>> around resizing volumes and snapshotting where we currently have some
>>> nasty
>>> scripts to do the work.
>>>
>>> See my commits in libvirt-java: http://www.libvirt.org/git/?p=**
>>>
>>> libvirt-java.git;a=summary<http://www.libvirt.org/git/?p=libvirt-java.git;a=summary>
>>>
>>> So keep in mind libvirt-java has some new features!
>>>
>>> Wido
>>>
>>
>

Mime
View raw message