cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Hoogland <daan.hoogl...@gmail.com>
Subject Re: Configuration table changes and database update
Date Tue, 24 Sep 2013 14:09:59 GMT
I ran into this as well, As I did some change to schema-420-430.sql I
was my primary suspect. It does not have to do with my field though.
Still looking,
Daan

On Tue, Sep 24, 2013 at 2:17 PM, Wei ZHOU <ustcweizhou@gmail.com> wrote:
> I ran a fresh installation on devcloud just now, it works.
> some records in configuration table are introduced by sql files, and
> ConfigurationServerImpl will check and insert the records if not exist.
>
>
> 2013/9/24 Hugo Trippaers <hugo@trippaers.nl>
>
>> Hey all,
>>
>> Noticed an interesting problem today. I was trying to start a management
>> server based on the latest sources in master, but failed. The reason was
>> that the configuration threw an exception that a certain column in the
>> database fit not exist. This column is added during the database upgrade
>> sequence, but apparently the configuration is already accessed before the
>> database upgrade takes place.
>>
>> Seems like a chicken and egg problem to me.
>>
>> Did anybody else run into this problem?
>>
>> Cheers,
>>
>> Hugo

Mime
View raw message