cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Hoogland <daan.hoogl...@gmail.com>
Subject Re: LocalHostEndPoint seems to get called
Date Fri, 27 Sep 2013 10:14:37 GMT
Min, I started the MS with the hosts and the ssvm running and while it
was registered as running in the db. It still keeps reporting the ssvm
as not running:

INFO  [c.c.h.x.d.XcpServerDiscoverer] (AgentTaskPool-1:ctx-e0e62e7a)
Host: mccdxen2 connected with hypervisor type: XenServer. Checking
CIDR...
INFO  [c.c.a.m.DirectAgentAttache] (AgentTaskPool-1:ctx-e0e62e7a)
StartupAnswer received 1 Interval = 60
INFO  [c.c.h.x.r.CitrixResourceBase] (DirectAgent-2:null) Host
10.200.23.42 OpaqueRef:78780f36-0f5a-10d8-b037-2e9e26e1d29c: Host
10.200.23.42 is already setup.
INFO  [c.c.n.s.SecurityGroupListener] (AgentTaskPool-1:ctx-e0e62e7a)
Received a host startup notification
INFO  [c.c.n.s.SecurityGroupListener] (AgentTaskPool-1:ctx-e0e62e7a)
Scheduled network rules cleanup, interval=2334
INFO  [c.c.n.s.SecurityGroupListener] (AgentTaskPool-1:ctx-e0e62e7a)
Received a host startup notification
INFO  [c.c.h.x.d.XcpServerDiscoverer] (AgentTaskPool-2:ctx-a3209637)
Host: mccdxen1 connected with hypervisor type: XenServer. Checking
CIDR...
INFO  [c.c.a.m.DirectAgentAttache] (AgentTaskPool-2:ctx-a3209637)
StartupAnswer received 2 Interval = 60
INFO  [c.c.h.x.r.CitrixResourceBase] (DirectAgent-1:null) Host
10.200.23.41 OpaqueRef:04b11bd1-ff1b-d2e2-f0f7-c70d7f8dc58e: Host
10.200.23.41 is already setup.
INFO  [o.a.c.s.d.p.DefaultHostListener] (AgentTaskPool-1:ctx-e0e62e7a)
Connection established between
org.apache.cloudstack.storage.datastore.PrimaryDataStoreImpl@6fd511e2
host + 1
INFO  [c.c.n.s.SecurityGroupListener] (AgentTaskPool-2:ctx-a3209637)
Received a host startup notification
INFO  [c.c.n.s.SecurityGroupListener] (AgentTaskPool-2:ctx-a3209637)
Scheduled network rules cleanup, interval=2080
INFO  [c.c.n.s.SecurityGroupListener] (AgentTaskPool-2:ctx-a3209637)
Received a host startup notification
INFO  [o.a.c.s.d.p.DefaultHostListener] (AgentTaskPool-2:ctx-a3209637)
Connection established between
org.apache.cloudstack.storage.datastore.PrimaryDataStoreImpl@479eb52a
host + 2
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint
INFO  [o.a.c.s.e.DefaultEndPointSelector] (StatsCollector-1:null) No
running ssvm is found, so command will be sent to LocalHostEndPoint

is this a bug or am i missing some architectural quirk?

regards,
Daan

On Thu, Sep 26, 2013 at 6:36 PM, Daan Hoogland <daan.hoogland@gmail.com> wrote:
> The state is 'RUNNING' not 'Up' . Maybe it is me out racing the
> computer. so don't deepdive. I just thought it was weird I got this
> message while the ssvm was up.
>
> once again, no hinder, Min. Thanks
>
> On Thu, Sep 26, 2013 at 6:27 PM, Min Chen <min.chen@citrix.com> wrote:
>> I am only aware that before ssvm is up, you will see such message in
>> StatCollector, but that is no hurt. I don't understand why you encountered
>> this even if your ssvm is up? Is your s-1-VM entry in host db table is in
>> Up state? Are you using devcloud or real hypervisor in your setup? We may
>> need detailed log to figure out what is going on here in your case.
>>
>> Thanks
>> -min
>>
>> On 9/26/13 6:39 AM, "Daan Hoogland" <daan.hoogland@gmail.com> wrote:
>>
>>>I get "No running ssvm is found, so command will be sent to
>>>LocalHostEndPoint" while I can see and log into a machine called
>>>s-1-VM which has state 'RUNNING' in the database. Is there some
>>>relation? I never though much of it as it does not seem to be the
>>>first thing stopping me usually.
>>>
>>>On Wed, Sep 25, 2013 at 11:20 PM, Edison Su <Edison.su@citrix.com> wrote:
>>>>
>>>>
>>>>> -----Original Message-----
>>>>> From: Darren Shepherd [mailto:darren.s.shepherd@gmail.com]
>>>>> Sent: Wednesday, September 25, 2013 12:38 PM
>>>>> To: dev@cloudstack.apache.org
>>>>> Subject: LocalHostEndPoint seems to get called
>>>>>
>>>>> While I'm doing development and restarting things and what not, it
>>>>>seems
>>>>> often storage commands get routed to LocalHostEndPoint.  This seems
>>>>>bad.  I
>>>>> don't have sudo setup for my user on my laptop, so things like "Unable
>>>>>to
>>>>> create local folder for:
>>>>> /mnt/secStorage/64d6e26f-e656-3ba3-908f-ce6610ede011 in order to mount
>>>>> nfs://192.168.3.134:/exports/secondary1" fail.  But the bigger problem
>>>>>is,
>>>>> shouldn't that not happen at all.  It seems like in a normal setup it
>>>>>should
>>>>> never try to use LocalHostEndpoint.  Do I have some setting flipped
>>>>>that is
>>>>> enabling that?
>>>>
>>>> The current code has bug if ssvm agent is not in the up state, then
>>>>template downloading will likely choose localhostendpoint to download
>>>>template.
>>>> Localhostendpoint should only be used to download system vm template.
>>>>
>>>>>
>>>>> Seems like with the current code you might accidentally mount
>>>>>secondary to
>>>>> the management server if the conditions are right...
>>>>>
>>>>> Darren
>>

Mime
View raw message