cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nguyen Anh Tu <ng.t...@gmail.com>
Subject Re: [GSoC] Can not access SSVM + CPVM with KVM + Openvswitch
Date Fri, 06 Sep 2013 01:20:36 GMT
Hi guys,

The problem is clearer now. I logged to SSVM and CPVM and saw that they
didn't receive IP addresses. Log on MS show that:
http://pastebin.com/n2H4Givm

Any hint?

Thanks for any help :-)


2013/9/6 Musayev, Ilya <imusayev@webmd.net>

> Tuna,
>
> Instead of SSH, have you considered launching a console and logging in as
> root? Password for root is 6m1ll10n
>
> In the future, when posting errors, try including 20 -30 lines above the
> actual exception as there maybe (and usually are) the pointers to the issue.
>
> Regards
> ilya
>
> > -----Original Message-----
> > From: Nguyen Anh Tu [mailto:ng.tuna@gmail.com]
> > Sent: Thursday, September 05, 2013 11:13 AM
> > To: dev@cloudstack.apache.org
> > Cc: Hugo Trippaers
> > Subject: Re: [GSoC] Can not access SSVM + CPVM with KVM + Openvswitch
> >
> > Ah. Finally error happens:
> >
> > 2013-09-05 22:10:05,748 WARN
> >  [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null)
> > Exception while trying to start secondary storage vm
> > com.cloud.exception.AgentUnavailableException: Resource [Host:1] is
> > unreachable: Host 1: Unable to start instance due to Unable to start
> > VM[SecondaryStorageVm|s-1-VM] due to error in finalizeStart, not retrying
> > at
> > com.cloud.vm.VirtualMachineManagerImpl.advanceStart(VirtualMachineMa
> > nagerImpl.java:946)
> > at
> > com.cloud.vm.VirtualMachineManagerImpl.start(VirtualMachineManagerIm
> > pl.java:557)
> > at
> > com.cloud.vm.VirtualMachineManagerImpl.start(VirtualMachineManagerIm
> > pl.java:550)
> > at
> > com.cloud.storage.secondary.SecondaryStorageManagerImpl.startSecStorag
> > eVm(SecondaryStorageManagerImpl.java:265)
> > at
> > com.cloud.storage.secondary.SecondaryStorageManagerImpl.allocCapacity(
> > SecondaryStorageManagerImpl.java:690)
> > at
> > com.cloud.storage.secondary.SecondaryStorageManagerImpl.expandPool(S
> > econdaryStorageManagerImpl.java:1297)
> > at
> > com.cloud.secstorage.PremiumSecondaryStorageManagerImpl.scanPool(Pre
> > miumSecondaryStorageManagerImpl.java:123)
> > at
> > com.cloud.secstorage.PremiumSecondaryStorageManagerImpl.scanPool(Pre
> > miumSecondaryStorageManagerImpl.java:50)
> > at
> > com.cloud.vm.SystemVmLoadScanner.loadScan(SystemVmLoadScanner.java
> > :104)
> > at
> > com.cloud.vm.SystemVmLoadScanner.access$100(SystemVmLoadScanner.ja
> > va:33)
> > at
> > com.cloud.vm.SystemVmLoadScanner$1.reallyRun(SystemVmLoadScanner.j
> > ava:81)
> > at
> > com.cloud.vm.SystemVmLoadScanner$1.run(SystemVmLoadScanner.java:72
> > )
> > at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> > at
> > java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:35
> > 1)
> > at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178)
> > at
> > java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.ac
> > cess$301(ScheduledThreadPoolExecutor.java:178)
> > at
> > java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.ru
> > n(ScheduledThreadPoolExecutor.java:293)
> > at
> > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.jav
> > a:1145)
> > at
> > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.ja
> > va:615)
> > at java.lang.Thread.run(Thread.java:722)
> > Caused by: com.cloud.utils.exception.ExecutionException: Unable to start
> > VM[SecondaryStorageVm|s-1-VM] due to error in finalizeStart, not retrying
> > at
> > com.cloud.vm.VirtualMachineManagerImpl.advanceStart(VirtualMachineMa
> > nagerImpl.java:913)
> > ... 20 more
> >
> > Two system vms are destroyed and created new.
> >
> >
> > 2013/9/5 Nguyen Anh Tu <ng.tuna@gmail.com>
> >
> > > Hi guys,
> > >
> > > I'm using an unofficial version ACS 4.1 (sdnextensions branch). I
> > > build my own cloud-agent package and install successfully into a kvm
> > > host and add this host success with two NICs: cloudbr0 (Management,
> > > Storage) and cloudbr1 (Guest, Public). I use openvswitch, follow Hugo's
> > guide here:
> > >
> > https://cwiki.apache.org/confluence/display/CLOUDSTACK/KVM+with+Ope
> > nVS
> > > witch
> > >
> > > SSVM and CPVM start normally but I can not ping or ssh into via
> > > local-link
> > > (169.254.0.0/16) although both of them are already allocated IP
> > > addresses. On MS, local-link nic is cloud0 (169.254.0.1).
> > >
> > > No error log happen. In DB, they are consistently in starting state,
> > > not running.
> > >
> > > Anyone can help?
> > >
> > > --
> > >
> > > N.g.U.y.e.N.A.n.H.t.U
> > >
> >
> >
> >
> > --
> >
> > N.g.U.y.e.N.A.n.H.t.U
>
>


-- 

N.g.U.y.e.N.A.n.H.t.U

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message