cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: Building Documents with publican
Date Thu, 15 Aug 2013 18:09:56 GMT
Looks like the file reference is wrong (two .xml parts):

removed-api-4.2.xml.xml

I changed it and plan to rebuild. I did find removed-api-4.2.xml (one .xml)
in the proper folder.


On Thu, Aug 15, 2013 at 12:04 PM, Mike Tutkowski <
mike.tutkowski@solidfire.com> wrote:

> It looks like my build did eventually fail:
>
> Processing file tmp/en-US/xml_tmp/writing-new-documentation.xml ->
> tmp/en-US/xml/writing-new-documentation.xml
>  Processing file tmp/en-US/xml_tmp/xenserver-maintenance-mode.xml ->
> tmp/en-US/xml/xenserver-maintenance-mode.xml
> Processing file tmp/en-US/xml_tmp/xenserver-topology-req.xml ->
> tmp/en-US/xml/xenserver-topology-req.xml
>  Processing file tmp/en-US/xml_tmp/zone-add.xml ->
> tmp/en-US/xml/zone-add.xml
> Beginning work on en-US
> FATAL ERROR: XInclude:1604 in whats-new.xml on line 49: could not load
> removed-api-4.2.xml.xml, and no fallback was found
>  at /opt/local/bin/publican line 936
> mtutkowski-lt:docs mtutkowski$
>
>
>
> On Thu, Aug 15, 2013 at 11:53 AM, Wei ZHOU <ustcweizhou@gmail.com> wrote:
>
>> You can follow what Prasanna do in jenkins.
>>
>> Have a look at http://linux.die.net/man/1/publican
>>
>> 2013/8/15 Mike Tutkowski <mike.tutkowski@solidfire.com>
>>
>> > I'm new to Publican, as well.
>> >
>> > When I run the following:
>> >
>> > c:\docs\en-US>publican build --formats=test --langs=en-US
>> >
>> > I get the following error message:
>> >
>> > Config file not found: publican.cfg. at script/publican line 689
>> >
>> > Unfortunately I don't know much about Publican. I'm just trying to
>> document
>> > the storage plug-in I developed for 4.2. :)
>> >
>> > Any thoughts on this one?
>> >
>> > Thanks!
>> >
>> >
>> > On Thu, Aug 15, 2013 at 12:31 AM, Prasanna Santhanam <tsp@apache.org>
>> > wrote:
>> >
>> > > On jenkins this is what is used:
>> > >
>> > > cp -R /usr/share/publican/Common_Content Common_Content
>> > > cp -R docs/publican-cloudstack Common_Content/cloudstack
>> > > (cd docs && publican build --config=publican-adminguide.cfg --formats
>> > > html,pdf --langs en-US --common_content=./Common_Content)
>> > > for format in html ; do tar cjf
>> > > "cloudstack-adminguide-en-US-$format.tar.bz2" -C
>> > "docs/tmp/en-US/$format" .
>> > > ; done
>> > > cp docs/tmp/en-US/pdf/* .
>> > >
>> > >
>> > > On Thu, Aug 15, 2013 at 07:22:32AM +0100, Marty Sweet wrote:
>> > > > Hi Jessica,
>> > > >
>> > > > Should I try to fix these errors? I can't see any build tests on
>> > Jenkins
>> > > > which are failing but that does seem to be looking at another
>> source,
>> > > where
>> > > > is this picked up from?
>> > > >
>> > > > Thanks,
>> > > > Marty
>> > > >
>> > > > On Wednesday, August 14, 2013, Jessica Tomechak wrote:
>> > > >
>> > > > > Marty,
>> > > > > These errors are caused by files being included in the docs twice
>> as
>> > > well
>> > > > > as links pointing to destinations that aren't included in the
same
>> > > book. I
>> > > > > have a page on this in the project wiki.
>> > > > >
>> > > > >
>> > > > >
>> > >
>> >
>> https://cwiki.apache.org/confluence/display/CLOUDSTACK/Publican+Troubleshooting+Guide
>> > > > >
>> > > > > In the end, the root cause is people adding/changing things in
the
>> > docs
>> > > > > repo without doing a test build locally in publican first.
>> > > > >
>> > > > > Jessica T.
>> > > > > ________________________________________
>> > > > > From: Marty Sweet [msweet.dev@gmail.com <javascript:;>]
>> > > > > Sent: Wednesday, August 14, 2013 11:18 AM
>> > > > > To: dev@cloudstack.apache.org <javascript:;>
>> > > > > Subject: Building Documents with publican
>> > > > >
>> > > > > Hi,
>> > > > >
>> > > > > I am trying to build the documentation from the latest git pull.
>> > After
>> > > > > running the following, lots of processing file entries appear,
>> then
>> > the
>> > > > > following errors:
>> > > > >
>> > > > > marty@devbox:~/workspace/cloudstack/docs$ publican build
>> --formats
>> > > html
>> > > > > --langs en-US
>> > > > > --common_content=/home/marty/workspace/cloudstack/Common_Content
>> > > > > Setting up en-US
>> > > > > Processing file tmp/en-US/xml/Common_Content/Conventions.xml
->
>> > > > > tmp/en-US/xml/Common_Content/Conventions.xml
>> > > > > Processing file tmp/en-US/xml/Common_Content/Feedback.xml ->
>> > > > > tmp/en-US/xml/Common_Content/Feedback.xml
>> > > > > Processing file tmp/en-US/xml_tmp/xenserver-topology-req.xml
->
>> > > > > tmp/en-US/xml/xenserver-topology-req.xml
>> > > > > Processing file tmp/en-US/xml_tmp/zone-add.xml ->
>> > > > > tmp/en-US/xml/zone-add.xml
>> > > > >
>> > > > > Beginning work on en-US
>> > > > > Validation failed:
>> > > > > hypervisor-support-for-primarystorage.xml:6: validity error :
ID
>> > > > > hypervisor-support-for-primarystorage already defined
>> > > > > add-remove-nic.xml:31: validity error : ID prereq-addnic already
>> > > defined
>> > > > > api-throttling.xml:6: validity error : ID api-throttling already
>> > > defined
>> > > > > api-throttling.xml:30: validity error : ID
>> api-throttling-configure
>> > > already
>> > > > > defined
>> > > > > api-throttling.xml:61: validity error : ID
>> api-throttling-limitations
>> > > > > already defined
>> > > > > globally-configured-limits.xml:6: validity error : ID
>> > > > > globally-configured-limits already defined
>> > > > > configure-package-repository.xml:28: validity error : IDREF
>> attribute
>> > > > > linkend references an unknown ID "sect-source-builddebs"
>> > > > > management-server-install-multi-node.xml:30: validity error :
>> IDREF
>> > > > > attribute linkend references an unknown ID "sect-source-builddebs"
>> > > > > using-netscaler-load-balancers.xml:41: validity error : IDREF
>> > attribute
>> > > > > linkend references an unknown ID "external-guest-lb-integration"
>> > > > > configure-package-repository.xml:28: validity error : IDREF
>> attribute
>> > > > > linkend references an unknown ID "sect-source-buildrpm"
>> > > > > management-server-install-multi-node.xml:30: validity error :
>> IDREF
>> > > > > attribute linkend references an unknown ID "sect-source-buildrpm"
>> > > > >
>> > > > >
>> > > > > Anyone got any ideas? I don't understand the docs folder well
>> enough
>> > > yet to
>> > > > > make sense of these errors.
>> > > > >
>> > > > > Thanks,
>> > > > > Marty
>> > > > >
>> > >
>> > > --
>> > > Prasanna.,
>> > >
>> > > ------------------------
>> > > Powered by BigRock.com
>> > >
>> > >
>> >
>> >
>> > --
>> > *Mike Tutkowski*
>> > *Senior CloudStack Developer, SolidFire Inc.*
>> > e: mike.tutkowski@solidfire.com
>> > o: 303.746.7302
>> > Advancing the way the world uses the
>> > cloud<http://solidfire.com/solution/overview/?video=play>
>> > *™*
>> >
>>
>
>
>
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the cloud<http://solidfire.com/solution/overview/?video=play>
> *™*
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the
cloud<http://solidfire.com/solution/overview/?video=play>
*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message