cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wei ZHOU <ustcweiz...@gmail.com>
Subject Re: Template Problem
Date Thu, 29 Aug 2013 22:16:36 GMT
Chiradeep, Thanks.
I cannot give more information as the environment has been cleaned.
Maybe Soheil can. I think it is the same issue.


2013/8/29 Chiradeep Vittal <Chiradeep.Vittal@citrix.com>

> It should be template_store_ref
>
> On 8/29/13 2:34 PM, "Wei ZHOU" <ustcweizhou@gmail.com> wrote:
>
> >It is the same issue to what I described in comment of CLOUDSTACK-4459:
> >
> >
> >Wei
> >Zhou<https://issues.apache.org/jira/secure/ViewProfile.jspa?name=weizhou
> >a
> >dded
> >a comment - 29/Aug/13
> >22:24
> >
> >Edison, after I redeploy the environment (clean db, restore devcloud to
> >original, reploydb), the system is up.
> >Th systemvms (ssvm and cpvm) are running and the state are up, but I can
> >not see tinylinux in template list. the template_host_ref table is empty.
> >
> >Wei
> >Zhou<https://issues.apache.org/jira/secure/ViewProfile.jspa?name=weizhou
> >a
> >dded
> >a comment - 29/Aug/13
> >23:10
> >
> >It works well on 4.2-forward branch.
> >
> >
> >
> >2013/8/29 Soheil Eizadi <seizadi@infoblox.com>
> >
> >> I migrated my development environment to the top of trunk which points
> >>to
> >> 4.3 now. I created a new CloudStack runtime environment running
> >>XenServer
> >> 6.2, for my Secondary Store I replicated another NFS Server that has
> >>images
> >> for preRC CloudStack version 4.2 SystemVM and TinyLinux on it.
> >>
> >> I have the CS running and it creates the SSVM and it is healthy, but I
> >> don't see any Templates in the UI, from the database I would expect to
> >>see
> >> the "tiny Linux" and "SystemVM Template" in the Templates view.
> >>
> >> I have restarted the management server and the problem is persistent.
> >>
> >> What is the next steps to debug this further?
> >> -Soheil
> >>
> >>
> >> Here is some logs below:
> >>
> >> From SSVM:
> >> /usr/local/cloud/systemvm/ssvm-check.sh
> >> ================================================
> >> First DNS server is  10.48.15.25
> >> PING 10.48.15.25 (10.48.15.25): 56 data bytes
> >> 64 bytes from 10.48.15.25: icmp_seq=0 ttl=64 time=1.038 ms
> >> 64 bytes from 10.48.15.25: icmp_seq=1 ttl=64 time=0.359 ms
> >> --- 10.48.15.25 ping statistics ---
> >> 2 packets transmitted, 2 packets received, 0% packet loss
> >> round-trip min/avg/max/stddev = 0.359/0.699/1.038/0.340 ms
> >> Good: Can ping DNS server
> >> ================================================
> >> Good: DNS resolves download.cloud.com
> >> ================================================
> >> NFS is currently mounted
> >> Mount point is /mnt/SecStorage/3667905e-f9c2-388e-a8c6-112cb96a98a9
> >> Good: Can write to mount point
> >> ================================================
> >> Management server is 10.48.15.10. Checking connectivity.
> >> Good: Can connect to management server port 8250
> >> ================================================
> >> Good: Java process is running
> >> ================================================
> >> Tests Complete. Look for ERROR or WARNING above.
> >>
> >> From MS log:
> >> WARN  [c.c.c.ClusterManagerImpl] (Cluster-Notification-1:null) Notifying
> >> management server join event took 21 ms
> >> INFO  [c.c.n.s.SecurityGroupListener]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Received a host startup
> >>notification
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Template Sync found routing-1
> >>already
> >> in the image store
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Template Sync did not find
> >>routing-3
> >> on image store 1, may request download based on available hypervisor
> >>types
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Template Sync did not find
> >> centos55-x86_64 on image store 1, may request download based on
> >>available
> >> hypervisor types
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Template Sync found tiny Linux
> >> already in the image store
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Template Sync did not find
> >> centos53-x64 on image store 1, may request download based on available
> >> hypervisor types
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Template Sync did not find
> >>routing-8
> >> on image store 1, may request download based on available hypervisor
> >>types
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Template Sync did not find
> >>routing-9
> >> on image store 1, may request download based on available hypervisor
> >>types
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Template Sync did not find
> >>routing-10
> >> on image store 1, may request download based on available hypervisor
> >>types
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Skip downloading template
> >>routing-10
> >> since current data center does not have hypervisor LXC
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Skip downloading template
> >>routing-9
> >> since current data center does not have hypervisor Hyperv
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Skip downloading template
> >>routing-8
> >> since current data center does not have hypervisor VMware
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Skip downloading template
> >>routing-3
> >> since current data center does not have hypervisor KVM
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Skip downloading template
> >> centos53-x64 since current data center does not have hypervisor VMware
> >> INFO  [o.a.c.s.i.TemplateServiceImpl]
> >> (AgentConnectTaskPool-2:ctx-b401ef43) Skip downloading template
> >> centos55-x86_64 since current data center does not have hypervisor KVM
> >> INFO  [c.c.c.AgentHookBase] (AgentConnectTaskPool-1:ctx-81d176bd)
> >> Successfully sent out command to start HTTP handling in console proxy
> >>agent
> >> INFO  [c.c.a.m.AgentManagerImpl] (ClusteredAgentManager Timer:null)
> >>Could
> >> not to find a Discoverer to load the resource: 2 for hypervisor type:
> >>null
> >> INFO  [c.c.a.m.DirectAgentAttache] (AgentTaskPool-2:ctx-0f928c9f)
> >> StartupAnswer received 2 Interval = 60
> >> INFO  [c.c.n.s.SecurityGroupListener] (AgentTaskPool-2:ctx-0f928c9f)
> >> Received a host startup notification
> >> INFO  [c.c.h.x.r.CitrixResourceBase] (AgentTaskPool-1:ctx-36b7c165)
> >> Private Network is cloud-public for host 10.48.15.20
> >> INFO  [c.c.h.x.r.CitrixResourceBase] (AgentTaskPool-1:ctx-36b7c165)
> >>Guest
> >> Network is cloud-public for host 10.48.15.20
> >> INFO  [c.c.h.x.r.CitrixResourceBase] (AgentTaskPool-1:ctx-36b7c165)
> >>Public
> >> Network is cloud-public for host 10.48.15.20
> >>
> >> Database:
> >>
> >> mysql> select * from template_host_ref;
> >> Empty set (0.00 sec)
> >>
> >> mysql> select * from template_store_ref;
> >>
> >>
> >>+----+----------+-------------+---------------------+--------------------
> >>-+--------+--------------+------------+------------+---------------+-----
> >>-----------+-----------+------------+------------------------------------
> >>------------------------+------------------------------------------------
> >>----------------------------------------+-------+-----------+---------+--
> >>------------+---------+---------+
> >> | id | store_id | template_id | created             | last_updated
> >>  | job_id | download_pct | size       | store_role | physical_size |
> >> download_state | error_str | local_path | install_path
> >>                           | url
> >>                                        | state | destroyed | is_copy |
> >> update_count | ref_cnt | updated |
> >>
> >>
> >>+----+----------+-------------+---------------------+--------------------
> >>-+--------+--------------+------------+------------+---------------+-----
> >>-----------+-----------+------------+------------------------------------
> >>------------------------+------------------------------------------------
> >>----------------------------------------+-------+-----------+---------+--
> >>------------+---------+---------+
> >> |  5 |        1 |           1 | 2013-08-28 23:10:50 | 2013-08-29
> >>21:01:19
> >> | NULL   |          100 | 2101252608 | Image      |    2101252608 |
> >> DOWNLOADED     | NULL      | NULL       |
> >> template/tmpl/1/1/170c3425-6078-479e-8843-3f8fdc02aaf3.vhd |
> >>
> >>
> http://download.cloud.com/templates/4.2/systemvmtemplate-2013-06-12-maste
> >>r-xen.vhd.bz2| Ready |         0 |       0 |            0 |       0 |
> >>NULL    |
> >> |  6 |        1 |           5 | 2013-08-29 18:16:53 | 2013-08-29
> >>21:01:19
> >> | NULL   |          100 |   52428800 | Image      |      50430464 |
> >> DOWNLOADED     | NULL      | NULL       |
> >> template/tmpl/1/5/0911ae22-350f-38f5-ad3e-423e7e5d6539.vhd |
> >> http://people.apache.org/~bhaisaab/vms/ttylinux_pv.vhd
> >>               | Ready |         0 |       0 |            0 |       0 |
> >>NULL
> >>    |
> >>
> >>
> >>+----+----------+-------------+---------------------+--------------------
> >>-+--------+--------------+------------+------------+---------------+-----
> >>-----------+-----------+------------+------------------------------------
> >>------------------------+------------------------------------------------
> >>----------------------------------------+-------+-----------+---------+--
> >>------------+---------+---------+
> >> 2 rows in set (0.00 sec)
> >>
> >>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message