cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Battala <rajesh.batt...@citrix.com>
Subject RE: Issue with deleting a volume that's never been attached to a VM
Date Tue, 06 Aug 2013 04:51:31 GMT
I able to reproduce it. 
Deleting unattached volume is coming back again. 
The removed column is not update in the db for this volume. 

Will create a major bug. 

*************************** 6. row ***************************
                        id: 6
                account_id: 2
                 domain_id: 1
                   pool_id: NULL
              last_pool_id: NULL
               instance_id: NULL
                 device_id: NULL
                      name: testVol
                      uuid: 3b008262-1c52-49a7-900d-b38fbf274e89
                      size: 5368709120
                    folder: NULL
                      path: NULL
                    pod_id: NULL
            data_center_id: 1
                iscsi_name: NULL
                   host_ip: NULL
               volume_type: DATADISK
                 pool_type: NULL
          disk_offering_id: 3
               template_id: NULL
first_snapshot_backup_uuid: NULL
               recreatable: 0
                   created: 2013-08-06 04:47:07
                  attached: NULL
                   updated: 2013-08-06 04:47:07
                   removed: NULL
                     state: Allocated
                chain_info: NULL
              update_count: 0
                 disk_type: NULL
    vm_snapshot_chain_size: NULL
                    iso_id: 0
            display_volume: 1
                    format: NULL
                  min_iops: NULL
                  max_iops: NULL
6 rows in set (0.00 sec)



-----Original Message-----
From: Rajesh Battala [mailto:rajesh.battala@citrix.com] 
Sent: Tuesday, August 6, 2013 10:15 AM
To: dev@cloudstack.apache.org
Subject: RE: Issue with deleting a volume that's never been attached to a VM

I will try on my setup 

-----Original Message-----
From: Mike Tutkowski [mailto:mike.tutkowski@solidfire.com] 
Sent: Tuesday, August 6, 2013 4:48 AM
To: dev@cloudstack.apache.org
Subject: Issue with deleting a volume that's never been attached to a VM

Hi,

I've noticed in 4.2 when I try to delete a volume that's never been attached to a VM that
CloudStack says the operation was successful and the GUI removes the volume from the table,
but when I refresh the table, the volume comes back.

Has anyone else noticed this behavior as of late?

If I attach the volume, then detach it, then delete it, all behaves as expected.

Thanks!

--
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the
cloud<http://solidfire.com/solution/overview/?video=play>
*(tm)*

Mime
View raw message