cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edison Su <Edison...@citrix.com>
Subject RE: Is the simulator broken?
Date Tue, 06 Aug 2013 20:32:00 GMT
Checked in a small fix: fe9f02c372be0f3b8e755afaea1fdb60d460fcbb on 4.2 branch, simulator works
for me now.

> -----Original Message-----
> From: Ian Duffy [mailto:ian@ianduffy.ie]
> Sent: Tuesday, August 06, 2013 11:51 AM
> To: dev@cloudstack.apache.org
> Subject: RE: Is the simulator broken?
> 
> Eventually got it running.
> Still hangs during marvin.setup though.
> On 6 Aug 2013 18:55, "Edison Su" <Edison.su@citrix.com> wrote:
> 
> > Can you try: mvn -P developer,systemvm,simulator  -D nonoss,simulator
> > clean install
> >
> >
> > > -----Original Message-----
> > > From: Ian Duffy [mailto:ian@ianduffy.ie]
> > > Sent: Tuesday, August 06, 2013 7:46 AM
> > > To: dev@cloudstack.apache.org
> > > Subject: Re: Is the simulator broken?
> > >
> > > Yeah complied with:
> > >
> > > mvn -P developer,systemvm  -D nonoss,simulator clean install
> > >
> > >
> > > Will retry...
> > >
> > > On 6 August 2013 14:43, Prasanna Santhanam <tsp@apache.org> wrote:
> > > > I haven't tried on master but it seems to be broken on 4.2:
> > > >
> > > > I see this in the management server log when starting systemVMs
> > > > https://gist.github.com/vogxn/6164508
> > > >
> > > > But that error you showed just means the simulator jar was not
> > > > found in the classpath. Did you build with the -Dsimulator switch?
> > > >
> > > > On Tue, Aug 06, 2013 at 12:51:41PM +0100, Ian Duffy wrote:
> > > >> Hi,
> > > >>
> > > >> Is the simulator broken?
> > > >>
> > > >> Trying to run
> > > >>
> > > >> nosetests -v --with-marvin --marvin-config=setup/dev/advanced.cfg
> > > >> -w /tmp
> > > >>
> > > >> and getting
> > > >>
> > > >> Traceback (most recent call last):
> > > >>   File "/opt/python/bin/nosetests", line 9, in <module>
> > > >>     load_entry_point('nose==1.3.0', 'console_scripts', 'nosetests')()
> > > >>   File "/opt/python/lib/python2.7/site-packages/nose/core.py",
> > > >> line 118, in __init__
> > > >>     **extra_args)
> > > >>   File "/opt/python/lib/python2.7/unittest/main.py", line 94, in
> > __init__
> > > >>     self.parseArgs(argv)
> > > >>   File "/opt/python/lib/python2.7/site-packages/nose/core.py",
> > > >> line 135, in parseArgs
> > > >>     self.config.configure(argv, doc=self.usage())
> > > >>   File "/opt/python/lib/python2.7/site-packages/nose/config.py",
> > > >> line 344, in configure
> > > >>     self.plugins.configure(options, self)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-
> packages/nose/plugins/manager.py"
> > > >> ,
> > > >> line 284, in configure
> > > >>     cfg(options, config)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-
> packages/nose/plugins/manager.py"
> > > >> ,
> > > >> line 99, in __call__
> > > >>     return self.call(*arg, **kw)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-
> packages/nose/plugins/manager.py"
> > > >> ,
> > > >> line 167, in simple
> > > >>     result = meth(*arg, **kw)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-packages/marvin/marvinPlugin.py",
> > > >> line 68, in configure
> > > >>     deploy.loadCfg() if options.load else deploy.deploy()
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-packages/marvin/deployDataCenter.
> > > >> py",
> > > >> line 576, in deploy
> > > >>     self.createZones(self.config.zones)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-packages/marvin/deployDataCenter.
> > > >> py",
> > > >> line 408, in createZones
> > > >>     self.createpods(zone.pods, zoneId)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-packages/marvin/deployDataCenter.
> > > >> py",
> > > >> line 126, in createpods
> > > >>     vmwareDc=pod.vmwaredc)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-packages/marvin/deployDataCenter.
> > > >> py",
> > > >> line 84, in createClusters
> > > >>     clusterresponse = self.apiClient.addCluster(clustercmd)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-packages/marvin/cloudstackAPI/clo
> > > >> udst
> > > >> ackAPIClient.py",
> > > >> line 1378, in addCluster
> > > >>     response = self.connection.marvin_request(command,
> > > >> response_type=response, method=method)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-
> packages/marvin/cloudstackConnection.
> > > >> py",
> > > >> line 222, in marvin_request
> > > >>     response = jsonHelper.getResultObj(response.json(),
> response_type)
> > > >>   File
> > > >> "/opt/python/lib/python2.7/site-packages/marvin/jsonHelper.py",
> > > >> line 148, in getResultObj
> > > >>     raise cloudstackException.cloudstackAPIException(respname,
> > > >> errMsg)
> > > >> marvin.cloudstackException.cloudstackAPIException: Execute cmd:
> > > >> addcluster failed, due to: errorCode: 431, errorText:Could not
> > > >> find corresponding resource manager for simulator
> > > >
> > > > --
> > > > Prasanna.,
> > > >
> > > > ------------------------
> > > > Powered by BigRock.com
> > > >
> >
Mime
View raw message