cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Burwell <jburw...@basho.com>
Subject Re: AWS SDK version for object store
Date Mon, 08 Jul 2013 17:28:50 GMT
Edison,

I vote to take the latest stable from Amazon.  In addition to keeping up with security and
bug fixes, it also ensures that we stay in sync with any "refinements" that Amazon introduces
as part of their continuous improvement/deployment model.

Thanks,
-John

On Jul 8, 2013, at 1:26 PM, Edison Su <Edison.su@citrix.com> wrote:

> From CloudStack point of view, there should be minor changes in order to adapt to latest
AWS SDK. What's your guys option, John, Thomas? Is it ok to upgrade to latest SDK?
> 
>> -----Original Message-----
>> From: Prasanna Santhanam [mailto:tsp@apache.org]
>> Sent: Friday, July 05, 2013 5:58 AM
>> To: dev@cloudstack.apache.org
>> Subject: AWS SDK version for object store
>> 
>> There was another issue I found today with the SDK v1.3.21. It appears I can't
>> use periods in the name of a bucket. I see an SSL Exception when this is done
>> [1]. The bug is fixed in the v1.3.22. There are also couple of other issues fixed
>> related to s3 on the latest version of the SDK.  Is there any reason not to use
>> the latest stable SDK version in CloudStack? IOW, why did we choose the
>> v1.3.21?
>> 
>> [1] http://issues.apache.org/jira/browse/CLOUDSTACK-3374
>> 
>> --
>> Prasanna.,
>> 
>> ------------------------
>> Powered by BigRock.com
> 


Mime
View raw message