cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijayendra Bhamidipati <vijayendra.bhamidip...@citrix.com>
Subject RE: deploydb jdbc/mysql connector error?
Date Mon, 29 Jul 2013 19:53:09 GMT
Prachi and I had a look at this, I should have pasted the entire output of the deploydb command
- in Prachi's env we see that the mysql-connector.jar is getting copied over to the deps/
directory, but I see this warning in the beginning when I run deploydb:


[WARNING] Some problems were encountered while building the effective model for org.apache.cloudstack:cloud-api:jar:4.2.0-SNAPSHOT
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
must be unique: mysql:mysql-connector-java:jar -> duplicate declaration of version ${cs.mysql.version}
@ org.apache.cloudstack:cloudstack:4.2.0-SNAPSHOT, /root/mywork/cloudstack/asf/latest/cloudstack/pom.xml,
line 278, column 19
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.cloudstack:cloudstack:pom:4.2.0-SNAPSHOT
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
must be unique: mysql:mysql-connector-java:jar -> duplicate declaration of version ${cs.mysql.version}
@ line 278, column 19
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability
of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed
projects.
[WARNING]


Any idea why this is happening?


The complete output is pasted below:

[root@vijay-vm1 cloudstack]# mvn -e -P developer -pl developer -Ddeploydb
Listening for transport dt_socket at address: 8787
[INFO] Error stacktraces are turned on.
[INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.cloudstack:cloud-api:jar:4.2.0-SNAPSHOT
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
must be unique: mysql:mysql-connector-java:jar -> duplicate declaration of version ${cs.mysql.version}
@ org.apache.cloudstack:cloudstack:4.2.0-SNAPSHOT, /root/mywork/cloudstack/asf/latest/cloudstack/pom.xml,
line 278, column 19
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.cloudstack:cloudstack:pom:4.2.0-SNAPSHOT
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
must be unique: mysql:mysql-connector-java:jar -> duplicate declaration of version ${cs.mysql.version}
@ line 278, column 19
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability
of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed
projects.
[WARNING]
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building Apache CloudStack Developer Mode 4.2.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- properties-maven-plugin:1.0-alpha-2:read-project-properties (default) @ cloud-developer
---
[INFO]
[INFO] --- maven-remote-resources-plugin:1.3:process (default) @ cloud-developer ---
[INFO]
[INFO] --- maven-antrun-plugin:1.7:run (default) @ cloud-developer ---
[INFO] Executing tasks

main:
[INFO] Executed tasks
[INFO]
[INFO] >>> exec-maven-plugin:1.2.1:java (create-schema) @ cloud-developer >>>
[INFO]
[INFO] <<< exec-maven-plugin:1.2.1:java (create-schema) @ cloud-developer <<<
[INFO]
[INFO] --- exec-maven-plugin:1.2.1:java (create-schema) @ cloud-developer ---
log4j:WARN No appenders could be found for logger (org.springframework.core.env.StandardEnvironment).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
========> WARNING: Provided file does not exist: /root/mywork/cloudstack/asf/latest/cloudstack/developer/developer-prefill.sql.override
========> Initializing database=cloud with host=localhost port=3306 username=cloud password=cloud
============> Running query: drop database if exists `cloud`
SQL exception in trying initDB: java.sql.SQLException: No suitable driver found for jdbc:mysql://localhost:3306/
[root@vijay-vm1 cloudstack]#


Regards,
Vijay





-----Original Message-----
From: Vijayendra Bhamidipati [mailto:vijayendra.bhamidipati@citrix.com] 
Sent: Monday, July 29, 2013 12:32 PM
To: dev@cloudstack.apache.org
Subject: deploydb jdbc/mysql connector error?

After rebasing my code against the latest master/4.2, I'm running into this error when doing
a " mvn -e -P developer -pl developer -Ddeploydb " across master and 4.2 :

========> WARNING: Provided file does not exist: /root/mywork/cloudstack/asf/latest/cloudstack/developer/developer-prefill.sql.override
========> Initializing database=cloud with host=localhost port=3306 username=cloud password=cloud
============> Running query: drop database if exists `cloud` SQL exception in trying initDB:
java.sql.SQLException: No suitable driver found for jdbc:mysql://localhost:3306/
[root@vijay-vm1 cloudstack]#


Is anyone else also seeing this? If not, has anyone seen this and can suggest a resolution??

I tried the operation on a clean new workspace and still see this error. I don't think it
has anything to do with any recent checkin - something must've changed in my setup, but again
I didn't do anything out of the ordinary.

Thanks!
Regards,
Vijay

Mime
View raw message