cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Likitha Shetty <likitha.she...@citrix.com>
Subject RE: [AWS-API] User registration failed with http error code: 404
Date Thu, 25 Jul 2013 11:45:40 GMT
Are you trying http://lcoalhost:7080/awsapi ?

Thanks,
Likitha

From: Dharmesh Kakadia [mailto:dhkakadia@gmail.com]
Sent: Thursday, July 25, 2013 5:06 PM
To: dev; Likitha Shetty
Cc: Sebastien Goasguen
Subject: Re: [AWS-API] User registration failed with http error code: 404

Thanks for the quick reply.

But I am seeing 404 on /awsapi URI. I am running this in devcloud setup on localhost.
Is the region name "AmazonEC2" correct ? What I am missing ?

Here is my code.

import boto
import boto.ec2

region = boto.ec2.regioninfo.RegionInfo(name="AmazonEC2", endpoint="localhost")

conn = boto.connect_ec2(aws_access_key_id="DqZOJMYHZMn-UCJWYmeIfLElCM4QupmAPgD7Azh7itYZMtOgTqCbichKyxyBxn6qvnQtKURYd7DN-8KDbOMrhA",
aws_secret_access_key="QpaT9QSyRLPTriqlf4yfvkxepyZMDmdx4z_4Bi6HFTBLnL_o0l3SDXifBIDwMc3qOM1uFA6pWJ6pl2_n6KnBOQ",
is_secure=False, region=region, port=8080, path="/awsapi", api_version="2012-08-15")

instance = conn.get_all_images()

Thanks,
Dharmesh

On Thu, Jul 25, 2013 at 3:52 PM, Likitha Shetty <likitha.shetty@citrix.com<mailto:likitha.shetty@citrix.com>>
wrote:
Dharmesh,

Since you are using the Boto client I presume you are trying to make EC2 Query API calls.
To make Query API calls you don't need to register the user.
See if this helps - https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=30736866.

Thanks,
Likitha

>-----Original Message-----
>From: Dharmesh Kakadia [mailto:dhkakadia@gmail.com<mailto:dhkakadia@gmail.com>]
>Sent: Thursday, July 25, 2013 3:45 PM
>To: dev; Sebastien Goasguen
>Subject: [AWS-API] User registration failed with http error code: 404
>
>Hi,
>
>I am trying to use aws-api with boto.
>
>I am following
>http://www.slideshare.net/sebastiengoasguen/cloudstack-ec2-configuration.
>
>but on slide 8, the command reads "cloud-bridge-register". If I am understanding
>correctly, it should be "cloudstack-aws-api-register"  as noted here :
>http://cloudstack.apache.org/docs/en-
>US/Apache_CloudStack/4.0.2/html/Installation_Guide/aws-ec2-user-setup.html
>.
>
>But I while using the "cloudstack-aws-api-register" command I am getting "User
>registration failed with http error code: 404".
>
>My mgmt server is running on localhost and the url I am using with above
>command is "http://lcoalhost:8080/awsapi".
>
>Any clue ?
>
>Thanks,
>Dharmesh


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message